MT7688 connects to a WiFi router with BSSID


I'm using a MT7688 with MTK official FW

This utilizes their own propriety wifi driver. What I'm trying to do here is to connect to a specific WiFi router with BSSID information. (I have multiple APs with the same SSID). I tried in /etc/config/wireless with option BSSID but it fails to connect.

I also found this post from MTK, which suggests I couldn't do this.

" For connecting to an AP with a hidden SSID, edit the /etc/config/wireless file and set the bssid and ssid fileds according to the BSSID and SSID information of the AP. For connecting to an AP without a hidden SSID, make sure the bssid filed to be empty."

Any ideas how to do this? Thanks!

@yesheng, welcome to the community!

  • Just enter the BSSID...if you entered it correctly, it should work.
  • You can show us your /etc/config/wireless omiting keys for a more in-depth look by the community



  • How is this OpenWrt related???
  • If it is OpenWrt related, can you identify that supported device, please?

Hi lleachii,

Thanks for your help. Maybe I wasn't clear in my first post, this device is MT7688 Not sure if I understand you correctly. The official FW from MTK is based on OpenWRT. Please let me know if this is inappropriate here. I'll remove it from here.


my configuration is the following:

config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'TW'
        option hwmode '11g'
        option htmode 'HT40'
        option channel 'auto'
        option disabled '0'
        option linkit_mode 'sta'

config wifi-iface 'ap'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option encryption 'none'
        option ssid 'LinkIt_Smart_7688_1B1801'
        option seq '1'

config wifi-iface 'sta'
        option device 'radio0'
        option mode 'sta'
        option network 'wan'
        option ifname 'apcli0'
        option led 'mediatek:orange:wifi'
        option encryption 'psk2'
        option ssid 'my_essid'
        option key 'mykey'

I tried adding an option bssid 'my_bssid' but it doesn't connect at all.


Not sure how you expect OpenWrt to support software it didn't build and doesn't have access to.

If OpenWrt supports it, please provide the link from here:

Use the correct BSSID. Simple.

Got it, thanks for all the information, and sorry for the inconvenience.