Mt7621 (er605) + vlan dsa

Hi everyone,

I started a new config (new clean install) with TpLink-ER605v2 (MT7621) configuring WAN/Internal Network/DHCP/DDNS... everything working like a charm.

After reading https://openwrt.org/docs/guide-user/network/dsa/converting-to-dsa I tried to config a very basic VLAN network (Vlan1 for my devices, and Vlan10 for IOT devices).

The problem comes when I enable "Vlan Filtering" (in device br-lan) and I try to assing vlans (as always I did with a non-DSA firmware - In Luci -> Switch Config). The router becomes unresponsive, no ping.. nothing.. I have to wait a minute for auto revert config.

I'm missing something?

root@ER605:~# uname -a
Linux ER605 5.15.118 #0 SMP Mon Jun 26 11:20:39 2023 mips GNU/Linux
root@ER605:~#

The network config is very simple:

root@ER605:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7f:7cbf:181c::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        list ports 'eth1'
        list ports 'eth2'

config device
        option name 'eth1'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config device
        option name 'eth2'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config device
        option name 'eth3'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config device
        option name 'eth4'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config device
        option type '8021q'
        option ifname 'eth0'
        option vid '6'
        option name 'eth0.6'
        option ipv6 '0'

config interface 'Internet'
        option proto 'pppoe'
        option device 'eth0.6'
        option username 'XXXXXX'
        option password 'xxxxx'
        option ipv6 '0'
        option delegate '0'

root@ER605:~#

Any idea will be welcome!!

Thanks for your help,

When you enable Vlan Filtering, you also have to move your "LAN" interface to br-lan.1 (or another VLAN) at the same time. In OpenWRT, local bridge interface is tagged for all VLANs marked as "Local".

Thanks @zekica I'll try.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.