Mt7601 usb dongle

Hi, im using an x86 openwrt router, i've bought USB Dongle with mt7601, installed kmod-mt7601u and mt7601u-firmware it apper on wireless, but when i try enable it, it says Wireless is not associated, it's also work on Scanning.. (i know using usb dongles dumb idea, but it for the first time only..)

root@OpenWrt:~# uci export network
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxx:xxxx:xxxx::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option proto 'pppoe'
        option password 'fpdxxxxx'
        option ipv6 'auto'
        option username 'v41xxxxx'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config interface 'Router_lan'
        option ifname 'eth2'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
[   10.822940] mt7601u 3-1:1.0: ASIC revision: 76010001 MAC revision: 76010500
[   10.873813] mt7601u 3-1:1.0: EEPROM ver:0d fae:00
[   11.090169] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   11.090364] usbcore: registered new interface driver mt7601u

Any station will by default show 'Not associated' as long as you don't have any clients connected to it. Did you try connecting to it?

Can't connect, dont even see it in networks on my phone

Did you install the wpad package and secure your AP with wpa or wpa-2?

Yes, i've also tryed Hostpad instead of wpad and i also tryed this usb-dongle on win-10 it works perfect as AP! Feels like i missed something, worst thing it works on Scan and can connect, AP isn't available..

I don't understand exactly what is your problem, but you said you don't see the network listed on your phone and you have checked hide ESSID.
What about unchecking it?

Its's Unchecked, i've just trying ANYthing including straight connect.., i've also reinstalled it and driver couple times, so everytime it was unchecked. sorry!

I'm quite sure it's a missing module, but honestly I don't know what to install.
nonetheless you might try this:

opkg list | grep kmod | grep usb

after seeing your second post I just want to make sure you installed kmod-mt76x02-usb and inserted the necessary modules.

i've tryed install kmod-mt76x02-usb but not helped, why install it's while my usb dongle is 7601, not 02? anyway didnt help..

Sorry you are right. I don't have more ideas.

The mt7601u kernel driver does not support AP mode yet.

or you can try that: https://github.com/olivluca/mt7601-openwrt

can you explain me how to use it? should i build it?

sure. you should try to make the openwrt version drive from the linux kernel drive