Mt76 driver - replacement [for test]

Hi, Because of bad stability of open source drivers (mt76), and more free time, I tried to do a build of official Mediatek driver for MT7612E, with support for cfg80211 (fullmac driver)

All these was ported to OpenWRT 19.07.2, but currently I do not have free device for test. Could someone help me to test some basic things:

  • if module loads
  • if radio is detected by iw
  • if it is able to work with hostapd and start open network
  • if it is able to setup wpa2 ap
  • if it is able to run vap.

I attach a kernel module for test, it should run on 19.07.2 OpenWRT for mt7621 cpu.

link to rlt_wifi.ko https://easyupload.io/cv56ew

How to load:

modprobe cfg80211
insmod rlt_wifi.ko

1 Like

days ago I tried to compile an image for netgear r6260, with mt7603 open driver and mt7615 with mediatek drivers closed, the packages were compiled correctly but I was unable to operate the mt7615 radio. do you also have some mt7615.ko?
not sure about all the package needed for closed mediatek driver to work.

Yes, possibly. But I am currently unsure about configuration. If you test it, could you specify your configuration (what is first, second and third radio on your platform - I need the offsets for configuration for each hw, stored in flash)

i have no idea i have try with mtk plugin, uci2dat, wificonf, nothing work, i can see the radio ra0 in mtk plugin, but don't work, i remember that the mac address of the radio was 00:00:00:00:00:00 all zero, from mtk plugin the radio looks up, but my devices cannot see the ssid. mabie my problem is that the offsets, how i can check that?
device is netgear r6260.
my device have only two radio mt7603 and mt7615, mt7603 i compiled with open driver, mt7615 with closed mtk driver. i used the defaul configuration for mt7615 radio, just enabled it by clicking reload.

i also flashad an r6350 immage 19.07.1 to my r6260 because the kernel is 4,14.167, i used the nossiac .ko for kernel 4,14.167 and even that have not worked for me.

/usr/lib/lua/luci/template.lua:97: Failed to execute template 'admin_mtk/mtk_wifi_dev_cfg'.
A runtime error occurred: /usr/lib/lua/mtkwifi.lua:491: Interrupted system call
stack traceback:
	[C]: in function '(for generator)'
	/usr/lib/lua/mtkwifi.lua:491: in function 'search_dev_and_profile_orig'
	/usr/lib/lua/mtkwifi.lua:553: in function 'search_dev_and_profile'
	/usr/lib/lua/mtkwifi.lua:674: in function 'get_all_devs'
	[string "/usr/lib/lua/luci/view/admin_mtk/mtk_wifi_d..."]:7: in main chunk
stack traceback:
	[C]: in function 'error'
	/usr/lib/lua/luci/template.lua:97: in function 
	(tail call): ?
	/usr/lib/lua/luci/dispatcher.lua:924: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:441: in function 

some help with this? i do not understand

Hi again,

My idea is to use just raw OpenWRT without mediatek modifications (luci); my work is to use existing 802.11 stack, but with mediatek driver.

I post driver to mt7603, to tests:
https://easyupload.io/bzuwtf

Instructions:

  • use OpenWRT 19.07.2 - module is compiled for only 19.07.2 release
  • unload existing drivers and erase wireless configurations
  • load only cfg80211 module
  • load this module from link
  • OpenWRT should detect mt7603 and I wait for tests

this is really drive me crazy i cannot make it work, i cannot test it on 19.07.2 no immag3e for my device. i wan try to make mt7615 to work.