MR12 wifi traffic not passing on br-lan

I picked up an MR12 from someone to play with and flashed LEDE on it ( LEDE Reboot 17.01.4 r3560-79f57e422d to be specific) but for the life of me I can't seem to get the wifi to pass traffic on the br-lan interface. I can ping the AP when connected to the wifi interface but nothing else, and I can't figure why because i've disabled both the firewall and dnsmasq so it should be a "dumb" AP at this point. I have also set the MAC as mentioned in the guide here which is the only thing I was able to find that might be an issue. I've spent hours messing with every config and google suggestion I can find and i'm just stumped. Is there something i'm missing somewhere?

Post your network and wifi config files here, please.

Sorry, I should have done that in my OP. Here they are:
network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5a:68f1:fc49::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.0.13'
        option gateway '192.168.0.1'
        option broadcast '192.168.0.255'
        option dns '192.168.0.2 192.168.0.3'

and here is wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'LEDE'
        option network 'lan'

It's a fresh install, all I did was change the IP address on the lan interface to match my network and add a new wireless AP - both through the web interface.

That config seems fine to me...
Did you try both ehternet ports?

I did, although there was no "eth1" listed on the web interface for the 10/100 port so I tried setting one up manually but i'm not sure I did it right. ifconfig from ssh also didn't list an eth1 (just eth0, wifi, and loopback)