Mount FAT32 partition. Confused for NTFS?

Hello,

I mount my NTFS disks using the following, and it works

mount.ntfs -o "rw,sync" "$(blkid --uuid 01D1CCB308243D20)" "/HP"

I now want to mount a FAT32 one-partition disk. I use the following

mount -o "rw,sync" "$(blkid --uuid 8457-AE8F)" "/TSH"

The partition mounts (it takes a second or so), I can access it and I can also see it in the Mounting Points page in LuCI, but it also throws the following when I mount it (and yes, it gives me the message twice):

Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Why does it think it's NTFS? Block info shows it as vfat.

If I try mount -t vfat -o "rw,sync" "$(blkid --uuid 8457-AE8F)" "/TSH" it works without complaining. But why if I don't specify the FSTYPE it presumes it's NTFS?

The BusyBox mount has limited functionality.
It supports less options than the one from util-linux package.
Probably its filesystem detection abilities are limited as well.

1 Like

It may also depend on the method how the filesystem was created, i.e. it seems working for natively formatted vfat:

opkg update
opkg install dosfstools kmod-fs-vfat
dd if=/dev/zero of=vfat.img bs=1M count=100
mkfs.fat vfat.img
mount vfat.img /mnt

Hm, it stops working if you install the ntfs-3g-utils package.
So, this looks like a bug.

1 Like

I’ve always assumed that mount required explicit type if not a primary, native file system.

I have kmod-fs-ntfs and ntfs-3g packages installed. I can confirm that ntfs-3g seems to be the cause of this ambiguous NTFS error message when using mount on a FAT32 paritionwithout specifying vfat as the FS. The partitions still mounts though.

kmod-fs-ntfs on its own doesn't seem to be a problem.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.