Mount an external CD ROM via USB

I recycled an old Zyxel NAS with current OpenWrt and got it to work with 4TByte disk for use as media center. Now I tried to add (aka mount) an external CD ROM drive via USB to speed up the transfer of my CD ROM collection to the NAS - and here I fail. I proceeded according to mount the HD drive, added some recommended drivers, I know the mount point (sr0) - however the device keeps showing als "not present".
Any hint to proceed?
Cheers Uli

opkg list-installed | grep iso | grep kmod
opkg list-installed | grep usb

I tried to mount the CD ROM as /mnt/cdrom

root@OpenWrt:~# ls /mnt/cdrom
root@OpenWrt:~# ls /dev/sr0

Here are the results of your suggestions:

root@OpenWrt:~# lsusb
-ash: lsusb: not found
root@OpenWrt:~# ls usb
ls: usb: No such file or directory
root@OpenWrt:~# ls cdrom
ls: cdrom: No such file or directory
root@OpenWrt:~# opkg list-installed|grep iso|grep kmod
kmod-nls-iso8859-1 - 4.14.95-1
kmod-nls-iso8859-13 - 4.14.95-1
kmod-nls-iso8859-15 - 4.14.95-1
root@OpenWrt:~# opkg list-installed|grep usb
kmod-usb-core - 4.14.95-1
kmod-usb-storage - 4.14.95-1
kmod-usb-storage-extras - 4.14.95-1
kmod-usb-storage-uas - 4.14.95-1

Cheers Uli

opkg update
opkg install kmod-fs-isofs
opkg install usbutils
mkdir -p /mnt/cdrom; mount /dev/sr0 /mnt/cdrom; ls /mnt/cdrom

note: some platforms need one or some of
funny your hard drive work without at least one of them... maybe my ignorance or perhaps list-installed wont show built-ins or something.

1 Like

now it seems to work fine - the kernel module and the usbutils were missing. Thanks for your help. The HD is connected via SATA, therefor no need for USB.
Cheer Uli

If your problem is solved, please consider marking the topic as [Solved] (Click the pencil behind the topic...).

1 Like