ModemManager LUCI connection info

I'm using a PCI 5G module in a x86 openWRT. Previously i was using another 4G modem with QMI protocol, and I was able to see connection info such as RSRP, RSSI, SINR, RSRQ, but above all the connected band info (primary and CA) using the luci-app-3ginfo-lite package. Moreover, with luci-app-modemband I was able to change band directly from LUCI.
Is there an alternative for modem using ModemManager?

You can check this package:
luci-app-mmconfig

and
modem-support-full.zip

I don't know any other packages for modems.

1 Like

I don’t know if it supports PCI module and 5G band. I have found your packages and I hope you will make them available for PCI 5G modem such as T99W175 X55. I have tried the latest version that should support it, but it doesn’t work in my case

I also don't know if the packages I sent will be compatible.

As for my packages. The problem is that your modem does not have a communication port. I don't know if it needs to be turned on with the at command.

I don't know what you have tried so far, or maybe you have already switched modem somehow.

Which communication port do you need to use to communicate with the PCI modem?

Modem should respond to command sms_tool -d /dev/wwan0at0 at "at^debug?" so the communication port is /dev/wwan0at0.

Question is why your modem does not respond to at commands. There are many topics on the internet with this question about the communication port. There are also many suggested solutions. I don't know what you tried.

It is possible that the modem responds to at commands on a different port /dev/wwan0mbim0? I don't have modem, so I can only speculate.

Maybe it depends on firmware version of the module or customer brand. In the next days, I will try again the T99 modem and I will let you know what I discover. I may update it to the latest firmware, but it's not easy because I need windows and there is risk to brick the module.

The thing I'm sure is that the module responds to at commands using mmcli -m 0 --command="AT^DEBUG?"

You can also check if there will be a response to commands:
sms_tool -d /dev/wwan0mbim0 at "at^debug?"
sms_tool -d /dev/wwan0qcdm0 at "at^debug?"

root@OpenWrt:~# sms_tool -d /dev/wwan0at0 at "at^debug?"
^C
root@OpenWrt:~# sms_tool -d /dev/wwan0mbim0 at "at^debug?"
tcgetattr(/dev/wwan0mbim0)
tcsetattr(/dev/wwan0mbim0)

The modem doesn't respond to AT command with sms_tool

If I disable modemmanager, then sms_tool receive answer from AT command, but internet is not working.

I have discovered the problem. I was using modemmanager with debug option enabled, so he was able to use the AT command port. If I run modemmanager without debug mode I can use sms_tool to send AT command.

EDIT: I received one answer with sms_tool, but then it stopped working and I get: no response from modem

Problem is that two applications want to communicate with modem at the same time. In this case, there will be no response or modem will respond with delays or even errors.

Edit:
I'm surprised that no one has written an MM package for LuCI yet. With such a large number of users.

So if I use modemmanager, the only way to send AT command is with mmcli?

That would be best.

Can 3ginfo now read data from modem?

No, even without modemmanager debug mode, sms_tool is not able to read data from the modem because it seems that modemmanager lock the AT port for itself

So there are two solutions. Someone needs to write a LuCI package for MM (the easier way) or modem needs to get support for the qmi/mbim or other dedicated protocol (to gain port access and be able to send at commands).