Mobile hotspot TTL firewall settings

So I’m using my archer c7 v2 openwrt router as a repeater for my T-Mobile hotspot, I have a jailbroken iPhone but setting the ttl to 65 on the phone doesn’t seem to work, so I went with doing this on the router instead.

I put “ iptables -t mangle -A POSTROUTING -j TTL --ttl-set 65” in to the custom firewall settings and it’s working for all devices connected except for my PS5, I found someone with this same issue on another site and this is what was suggested below.


Link: https://wirelessjoint.com/viewtopic.php?t=2689#top

I tried what was suggested but it did not work, is he right about data leaking through ipv6 even tho my hotspot is using ipv4? Any suggestions on what I should do? Also what would be the best approach in narrowing down the issue?

Try

net.ipv4.ip_default_ttl=65
net.ipv6.ip_default_ttl=65

In /etc/sysctl.conf

Ok thanx, to add those lines I have to use the sysctl -w command right? I found this guide https://www.wirelessjoint.com/viewtopic.php?t=3498 and one of the packages it says to install is iptables-mod-physdev, but when I run “opkg list” it’s not there, how can I install this package?

you can vi it, or echo "...." >> /etc/sysctl.conf

the module might already be in the kernel, trial and error.