I have a TP-Link Archer C6 configured ok, now i want to set the same config on a x86 but the x86 doesnt have the "Switch" section.
x86:
Archer C6:
I installed "swconfig" in the x86 but still missing. Why?
I have a TP-Link Archer C6 configured ok, now i want to set the same config on a x86 but the x86 doesnt have the "Switch" section.
x86:
Archer C6:
I installed "swconfig" in the x86 but still missing. Why?
hi @Exio0
start from beginning
swconfig is utility for managing switch chips in routers
it is old piece of software and in new releases it is mostly replaced with DSA drivers
anyway ... swconfig ... your question does not make sense because PC does not have switch chip, so there could be no use of swconfig and without swconfig, there is no "switch section" in Luci
but ...
you could still apply all VLANs magic on x86 PC following any DSA tutorial
yes, it is confusing, why DSA when there is no switch chip but it is one of nice things with DSA, it will unify things and make life easy, you don't need to know what is under the hub
x86 hardware is almost always multiple ports each with an independent direct connection to the CPU. All "switching" between eth ports must be handled by software bridge(s) in the kernel instead of hardware paths. An x86 CPU is fast enough to do this with a very minimal burden.
With independent CPU ports you can also create independent bridges such as br-vlan10 with members eth0.10 and eth1, br-vlan20 with members eth0.20 and eth2, etc. In this scenario eth0 would be a trunk port with both vlans tagged, eth1 would be untagged access to vlan 10, eth2 would be untagged access to vlan 20. This is the old way of doing it, from before VLANs were possible inside a bridge. I find it conceptually easier to understand, however it is not portable to DSA hardware.
here is example with two nic (eth0 & eth1)
eth0 is trunk
eth1 is access (native, untagged) on vlan10
First of all, thanks for your answer.
All i wanted to do is assign the VLAN 20 to wan interface as i did on a router...
I have done this
I have configured that wan interface like this:
In a router, i have done the same and it worked, what im i missing?
I just followed this guide
https://openwrt.org/docs/guide-user/virtualization/virtualbox-vm
Hi @Exio0
it is unclear from your screenshots what have you done
so, please connect to your OWRT with SSH and then
cat /etc/config/network
paste output here in preformated tags "<" and "/>"
Here you have, @NPeca75 :
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd2f:8a0b:5c99::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'mng'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.56.2'
option netmask '255.255.255.0'
config interface 'wan'
option device 'eth1.20'
option proto 'pppoe'
option username 'xxxxxxxxx@digi'
option password 'xxxxxxxx'
option ipv6 'auto'
config interface 'lan'
option device 'eth2'
option proto 'static'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option ipaddr '192.168.1.2'
config device
option type '8021q'
option ifname 'eth1'
option vid '20'
option name 'eth1.20'
root@OpenWrt:
Hi, i have some problems connecting to PPPoE. I already have configured PPPoE in a router with OpenWRT but that router doesnt have enough hardware to reach the 500mbps of the ISP, then i wanted to make a VM with VBox in a x86 PC.
I have this in /etc/config/network:
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd2f:8a0b:5c99::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'mng'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.56.2'
option netmask '255.255.255.0'
config interface 'wan'
option device 'eth1.20'
option proto 'pppoe'
option username 'xxxxxxxxx@digi'
option password 'xxxxxxxx'
option ipv6 'auto'
config interface 'lan'
option device 'eth2'
option proto 'static'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option ipaddr '192.168.1.2'
config device
option type '8021q'
option ifname 'eth1'
option vid '20'
option name 'eth1.20'
root@OpenWrt:
but im getting the error "Connection attempt failed"
I have configured the ifaces as this guide says:
https://openwrt.org/docs/guide-user/virtualization/virtualbox-vm
Can someone give me a hand please?
maybe your ISP have some MAC restriction, so it will be useful to copy WAN mac from old device ?
hmm dont think so @NPeca75, i have configured an OpenWRT with PPPoE before and all ok. The thing it was a router with the Swich section and the VM doesnt have it as i mentioned here Missing "Switch" section in openwrt-23.05.2-x86-64-generic-ext4-combined.img?. Once solved, I thought the configuration would go well and I would have no problems but here i am...
Your ISP expects VLAN 20?
Yep, VLAN 20
Is this the main router?
If so... why is there a different gateway here?
Have you tried to edit /etc/ppp/options ?
Hereis mine:
root@turris:~# cat /etc/ppp/options
debug # this will cause more information show up in the OpenWrt log
logfile /srv/pppd_logs/ppp.log # and this will also dump this into this logfile, adjust for your system
noipdefault
noaccomp
nopcomp
nocrtscts
lock
maxfail 0
It will be the main, but first, i have to do tests. Once all config is ok, i will change the gateway and IP addr
What tests are you doing? The fact that it is not currently the main router means that only certain tests can be done.
How is it currently connected and what are the tests that have succeeded and what has failed?
I have opened this topic to solve the pppoe problem. Switch one is solved as @NPeca75 said. I dont want to mix things.
https://forum.openwrt.org/t/pppoe-not-connecting/190972/5
Is this a real PC ? or some kind of VM ?
Is this device directly connected to the ISP at this point? You can't test the PPPoE connection unless eth1 is directly connected to the ISP modem.