Missing packages in 22.03.5 (strongswan*)


I've just upgraded my router from 21.02.03 -> 22.3.5 (Linksys EA6350v3) and I seem to be missing a lot of packages (specifically: strongnswan*, but there are many others).

I can't decide if this is just a breakdown in package the build process, ie it will eventually be corrected and the missing packages will turn up in a few days time, or is there's a wider issue here (like dropped support for my device tree?

Any suggestions/advice?


I'm facing the same issue with a totally different device -- Netgear R6220 (mips) -- so it seems like a problem with the release. I was trying to install samba when I found out that the samba server package is missing, and more.

The version is OpenWrt 22.03.5 r20134-5f15225c1e.

The luci samba4 package is available, but when trying to install:

"Required dependency package samba4-server is not available in any repository."

More than a month since your post, so what is going on?

Same problem with missing samba4-server package.
I'm on 22.03.5 r20134-5f15225c1e, my router is ASUS RT-AX53U.
When trying to install luci-app-samba4, I get the same error as @matthayichen.
No matter if I try from LUCI or via SSH with the opkg install command.
Does anyone know why the package is missing?
Tried a backup solution with SMBD, but it seems under no support.

Edit: doing some search in the download site, it turns out that the very last release with samba4-server for my platform (mipsel_24kc) is 21.02.07.
Can I download the packages from 21.02.07 repo and install them with LUCI on 22.03.5, or will this break the entire router?

1 Like