Missing bits/local_lim.h in x86/64 and Arch toolchains

I am porting custom package which is generic C code, tired to compile and run it on Ubuntu and it work great, then i tried ti port it to OpenWrt but it did not go well, the custom package uses bits/local_lim.h which can be found in "/usr/include/x86_64-linux-gnu/bits/" in Ubuntu, when i finished making the Makefile that fits OpenWrt and on compiling with "target-x86_64_musl"(x86_64 generic)(gcc-7.3.0_musl) or on
i get the following issue

src/globals.h:17:10: fatal error: bits/local_lim.h: No such file or directory
 #include "bits/local_lim.h"

I am using version 18.06 and after checking in the path below the file was missing


I tried to copy the bits folder from the Ubuntu and replace the one in the target but lead to more missing things and it's clear that it wont work :slight_smile: but i had nothing else to try .
So what i can do to solve that missing file issue bits folder, so how i can overcome this issue and compile the package ?

Any ideas ?