Minidlna found nothing

Mon Sep 14 10:20:54 2020 daemon.info minidlnad[7325]: monitor.c:126: error: inotify_add_watch(/mnt/sda1/aria2) [Permission denied]
Mon Sep 14 10:20:54 2020 daemon.info minidlnad[7325]: monitor.c:126: error: inotify_add_watch(/mnt/sda1/aria2) [Permission denied]


miniDLNA 状态

miniDLNA服务已启用,提供 0 音频, 0 视频 和 0 图片.


how can i solve this problem??:sob::sob::sob:

What are the permissions at "/mnt/sda1/aria2"?
How is "minidlna" configured?

1 Like
root@OpenWrt:/mnt/sda1# ls -l
drwxrw-rw-   10 root     root         12288 Sep 14 09:03 aria2

copy from /etc/config/minidlna

config minidlna 'config'
        option user 'minidlna'
        option port '8200'
        option interface 'br-lan'
        option friendly_name 'OpenWrt DLNA Server'
        option db_dir '/var/run/minidlna'
        option inotify '1'
        option notify_interval '900'
        option serial '12345678'
        option model_number '1'
        option root_container '.'
        option album_art_names 'Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg'
        option uuid '5be5d87d-eb10-451c-8684-100d9d3f97dd'
        list media_dir '/mnt/sda1/aria2/'
        option presentation_url 'http://192.168.100.252'
        option enabled '1'

i have use a command:chmod 766 /mnt/sda1/aria2/*

helppppppppp... :confounded:

chmod -R a=rwX /mnt/sda1/aria2
1 Like

thanks...i try,but nothing change... :cry: :cry:

ls -l -d / /mnt /mnt/sda1 /mnt/sda1/aria2

What is the output?

1 Like
root@OpenWrt:/# ls -l -d / /mnt /mnt/sda1 /mnt/sda1/aria2
drwxr-xr-x    1 root     root          3488 Sep 12 23:39 /
drwxr-xr-x    1 root     root          3488 Sep 12 23:39 /mnt
drwxrw-rw-    3 root     root          4096 Jan 20  2020 /mnt/sda1
drwxrwxrwx   10 root     root         12288 Sep 14 16:54 /mnt/sda1/aria2
1 Like

hep....helppppp... :sweat: :sweat: :sweat:

anyone here?? :sweat_smile: :sweat_smile: :sweat_smile:

Please, do not repost the same question.
Even with the smileys, it is not funny.

1 Like

like 10th and 11th floor i posted?

so ... have you found a solution to fix the problem... :sweat_smile: :sweat_smile:

can anybody help?? :sweat_smile: :sweat_smile:

option user 'root'

1 Like