Mikrotik RB952Ui-5ac2nD-TC - Some questions

I have succesfully netbooted vmlinux-initramfs.elf for this device.

ifconfig enp0s31f6 up
dnsmasq -i enp0s31f6 --dhcp-range=, \
--dhcp-boot=openwrt-ar71xx-mikrotik-vmlinux-initramfs.elf \
--enable-tftp --tftp-root=/srv/tftp/ -d -u my_unix_username -p0 -K --log-dhcp --bootp-dynamic

From here I want to install LEDE (or OpenWRT). Some questions:

This link will bring you to ~15 files. Perhaps someone could identify some files for me, as I don't know what most are for:

  1. What's vmlinux-initramfs-lzma.elf ? If it is a compressed version of vmlinux-initramfs.elf, why is it there?
  2. What's the difference between vmlinux-initramfs.elf and vmlinux-initramfs.bin ?
  3. Why are they so many sysupgrade.bin's and how do I know which one I can use for my specific device?
  4. How do I determine if I need files from the /trunk, from /snapshots or from /releases ?

I tried following Common Procedures for Mikrotik RouterBoard Products but found that wget2nand can be replaced by using sysupgrade -n *.bin. I don't know which one I need, though:

  • nand-64m-squashfs-sysupgrade.bin
  • nand-large-ac-squashfs-sysupgrade.bin
  • nand-large-squashfs-sysupgrade.bin
  • rb-nor-flash-16M-ac-squashfs-sysupgrade.bin
  • rb-nor-flash-16M-squashfs-sysupgrade.bin

And finally, will this install LEDE or Openwrt? Or are they the same?


OpenWrt is newest.

See https://mikrotik.com/product/RB952Ui-5ac2nD-TC: 16MB flash (nor) and WiFi AC, so... rb-nor-flash-16M-ac-squashfs-sysupgrade.bin is proper image.

Thank you for the quick reply. I tried sysupgrade -n openwrt-ar71xx-mikrotik-rb-nor-flash-16M-ac-squashfs-sysupgrade.bin and it worked fine.

Much appreciated.

Hello, I would like to inform other users googling to this page about my experience with this hardware.

The -TC is different not only in the external case. I have one RB952Ui-5ac2nD-TC from december 2018, I tried to install openwrt 18.06.1, but when I boot from tftp with the distributed image there are no mtd devices, and sysupgrade does not recognize the hardware. So, when called with -F it closes SSH but actually does nothing, i.e. at next boot the device starts with routeros.

I rebuilt 18.06.1 (not the dev snapshot) using the patch to support the new W25Q128JVSIM chip:


and when booted from tftp with this image, mtd devices are actually present. sysupgrade -F installs the rebuilt openwrt-ar71xx-mikrotik-rb-nor-flash-16M-ac-squashfs-sysupgrade.bin, but the device stays in a reboot loop. It can still be booted from tftp with the reset button.

Since I do not have the serial converter I cannot easily read the last log messages when boot from flash fails.

If anyone has a suggestion for further troubleshooting without serial I would be happy to hear it, in the meanwhile I will try to flash the dev snapshot image, or the snapshot of May 2018 of the original post, and will keep this forum informed.


No luck with the dev snapshot, still boot loop.

read this document first, expecially licence key part


first attach your device ethernet to port 5
then power your mikrotik.
open and

  1. System → Routerboard → Settings → Boot device: Try ethernet once then NAND

  2. System → Routerboard → Settings → Boot protocol: DHCP

  3. System → Routerboard → Settings → Force Backup Booter: Checked (if supported by your routerboard - !IMPORTANT)

unplug power.
attach ethernet to port 1

form this url

download files

create a script file, and change interfaces and tftp-root

ifconfig eno1(your interface) up
dnsmasq -i eno1(your interface) --dhcp-range=,
--enable-tftp --tftp-root=/where is files/ -d -u dnsmasq -p0 -K --log-dhcp --bootp-dynamic

then run script,(you can download dnsmasq and compile from source for use,also kill all your tftp and dhcp servers. google)

hold reset button
plug power
wait about 20 seconds(you can watch progress from script screen,after you see send ***.initramfs.bin unhold reset button)

wait 20 seconds again
detach ethernet from mikrotik
attach ethernet to port 5 again

wait 15 seconds
if your computer ethernet does not have an ipv4
set your computer ethernet
ifconfig eno1


if got responses

if you see luci, kernel and ramfs is working.

open upgrade section and select your

thats it

No luck.
LuCI started on, but on WAN port and only RED LED light. Try firmware upgrade, after choose file "openwrt-18.06.2-ar71xx-mikrotik-rb-nor-flash-16M-ac-squashfs-sysupgrade.bin" and click on "Flash Image" button:
"The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

mikrotik rb952ui-5ac2nd-tc

This https://github.com/aredn/aredn_ar71xx AREDN specialized firmware build on OpenWRT is with rb952ui-5ac2nd-tc working. Im not programmer so dont know why.
But, AREDN firmware is specialized only for Amateur Radio Emergency Data Network (AREDN) and not for home user.

Hello. I try to flash the router, I get the same error. Loading from TFTP is normal. The luci web interface is also only on the wan port (1). Also tried using ssh, the image is not recognized. I tried different releases 18.06.1(2) and trunk, everywhere the same error.
How can I flash?
I have RB952Ui-5ac2nD (no TC) hAP ac lite

login as: root

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r9610-5e247f3ac1
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
root@OpenWrt:~# sysupgrade -n /tmp/openwrt-ar71xx-mikrotik-rb-nor-flash-16M-ac-s
Device unknown not supported by this image
Supported devices: rb-750-r2 rb-750up-r2 rb-750p-pbr2 rb-911-2hn rb-911-5hn rb-9                                             31-2nd rb-941-2nd rb-951ui-2nd rb-952ui-5ac2nd rb-962uigs-5hact2hnt rb-lhg-5nd r                                             b-map-2nd rb-mapl-2nd rb-wap-2nd rb-wapr-2nd rb-wapg-5hact2hnd
Image check 'fwtool_check_image' failed.

So I could not flash openwrt. I need help.
Tried to use sysupgrade -F, now the router reboots cyclically. TFTP boot is normal
The list of supported models rb-952ui-5ac2nd is present

root@OpenWrt:~# sysupgrade -n /tmp/openwrt-ar71xx-mikrotik-rb-nor-flash-16M-ac-s
Device unknown not supported by this image
Supported devices: rb-750-r2 rb-750up-r2 rb-750p-pbr2 rb-911-2hn rb-911-5hn rb-931-2nd rb-941-2nd rb-951ui-2nd rb-952ui-5ac2nd rb-962uigs-5hact2hnt rb-lhg-5nd rb-map-2nd rb-mapl-2nd rb-wap-2nd rb-wapr-2nd rb-wapg-5hact2hnd
root@OpenWrt:~# cat /proc/cpuinfo
system type             : Qualcomm Atheros QCA9533 ver 2 rev 0
machine                 : MikroTik RouterBOARD RB952Ui-5ac2nD
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 432.53
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa                     : mips1 mips2 mips32r1 mips32r2
ASEs implemented        : mips16
shadow register sets    : 1
kscratch registers      : 0
package                 : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

root@OpenWrt:~# cat /proc/mounts
rootfs / rootfs rw 0 0
proc /proc proc rw,nosuid,nodev,noexec,noatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,noatime 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev,noatime 0 0
tmpfs /dev tmpfs rw,nosuid,relatime,size=512k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,mode=600,ptmxmode=000 0 0
debugfs /sys/kernel/debug debugfs rw,noatime 0 0