Mikrotik RB760iGS / eth0 / No LAN1


I recently installed OpenWrt on a Mikrotik RB760iG S (Hex S).

Everything works great except for one thing. The "Switch Port" lan2, lan3, lan4, lan5 work correctly in the "br-lan" bridge.

But I can't get lan1 to work, it looks like eth0 is the source. When I change the MTU of eth0 from 1504 to 1500 I lose full access to the router and I have to reinstall the system.

The "Switch Port" lan1 does not exist in the device list. On this router there is 1 SFP port and 5 ethernet ports. Since I switched to OpenWrt (not Snapshot, 21.02.0-rc3), I lose port 1, whereas I would like to integrate it into br-lan.

On RouterOS, I had put all the ports (eth1,2,3,4,5) in a bridge with a DHCP server.

I believe that the CPU of my router does not support the "switch" function.

Do you have an idea of ​​the problem ? Or is it normal ?

/etc/config/network, Hidden sensitive informations :

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask ''
	option ip6assign '64'
	list ip6class 'wan6'
	option delegate '0'
	option ipaddr ''

config device
	option name 'sfp'

config device
	option type '8021q'
	option ifname 'sfp'
	option vid '832'
	option name 'sfp.832'

config interface 'wan'
	option proto 'dhcp'
	option device 'sfp.832'
	option broadcast '1'
	option vendorid 'sagem'
	option reqopts '1 15 28 51 58 59 90'
	option sendopts 'xxxxx'

config interface 'wan6'
	option proto 'dhcpv6'
	option device 'sfp.832'
	option reqaddress 'none'
	option reqprefix 'auto'
	option defaultreqopts '0'
	option sendopts 'xxxxx'
	option noclientfqdn '1'
	option noacceptreconfig '1'


1 Like

Hi Aize,

This device uses DSA, so each switch port is exposed as a linux network device. You may need to set the MTU at the bridge (br-lan), or port (lan2) level. I am not sure.

The ether1 port from RouterOS is labelled as wan in OpenWrt. Add this port to your config devicebr-lan stanza: list ports 'wan', and remove it from br-wan (looks like you did this already).


Hi johnth,

Thank you for your reply.

I wasn't expecting that the "wan" port is ether1. Because my wan port is actually the SFP port.

Sorry, but i'm new on OpenWrt.



This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.