MikroTik RB751G-2HnD: all eraseblocks are bad


tried to install LEDE 17.01.4 on Mikrotik device but probably I bricked it.

From RouterOS I set:

System → Routerboard → Settings → Boot device: Try ethernet once then NAND
System → Routerboard → Settings → Boot protocol: DHCP
System → Routerboard → Settings → Force Backup Booter

After booting via TFTP with initrams, tried (from /tmp) with
sysupgrade -n nand-64m-squashfs-sysupgrade.bin
(and also with -n -F) and got the message "Image metadata not found" and lost ssh console, then after few minutes the device restart but I cannot no more access it (no ping also and no interface up).

The netinstall (require bootp) is not an option because the device remain with the past settings (boot protocol = dhcp) so I cannot recover it (seen with wireshark.
The usual methods to reset from Mikrotik aren't no more available.

Started again using TFTP server and loading the initramfs image, I tried also this guide: https://wiki.openwrt.org/toh/mikrotik/common

using 15.05 version.

Wget2nand give me this error:

Connecting to (
kernel 100% |*******************************| 1191k 0:00:00 ETA
Connecting to (
rootfs.tgz 100% |*******************************| 2738k 0:00:00 ETA
Erasing filesystem...
Mounting /dev/mtdblock2 as new root and /dev/mtdblock1 as kernel partition
Copying kernel...
cp: can't create '/tmp/wget2nand/mnt_kernel/kernel': Cannot allocate memory
Error occured while copying the kernel

so I tried the manual procedure:

root@OpenWrt:~# cat /proc/mtd
dev: size erasesize name
mtd0: 00040000 00020000 "booter"
mtd1: 003c0000 00020000 "kernel"
mtd2: 07c00000 00020000 "rootfs"

and then

mtd erase /dev/mtd1
Unlocking /dev/mtd1 ...
Erasing /dev/mtd1 ...

Skipping bad block at 0x0 
Skipping bad block at 0x20000 
Skipping bad block at 0x40000 
Skipping bad block at 0x60000 
Skipping bad block at 0x80000
...skipped 30 blocks.......

so I suspect all blocks are gone on /dev/mtd1

As a last resort I tried:

/tmp# ubiformat /dev/mtd1
ubiformat: mtd1 (nand), size 3932160 bytes (3.8 MiB), 30 eraseblocks of 131072 bytes (128.0 KiB), min. I/O size 2048 bytes
libscan: scanning eraseblock 29 -- 100 % complete 
ubiformat: error!: all 30 eraseblocks are bad

so I think the device is definitely gone.

Before installation from winbox I got a 0% failed block, so I suppose LEDE bricked my device.

Can someone confirm it?

Thanks in advance


After flashing LEDE 17.01.4 on RB450G I encounter same problem... more or less I tried the same workaround but same error messages back.

Flashing a default OpenWRT build of 18.06 on RB912UAG-2HPnD in the same problem. I suspect it is a software problem. Same errors.