MikroTik rb450gx4 support

You need to git clone the branch I linked and then you can easily build that.
Yes, you simply select the packages you want in menuconfig, well if you want to install a package that depends on kernel module or other specific package version then you need to compile a image with those versions or compile those packages separately.

No, you need to select the RB450Gx4 profile in IPQ40xx

RB450gx4 does not exist anywhere as a system, subtarget or profile:
nothing exists between Q-U for profile...

Like I said, you need to clone the branch I linked to you in the first reply.
So git clone -b RB450Gx4-rebase-sdhci --single-branch https://github.com/robimarko/openwrt.git

1 Like

got it, thank you!

I get this error, any thoughts?

WARNING: Makefile 'package/feeds/packages/frr/Makefile' has a dependency on 'more', which does not exist

Its just a warning, not unusual in master repo.
Do you use the ffr package?
If not simply ignore

1 Like

new error, I'm guessing my build environment isn't right? any idea how to troubleshoot? verbose mode is quite confusing...

make -r world: build failed. Please re-run make with -J1 V=s or V=sc for higher verbosity level to see what's going on
make: *** [/home/pi/openwrt/include/toplevel.mk:218: world] Error 1

This is at line 218: cp .config tmp/.config; \

So far I've done this on 3 different Debian systems with the following dependencies installed and each one has the same error:
sudo apt install build-essential libncurses5-dev gawk git libssl-dev gettext zlib1g-dev swig unzip time file

You need to use make -j1 V=s to see whats the actual error.
And post that, which Debian version are you using?

using 10.2. as a VM and a variant of 9 on an RK3399 SBC.

I'll run with make -j1 V=s and see if I can post an output

I have two builds giong on, one with packages and one without, this one is without, this is the one on Debian 10.2:

You are missing python3-distutils
sudo apt install python3-distutils should fix it

That worked for the Debian 10.2, thanks!

This is the error output from the Debian 9 with additional packages:

In file included from /usr/include/asm-generic/types.h:6:0,
                 from /usr/include/aarch64-linux-gnu/asm/types.h:1,
                 from /usr/include/linux/types.h:4,
                 from /usr/include/aarch64-linux-gnu/asm/sigcontext.h:19,
                 from /usr/include/aarch64-linux-gnu/bits/sigcontext.h:27,
                 from /usr/include/signal.h:306,
                 from /usr/include/aarch64-linux-gnu/sys/param.h:28,
                 from tools/proftool.c:18:
/usr/include/asm-generic/int-ll64.h:30:42: error: conflicting types for '__u64'
 __extension__ typedef unsigned long long __u64;
In file included from <command-line>:0:0:
././include/compiler.h:69:18: note: previous declaration of '__u64' was here
 typedef uint64_t __u64;
scripts/Makefile.host:99: recipe for target 'tools/proftool' failed
make[5]: *** [tools/proftool] Error 1
Makefile:1509: recipe for target 'tools-only' failed
make[4]: *** [tools-only] Error 2
make[4]: Leaving directory '/home/pi/openwrt/build_dir/host/u-boot-2018.03'
Makefile:46: recipe for target '/home/pi/openwrt/build_dir/host/u-boot-2018.03/.built' failed
make[3]: *** [/home/pi/openwrt/build_dir/host/u-boot-2018.03/.built] Error 2
make[3]: Leaving directory '/home/pi/openwrt/tools/mkimage'
time: tools/mkimage/compile#21.44#5.71#28.12
tools/Makefile:157: recipe for target 'tools/mkimage/compile' failed
make[2]: *** [tools/mkimage/compile] Error 2
make[2]: Leaving directory '/home/pi/openwrt'
tools/Makefile:155: recipe for target '/home/pi/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.tools_compile_yynyynnyyynyyyyynyynnyyyynyyyyyyyyyyyyyyynyynynnyyynnyyy' failed
make[1]: *** [/home/pi/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.tools_compile_yynyynnyyynyyyyynyynnyyyynyyyyyyyyyyyyyyynyynynnyyynnyyy] Error 2
make[1]: Leaving directory '/home/pi/openwrt'
/home/pi/openwrt/include/toplevel.mk:216: recipe for target 'world' failed
make: *** [world] Error 2

On which package do you get that?
It could easely have been already fixed in current OpenWrt master, but I have not tested building on Debian as I use Fedora for all of my builds.

HOSTCC tools/proftool

Well that is part of mkimage and as far as I remember uses parts of U-boot for it so its most likely bug with version used and Debian 9 combo.
I really cant help you here

fair enough. My Debian 10.2 is still compiling, so good news there. Thanks again for all your help!

looks like the compile completed. where do I find the finished file?

Its in bin/targets and then follow the target/subtarget folders

DING DING DING!!! WE HAVE A WINNER!!! Thanks for all your help!

Trying to compile with packages and ran into this, does it make any sense? A simple google yields nothing for rpcd-mod-luci...

[ 50%] Building C object CMakeFiles/rpcd-mod-luci.dir/luci.c.o
/home/pi/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/rpcd-mod-luci-20191114/luci.c: In function 'rpc_luci_get_iwinfo':
/home/pi/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/rpcd-mod-luci-20191114/luci.c:924:31: error: 'IWINFO_KMGMT_SAE' undeclared (first use in this function); did you mean 'IWINFO_KMGMT_NAMES'?
      if (crypto.auth_suites & IWINFO_KMGMT_SAE)
/home/pi/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/rpcd-mod-luci-20191114/luci.c:924:31: note: each undeclared identifier is reported only once for each function it appears in
/home/pi/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/rpcd-mod-luci-20191114/luci.c:927:31: error: 'IWINFO_KMGMT_OWE' undeclared (first use in this function); did you mean 'IWINFO_KMGMT_SAE'?
      if (crypto.auth_suites & IWINFO_KMGMT_OWE)
make[6]: *** [CMakeFiles/rpcd-mod-luci.dir/build.make:63: CMakeFiles/rpcd-mod-luci.dir/luci.c.o] Error 1
make[6]: Leaving directory '/home/pi/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/rpcd-mod-luci-20191114'
make[5]: *** [CMakeFiles/Makefile2:73: CMakeFiles/rpcd-mod-luci.dir/all] Error 2
make[5]: Leaving directory '/home/pi/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/rpcd-mod-luci-20191114'
make[4]: *** [Makefile:130: all] Error 2
make[4]: Leaving directory '/home/pi/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/rpcd-mod-luci-20191114'
make[3]: *** [Makefile:58: /home/pi/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/rpcd-mod-luci-20191114/.built] Error 2
make[3]: Leaving directory '/home/pi/openwrt/feeds/luci/libs/rpcd-mod-luci'
time: package/feeds/luci/rpcd-mod-luci/compile#0.39#0.17#0.54
make[2]: *** [package/Makefile:109: package/feeds/luci/rpcd-mod-luci/compile] Error 2
make[2]: Leaving directory '/home/pi/openwrt'
make[1]: *** [package/Makefile:103: /home/pi/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/pi/openwrt'
make: *** [/home/pi/openwrt/include/toplevel.mk:218: world] Error 2