MikroTik Hex S (RB760iGS) - Installation via sysupgrade - no connection

How did you do that router is booting without any problems? I perform a "clean" install, I reverted back to RouterOS and then start OpenWRT from initramfs image, then sysupgrade -n from sysupgrade image - still freezing on boot after the update.

Just sysupgrade -n from openwrt booted from RAM as you did. Maybe you can try downloading the sysupgrade image again?

How do you manage to revert to routeros? It would be nice to know how to do it if necessary.

I will try once again with the newest sysupgrade image soon.

I did the revert via NetInstall tool from MikroTik (https://wiki.mikrotik.com/wiki/Manual:Netinstall) I need to try a couple of times to start it up but finally it will revert to RouterOS without any problems.

With the image from 06/11/2020 there is still problem with booting, after sysupgrade -n the router reboots and I need to disconnect power cable, press reset buton on the side, connect power cable and hold the button for like 3 sec, after that router starts with OpenWrt.

any trick with netinstall, that i'm trying to recover a mikrotik but it will not work?

Try to disconnect the power connector, press the reset button, connect the power connector and hold it until netinstall not finds it. Sometimes you need to make this couple of times because it can not start the process somehow.

This is not what happens here, after sysupgrade it booted smoothly.

Now that iI added sfp interface to lan bridge I can access to the sfp and I see that now GPON is not working, the SFP is correctly configured for GPON and it worked from routeros, what could be doing openwrt to prevent it to work? It gets states 03 of ploamsg

@Nidhhogg I am not seeing this first-boot behavior. You would need connect to the hardware UART pads and provide a serial log to look further into this.
Snapshot does not include luci.
I usually leave device for 5 minutes after sysupgrade to give it time to erase flash, write flash, poweroff, startup, first-boot.

@birry's GPON SFP module not functioning is solved by this (unmerged) PR: https://github.com/openwrt/openwrt/pull/3584

I found the source of the problem! My MikroTik was on the newest development version of RouterOS and that is causing the issue. When I revert to the stable version of RouterOS and after that I flash OpenWRT it starts without any problems, there is probably some changes in partitions table in the newest development RouterOS or something... dunno, but it's finally working! :smiley:

I'm facing this problem on my RB760igs, I use it at home, I used it on firmware 7.6 Beta, I tried to install openwrt, it turns out that intramfs boots normally, but when I go to sysupgrade, it dies, and I can't go back to RouterOS. Remembering that I'm a beginner, could someone help me?

Follow the Mikrotik Netinstall process: https://help.mikrotik.com/docs/display/ROS/Netinstall. Download a v6 stable netinstall and RouterOS (MMIPS for hex s), apply it, then downgrade the RouterBOOT firmware from console (ssh to the hexs running RouterOS) with /system routerboard upgrade https://help.mikrotik.com/docs/display/ROS/RouterBOARD

Need to hold in the hexs reset button (for long time: sometimes more than 25s) while the device is starting to look for netinstall server.


unfortunately I found this posting after I run into the same issue.
Before I started to load OpenWRT from RAM I flashed the latest FW and RouterOS version 7.2.1 on the router.
Based on the information in the thread this is causing the issue when trying to sysupgrade the squashfs image.

Now I'm facing this situation:

  • Router is not booting after sysupgrade
  • Router cannot be flashed with RouterOS using netboot

I can only boot the router with serving OpenWRT intramfs image via TFTP.

How can I fix this issue?

This trick for boot normally still present on 22.03.x because the bug still here.

Unplug, power on pressing the reset button for 3 seconds and leave and after some seconds boots normally.

HI bro i ma working on same router can you guide me properly...if you have time ??