MikroTik Hex S (RB760iGS) - Installation via sysupgrade - no connection

I'm trying to install OpenWrt on my MikroTik Hex S (RB760iGS). I followed the advice steps here - https://openwrt.org/toh/mikrotik/common - I will now list the steps I followed in order, then at the bottom I will state my issue. The Hex S installation procedure is to load the relevant OpenWRT development snapshot into RAM, then install to disk via sysupgrade.

  • Downloaded the initramfs and sysupgrade files, then verified the sha256sum

  • Made the initramfs available via TFTP (using dnsmasq)

  • Rebooted the router while holding the reset button until it beeps, with a connection to my TFTP server in the WAN port. This is successful, the TFTP server sends the initramfs bin to the router.

  • Moved my computers ethernet from the WAN port to the LAN port on the router. Connected via ssh to the router, logged in as root. The router is running OpenWrt in RAM at this point, so far so good.

  • Transferred sysupgrade to router's /tmp folder via scp

  • Performed sysupgrade with the bin file in /tmp, sysupgrade seems to be successful, the router then closes the ssh connection and reboots.

And that brings us to now. Now I cannot connect to the router via the LAN ports. I tried all of the LAN ports. The LEDs on the router light up to show that the LAN port is connected, but I cannot connect to the router from my computer. I can't ping the router, I don't get assigned a dhcp IP from the router. I tried connecting via linux on two machines and could not. I tried connecting via putty on Windows and could not. I can start the whole process from the beginning, and everything works fine every time until the reboot after sysupgrade.

As an extra note, I also tried connecting via WAN, but after the sysupgrade the router doesn't seem to even make a dhcp request to the WAN.

Any help you can give me will be greatly appreciated. As a warning, I don't have a huge amount of networking experience, and this is my first time using OpenWrt.

Thanks so much for your time.

@hexagon, welcome to the community!

  • Did you try flashing a second time?
  • Did you make sure you formatted/erase the flash?

Thank you for your reply.

I did try flashing multiple times, I also tried reverting to RouterOS (successfully) then re-attempting to flash OpenWrt, all attempts ended in the same result.

I did not erase/format anything between flashes. I saw some mention of erasing kernel and rootfs on the MikroTik Common Procedures page, but this was marked as deprecated and only to be used for reference. If there is something you think I should erase/flash, can you tell me what specifically and which commands to use? I don't want to accidentally erase the wrong thing!

Thanks again for taking the time to reply!

This is on the RouterBoot menu. It's fool proof - I really don't know how to elaborate any further.

Sorry, I haven't accessed the RouterBOOT menu before. I assume you're talking about the menu described here - https://wiki.mikrotik.com/wiki/Manual:RouterBOOT#Configuration - using 'e' to format nand?

That page states that accessing the RouterBOOT, menu is via serial console, as described here - https://wiki.mikrotik.com/wiki/Manual:System/Serial_Console - but I've never done this before and am a little confused. From the RJ45 type serial port, am I to assume that the connection is just over a standard ethernet cable to my computer from the router, which I initiate during the normal boot process via an application like putty?

Apologies for my ignorance, and thank you for showing patience with me!

Bump, I am having just the same issue, same device, image and error.

Me too sadly...
Boot perfectly on RAM, but not in the NAND.

How are you trying to connect after flashing the sysupgrade, via ssh or webinterface?

Both, but not luck.
I don't get DHCP from the router, but if I set IP manually, don't reply.

Bump, any ideas?

Well, I found something...
Actually I was able to run OpenWrt from RAM and sysupgrade the squashfs image to it and after reboot it hang up... Then I was trying to upload RouterOS image (MMIPS) via script in MikroTik common manual (https://openwrt.org/toh/mikrotik/common#select_a_dhcpbootptftp_netboot_server), after the load of that image I was sure that I will see RouterOS but no... there is OpenWrt installed and started from flash.
But it works only to reboot, after the reboot you need to load the RouterOS image again, so it looks like there is some problem with bootloader ;(

I guess that we are in this situation: https://github.com/openwrt/openwrt/pull/3511

Yes, that pull request should fix the problem, but it needs testing, for anyone that is happy to compile Openwrt with it for a Mikrotik mt7621 or ath79 device.

The issue is that sometimes the part that starts Openwrt (lzma-loader) fails: https://bugs.openwrt.org/index.php?do=details&task_id=3354

Current boot process:

  1. RouterBoot
  2. ELF boot of lzma-loader, which decompresses kernel
  3. Linux kernel boot

The PR removes step 2.

Cheers

1 Like

I am happy to try it, unfortunately I could not compile openwrt successfully, is it possible to bring up a complied image? I will test it immediately.

1 Like

I don't know if this will help but I found that you can start OpenWrt installed on MikroTik but during the start you need to press the Reset button for 3 seconds (https://wiki.mikrotik.com/wiki/Manual:Reset#Using_reset_button) until the SFP LED is turn on (RB760iGS) and after the beep from buzzer the OpenWrt is starting normally.

I´m able to test it in my hEXs RB760GR3 but now I can´t compile the firmware...

The snapshot Mikrotik mt7621 and ath79 devices now should be booting without lzma-loader.
Please let us know if you have troubles with today's snapshot:


https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-mikrotik_routerboard-760igs-initramfs-kernel.bin
https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-mikrotik_routerboard-760igs-squashfs-sysupgrade.bin

Cheers

1 Like

Hi,

I still have problem, after sysupgrade to the newest snapshot the router froze at the boot process and I need to disconnect power cable, press reset buton on the side, connect power cable and hold the button for like 3 sec, after that router boots normally.

I made that by sysupgrade -n, after that I have also couple of other issues like duplicate src declaration, and cannot enter Luci after installation. Also when I restore the backup the router is also froze and only the power LED is blinking and I cannot connect to it.

Hi! Just tested this snapshot and it booted correctly!
I am going to use the rb760 with a Nokia G-010S-A Gpon SFP, with routeros the sfp worked fine and I got internet, but in openwrt I can not even ping to 192.168.1.10 which is default of the sfp, any ideas? Thanks for this great work!

To access 192.168.1.10, you will need to assign the sfp port to LAN bridge.