Mikrotik and OpenWrt trunk vlan do not communicate

Hello
I am having trouble communicating between 2 devices using vlans.
I have 3 devices, a mikrotik router, an openwrt router and my personal computer.
I intend to use the mikrotik as a switch for 2 vlans, both are already configured in the mikrotik and working, I connect my personal equipment to the mikrotik and I have both wan connectivity, to the mikrotik itself and to the openwrt router.
From the openwrt router I have connectivity to the 2 mikrotik ips
but from my personal computer, connected to the openwrt router I don't have that connectivity, but I do have connectivity to the openwrt IPs and the WAN.
In an initial configuration, in openwrt I created the device vlan lan1.30 and lan1.80 as well as a bridge2, each of these devices added it to its respective bridge, and everything worked fine, except for the fact that if I connected something to some openwrt port the port was never raising. I read the documentation and they indicate that the filtering be done from the same br-lan so I proceeded to make that configuration by adding the corresponding ips to br-lan.30 and br-lan.80, but the problem that I am commenting on occurs

cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0b:34c9:c69b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        option bridge_empty '1'
        option stp '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'br-lan.30'
        option ipaddr '192.168.10.2'

config device
        option name 'wan'
        option macaddr '16:91:82:b5:df:70'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config bridge-vlan
        option device 'br-lan'
        option vlan '30'
        list ports 'lan1:t'
        list ports 'lan3:u*'

config interface 'Temp'
        option proto 'static'
        option device 'lan4'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'

config interface 'DMZ'
        option proto 'static'
        option device 'br-lan.80'
        option ipaddr '192.168.20.2'
        option netmask '255.255.255.0'

config bridge-vlan
        option device 'br-lan'
        option vlan '80'
        list ports 'lan1:t'
        list ports 'lan2:u*'