Messed up my config, can't access the router now

Hi, i installed openwrt back in 2016 on an old tp-link TL-WR941ND v3.6 because the default firmware had issues, can't really remember which version of openwrt it was

didn't do anything fancy, it came with luci installed so i just changed its ip to and disabled the wifi interface and the dhcp client in order to use it as a sort of switch for my home

the issue came today when i wanted to move the router after years to another place and enable the wifi interface, i enabled it and when testing which interface should it connect to i selected eth0 and saved and applied the settings, after that everything disconnected and now none of my devices can get an ip address nor can it connect to the router interface in order to undo the change

i tried hard reseting with the buttons on the router but nothing happened after holding for almost a minute, failsafe mode didn't work either, the light starts blinking very fast but i tried on every port and it didn't connect and when pinging i just get destination host unreachable

i feel like i bricked the router and i really hope that's not the case because i don't know if i have the tools to fix it, if anyone had a similar experience and can help me either access the interface or hard reset the router it would be a huge help, thanks!

there is a tftp install on the openwrt page did you try this ?

Push-button tftp recovery is not available on v2/ v3 of the tl-wr941nd.

Edit: Just to clarify, if you just messed up the configuration, the normal failsafe/ firstboot procedures will work

But if you installed a broken firmware version, the device will be effectively dead, without any enduser compatible recovery method (push-button tftp recovery does not exist, the serial console is heavily crippled and inaccessible - and after all we're talking about a 13 year old 4/32 device with borderline broken draft-n wireless, which (in its newer incarnations) was selling for under 15 EUR/ USD new).


Assuming the router actually boots up, one could try to assign it an IP using the arp command.

Configure your client with a static IP address, for example
OpenWrt does not run a DHCP server in failsafe mode.

1 Like