Mesh network on ubiquiti router station pro

#1

I have two ubiquiti router stations pro, and two doodle radios, is it possibl to flash barrier breaker with BATMAN advanced onto the routerboard and set up a mesh network, more nodes will be added later.

#2

Barrier Breaker, no -- unsupported for many years, known insecure, doesn't support current mesh protocols and routing approaches

v18.06.2, yes, if your devices are presently supported

1 Like
#3

Jeff thanks for the quick response.
Below the hardware info for the ubiquity router-station pro. I have Ubuntu loaded on a virtual machine. I have compiled Chaos Calmer and configured it with BATMAN. Would I be better off compiling v18.06.2 instead. I want to set up a mesh for remote devices to stream video. Ubiquity router-station pro supports the doodle lab radios. Both support openWRT. I do not mind spending time working with the hardware as long as it is possible to achieve.
Any advice appreciated.

**|Architecture|MIPS|
|---|---|
|Vendor|Atheros|
|Bootloader|RedBoot|
|System-on-Chip|Atheros (AR7161) MIPS 24K|
|CPU Speed|680 MHz|
|Flash-Chip||
|Flash size|16 MiB|
|RAM|128 MiB DDR|
|Wireless|3x 32-bit Mini-PCI slots (None included)|
|Switch|Atheros AR8316|
|Ethernet ports|1+3|

#4

There is a release version 18.06.2 for the RouterStation Pro. You would also need to install kmod-batman-adv and the kmods for at9k and ath10k (and ath10k firmware) for the wifi cards. There is no need to compile anything yourself.

#5

Mike,
Any chance you have a link to that release, both radios already have ath 10k firmware installed, Cheers.

#6

It should be this one:
http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/generic/openwrt-18.06.2-ar71xx-generic-ubnt-rspro-squashfs-factory.bin

#7

Cheers thanks for the help,

What is the best way to transfer these files to the board, Ubuntu, which I have on a virtual machine, or windows 10 my current operating system. Any places that give a good step by step set of instructions.
David

#8

A "factory" image can usually be flashed from the stock firmware's web interface using any web browser. But always check the devices OpenWrt wiki page for instructions.

#9

Hi all,

I have two routeStations and three routerStations pro. I can SSH into routerStations pro but get a connection error each time I try to connect to the router stations. I used an IP scanner and the address returned is 192.168.1.1. tried to factory reset still same results. Know this is not a specific OpenWrt question but any help would be appreciated or point in the right direction.

The ubiquity routerStation boards have 2009 date on them will i need to upgrade their firmware' if so which version works best with BATMAN-adv.

Appreciate any help.

#11

Instructions for flashing the original (not Pro) RouterStation are here:
https://openwrt.org/toh/ubiquiti/routerstation
It's a TFTP flash through the bootloader. The original OS will not be booted at all.

They have enough memory for the latest version 18.06.2. BATMAN's major revisions are not backward-compatible, so you will need a similar kernel version in all of your nodes for BATMAN to work.

#12

Mike,

Trying to upgrade the routerstation pro, using WinSCP I log in using 192.168.1.20 then using PuTTY username root / password-ubnt I i connect o the board itself. At this stage i get the openwrt home page on the router board.

Then I try the following

cd /tmp/
wget [http://downloads.openwrt.org/backfire/10.03.1/ar71xx/openwrt-ar71xx-ubnt-rspro-squashfs-sysupgrade.bin](http://downloads.openwrt.org/backfire/10.03.1/ar71xx/openwrt-ar71xx-ubnt-rspro-squashfs-sysupgrade.bin)
sysupgrade -i /tmp/openwrt-ar71xx-ubnt-rspro-squashfs-sysupgrade.bin

The first line works ok. The second line returns bad address. Am I on the right track? thanks for the help.

#13

A few things:
Router must be connected to the Internet for wget to work. Alternative is to download the firmware .bin file to your PC using any web browser then scp it to the router's /tmp directory.

You were trying to use version 10, which is very old and no longer on that server.

Use version 18 here:
http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/generic/openwrt-18.06.2-ar71xx-generic-ubnt-rspro-squashfs-sysupgrade.bin
Do not put any brackets or parenthesis around the URL.

Not sure how sysupgrade works on old versions. Try -n (do not save config files) instead of -i.

#14

Mike,

Thanks for the quick response,

I downloaded the link you provided and using WinSCP I copied it to the tmp director.

I then typed:

the command 'ls' showes that the file is in the tmp director

sysupgrade -n openwrt-18.06.2-ar71xx-generic-ubnt-rspro-squashfs-sysupgrade.bin

Tried both -n and -i got same message below.

Firmware was not implemented on this platform.

Any ideas.

David

#15

If whatever firmware is installed doesn't have a working sysupgrade, use the TFTP method instead.

I've attempted to clarify the installation instructions on the RSpro wiki page.

#16

Mike

Hope I am not driving you crazy with all the questions,

Set up a TFTP server 64 Ph Jounin, all you tube videos set it up as a server where the troubleshooting page needs it set up as a client,. Ay more detail on the TFTP server setup or lings to youtube videos.

Can always ssh into the routerboard on normal power up using PuTTY.

But cant gain access through telnet or any of the other protocols, on normal power up. using PuTTY or WinSCP

When I power up with the reset pushed cant log in with any of the PuTTY protocols, also cant find its IP address using an IP sniffer. When I power off and power up as normal I can ssh into it again using 192.168.1.20 - root - ubnt

Trying to set up a mesh network for an OU final project. Have five router boards that i hope to use in the project their old stock.

Need to get new firmware on all five so that I can start to configure the interfaces with BATMAN. Hope I haven't taken on too big of a task!!

Any advice greatly appreciated.

David

#17

Read the RS Pro wiki again I have edited the instructions. It appears that you can use the same instructions for the non Pro other than using different firmware.

Like most Ubiquiti equipment, when the router is booted into recovery mode (by holding the reset button down during power up), the router is a TFTP server with the fixed address 192.168.1.20. It will also answer pings. That is all that it will do on the network. Also you need to plug into the WAN port not the LAN ports to access these services. It is not a DHCP server, so you will have to set up your PC with a static IP. You do not need a TFPT server on the PC, use a TFTP client there. There is a trick to this in Windows which I have explained on the wiki page.

Another problem you may have is that the wifi cards you have are almost certainly going to be ath5k chips that support b/g standards only, and possibly the ath5k driver doesn't have 802.11s meshing either. I don't think there are any parallel PCI 802.11n compatible cards. Parallel PCI and ath5k were already obsolete when the RouterStation hit the market in 2009.

#18

Mike,

Finally got the TFTP server up an running on my PC. Got my router board upgraded with new firmware.

openwrt-18.06.2-ar71xx-generic-ubnt-rspro-squashfs-factory.bin THANKS for the help.

Before installing the new files I had a wireless file in the etc/config folder (OLD VERSION).I have no wireless file now. Is it in a different location or does it need to be installed separately?

Cheers

#19

You probably need to install the drivers for your wifi card(s). Then the base /etc/config/wireless should automatically build.

#20

Thanks for the quick response.

#21

Hi all,

Have updated all routerStation boards hoping to get some work done on installing wireless drivers. Their old doodle labs Single AR5006XS and I am not sure which drivers to install. I think its ath5k but not 100%, have looked at both the hardware section and the doodle lad specifications and no clear information on which drivers to install. Any help appreciated
Cheers