Mesh network - bad performance

Thank you @16F84 for your long post. Regarding signal strength, I did some DIY console dashboard to monitor the three wifi links (as introduced in the first post). I assume that a stronger signal is always beneficial - however, I was afraid that if e.g. all the nodes are too close to each other they would "scream each other down". Thinking about it I reckon that the mac layer should actually handle collisions + retry so maybe I was wrong

Anyway, here is an overview of the link qualities captured from the nodes via ssh calling the respective local iwinfo command + some polishing of the output via grep and sed:

Although here in the overview the link between Bridge 1 and Gateway is the weakest - for this couple I did my "move the 2 to an exclusive channel test" with a batctl tp speed of up to 50 Mbit/s.

Question: Can a far away/ weak link slow down a mesh?

One improvement should probably be to move Bridge 1 closer to Gateway - or get an external antenna.

PS: yes the mesh nodes are named by some Pokemon trainers :wink:

1 Like

Dear Mark,

tnx for your ideas. We use channel 149 on the 5 Ghz band exclusively for meshing so this should not impact the performance.

Regarding running without encryption - this will be one of my experiments the next evenings. Since we're in a crowded living area I can only do this for a short time (security) but I also think it is worth a try!

The new LibreMesh stock builds sound very interesting. Could you please quickly explain how the LibreMesh builds relate to the OpenWrt builds? Also, I've invested quite some time in my auto-generated Openwrt configs (uci). Can I continue using them?

Dear Carlos,

Regarding all you other ideas - I will try them out and feedback here as soon as possible.

Update on my plan to go from 80 Mhz channel width to 40 Mhz:

Did it - no change in the described behaviour. Speed is still dropping as you can see the in iperf3 tests which ran already on 40 Mhz channel width.

LibrrMesh is an enhancement to OpenWRT for easy mesh network deployment

It automatically configure your device at first boot as a community mesh network.

You alter its behavior by modifying the lime-defaults or with UCI commands or directly editing the openwrt configuration files.

LIbreMesh also has a hardware device available

But also does build for other ath79 devices

You can also create your own builds using the development steps like you would do creating OpenWRT images from source with their added feeds and packages

https://libremesh.org/docs/en_quick_starting_guide.html

2 Likes

Yes.

The first thing you should do is try turning up transmit power to the MAXIMUM on everything. If you can achieve at least -60db/-50db RSSI you may not have to move the nodes closer together.

Higher transmit power = higher received signal strength at the receiver = higher bit rates.

I have read many passionate dissertations about keeping transmit power as low as possible. That isn't going to help here. Crank it up!

I am surprised that didn't fix it.

This should be set to MAX POWER for your country or '30' / 1000mW, is what I can set mine to in Canada for channel 149.

You could also try the DFS channels 52 - 148. I haven't tested that on the C7 yet. They should be generally unused and you may get a better RSSI/SNR (higher tx/rx rates) on a quieter channel.

....txpower '25' / 316mW, is the max on my C7 set to Canada on 2.4Ghz which is low since most routers can do 1000mW. This may be due to the C7 V2 having internal antennas for the 2.4Ghz, or hardware limits - not sure. Eitherway that's bad/ a fair bit lower than the max '30'.

Maximum wifi transmission power per country | Wolph

You should be seeing in luci->network->wireless (or your SSH) tx/rx rates of at least 600-866Mbps between the mesh nodes. Your tx/rx rates are going to be slow at -78db RSSI. -78db is too low. This should be -60db /-50db or better if possible.

Until that is resolved that mesh will have low RSSI and high error rates resulting in 1-10Mbps connection speeds. Adding a few more mesh nodes may also aid in offloading the C7's that have AP's active / stabilize everything.

GLHF

PS

I am able to run my mesh nodes at low power settings (15db/31mW) due to their close proximity / no walls and achieve -50db RSSI (50-60db SNR) and max bit rates for the EA8300 of 866Mbps per 5Ghz radio.

***Also make sure you have software/hardware flow offloading checked off under 'network->firewall' to speed things up. Many thanks @nbd.

Wow. A lot of good advice. Will try it out this evening.

I had time to run a few tests today and try to replicate the issues you've been experiencing with the Archer C7. Unfortunately, I was unable to replicate your issue. Even behind three 15cm-thick walls, with the nodes roughly 15m apart of each other and connected over 5Ghz, I was still able to get a mean 52Mbits/sec via TCP and 85Mbits/sec via UDP. For reference, when the nodes are within line of sight and 2m apart of each other (mesh baseline), I was able to get a mean 125Mbits/sec via TCP and 143 Mbits/sec via UDP. (You can find the details of my tests at the end of this reply.)

Regarding your own iperf tests, it seems you're running them on the nodes themselves, rather than through the nodes. I get very different readings when running iperf on the nodes vs. through them, which I assume has to do with the CPU limitations of the Archer C7. As @16F84 pointed out, many of such network devices have limited processing power. This is the reason why I mentioned using laptops connected to the mesh nodes via an Ethernet cable.

I also played around with MTU sizes and fragmentation options (e.g., https://www.open-mesh.org/projects/batman-adv/wiki/Fragmentation-technical) but did not notice any remarkable differences that could explain your throughput issues. I think @16F84 provided a few interesting suggestions regarding tuning your radio settings (see channel selection) but honestly, I've been using pretty much default values and not running into anything like you reported.

All this makes me think there is something peculiar about the environment in which the nodes were deployed or maybe the nodes are almost not seeing each other. If you cannot take them down for further testing, then try adding a few nodes between them, then play around with hop penalty settings, and see how that impacts proper throughput measurements (through your mesh nodes). To help you debug this further, check logs, see what batctl s says before and after a throughput test, and save the output of batctl td bat0 to a file and later on, check it for errors (you might need to change the log level).


Tests

  • Iperf3 server (S): Laptop with gigabit Intel NIC and i7-4700mq CPU running Linux;

    • Server Iperf3: iper3 -s
  • iperf3 client (C): Desktop with gigabit Intel NIC and i7-4790k CPU running Linux;

    • Client iperf3 TCP mode: iperf3 -t 60 -P 5 -w 64K -c SERVER_IP
    • Client iperf3 UDP mode: iperf3 -u -t 60 -b 1G -c SERVER_IP
  • Mesh nodes 01 and 02: Archer C7 v2;

  • Mesh node 03: Archer C7 v4;

  • All nodes:

    Architecture: Qualcomm Atheros QCA9558 ver 1 rev 0
    Firmware Version: OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.128.50949-ec81a49
    Kernel Version: 4.14.221
    Relevant pkgs:
      ath10k-firmware-qca988x - 2019-10-03-d622d160-1
      kmod-ath10k - 4.14.221+4.19.161-1-1
      wpad-mesh-openssl - 2019-08-08-ca8c2bd2-7
      batctl-default - 2019.2-8
      kmod-batman-adv - 4.14.221+2019.2-11
    
  • Openwrt /etc/config/wireless:

    config wifi-device 'radio0'
            option type 'mac80211'
            option channel '44'
            option hwmode '11a'
            option path 'pci0000:00/0000:00:00.0'
            option htmode 'VHT80'
            option country 'BR'
            option disabled '0'
    
    config wifi-iface 'wmesh'
            option device 'radio0'
            option ifname 'if-mesh'
            option network 'mesh'
            option mode 'mesh'
            option mesh_id 'REDACTED'
            option encryption 'sae'
            option key 'REDACTED'
            option mesh_fwding '0'
            option mesh_ttl '1'
            option mcast_rate '24000'
            option disabled '0'
    
  • Openwrt /etc/config/network:

    config interface 'lan'
            option type 'bridge'
            option ifname 'eth1.1 bat0.1'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            list dns '8.8.8.8'
    
    config switch                            
            option name 'switch0'            
            option reset '1'                 
            option enable_vlan '1'           
                                             
    config switch_vlan                       
            option device 'switch0'          
            option vlan '1'                  
            option ports '2 3 4 5 0t'        
    
    config interface 'bat0'                  
            option proto 'batadv'            
            option routing_algo 'BATMAN_IV'  
            option aggregated_ogms '1'       
            option ap_isolation '0'          
            option bonding '0'               
            option bridge_loop_avoidance '1' 
            option distributed_arp_table '1' 
            option fragmentation '1'         
            option gw_mode 'off'             
            option hop_penalty '30'          
            option isolation_mark '0x00000000/0x00000000'
            option log_level '0'                         
            option multicast_mode '1'                    
            option multicast_fanout '16'                 
            option network_coding '0'                    
            option orig_interval '1000'                  
                                                         
    config interface 'mesh'                              
            option proto 'batadv_hardif'                 
            option master 'bat0'                         
            option mtu '2304'                            
            option throughput_override '0'               
    

Test scenarios

  • Very noisy environment (multiple apt buildings nearby)
  • Tested conditions:
    1. SC same node (baseline mesh-less)
    2. S - Node 01 - Node 02 - C (baseline mesh): within line of sight + 2 meters apart
    3. S - Node 01 - Node 02 - C (close): 01 concrete wall (15cm thick) + roughly 7 meters apart
    4. S - Node 01 - Node 03 - Node 02 - C (far): 03 concrete walls + 15 meters apart

Results

The first output is always for the TCP test, while the second is for UDP. All results are summaries over 1 minute. (Of note, for TCP, the window size was changed to 64K because I was getting lots of retries with the default value and over the mesh connections. This made me play around with MTU and fragmentation settings but the results did not show anything relevant to OP's issue, so I'm not reporting them here.)

Baseline mesh-less

$ iperf3 -t 60 -P 5 -w 64K -c S_IP
[ ID] Interval           Transfer     Bitrate         Retr
[SUM]   0.00-60.00  sec  6.57 GBytes   941 Mbits/sec    0             sender
[SUM]   0.00-60.00  sec  6.57 GBytes   941 Mbits/sec                  receiver

$ iperf3 -u -t 60 -b 1G -c S_IP
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  6.68 GBytes   956 Mbits/sec  0.000 ms  0/4953791 (0%)  sender
[  5]   0.00-60.00  sec  6.68 GBytes   956 Mbits/sec  0.022 ms  123/4953791 (0.0025%)  receiver

Baseline mesh

$ iperf3 -t 60 -P 5 -w 64K -c S_IP
[ ID] Interval           Transfer     Bitrate         Retr
[SUM]   0.00-60.00  sec   893 MBytes   125 Mbits/sec    1             sender
[SUM]   0.00-60.02  sec   893 MBytes   125 Mbits/sec                  receiver

$ iperf3 -u -t 60 -b 1G -c S_IP
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  6.66 GBytes   954 Mbits/sec  0.000 ms  0/4940958 (0%)  sender
[  5]   0.00-60.03  sec  1021 MBytes   143 Mbits/sec  0.085 ms  4201504/4940913 (85%)  receiver

Close

$ iperf3 -t 60 -P 5 -w 64K -c S_IP
[ ID] Interval           Transfer     Bitrate         Retr
[SUM]   0.00-60.00  sec   753 MBytes   105 Mbits/sec    1             sender
[SUM]   0.00-60.01  sec   753 MBytes   105 Mbits/sec                  receiver

$ iperf3 -u -t 60 -b 1G -c S_IP
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  6.66 GBytes   954 Mbits/sec  0.000 ms  0/4940942 (0%)  sender
[  5]   0.00-60.04  sec   868 MBytes   121 Mbits/sec  0.682 ms  4312030/4940422 (87%)  receiver

Far

$ iperf3 -t 60 -P 5 -w 64K -c S_IP
[ ID] Interval           Transfer     Bitrate         Retr
[SUM]   0.00-60.00  sec   377 MBytes  52.7 Mbits/sec   23             sender
[SUM]   0.00-60.05  sec   376 MBytes  52.6 Mbits/sec                  receiver

$ iperf3 -u -t 60 -b 1G -c S_IP
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  6.66 GBytes   954 Mbits/sec  0.000 ms  0/4938732 (0%)  sender
[  5]   0.00-60.08  sec   608 MBytes  84.9 Mbits/sec  0.029 ms  4497992/4938407 (91%)  receiver
1 Like

your

batctl -s

should be

batctl s

@cgomesu have you successfully used BATMAN-adv bonding or BATMAN-adv over Ethernet ?

thanks for the correction!

I have never played too much with any of the multilink optimizations because the default behavior is almost always enough for my use-cases. Why are you asking?

Regarding batman over wired connections, I've never used that before but I don't see any reason why it should not work if the physical ports are properly configured to route mesh vs non-mesh traffic (or possibly through vlans instead). (Funny enough, I got an email just a few days ago about this same topic. It was a user running a small ISP and thinking about using wired mesh for redundancy. Asked them to keep me posted on the project.) So far, however, I've never seen any successful implementation of wired mesh with batman.

The batman-adv bonding yielded no performance gain on my last tests.

As for batman-adv over Ethernet........

What I did last time

I also took discussion on github with the LIbreMesh developers

Further the Gluon documents also refer to it
https://gluon.readthedocs.io/en/latest/features/wired-mesh.html

The use cases for wired mesh are very limited but I'll gladly test it with the Archers C7 I have here and their standard OpenWrt images. However, as you might have noticed, this topic is unrelated to @samba2 's issue, so I don't think it would be appropriate to talk about it here. If you want help with wired mesh using the batman routing protocol, write a new post and ping me there. (The post you mentioned is closed.)

Iperf3 tests

3 node mesh, all nodes are EA8300, 19.07.7, vanilla 802.11s, WPA3 SAE

Layout:
Nodes 1 and 2: have a partial LOS, are located 18ft apart, some walls.
Node 3: has no LOS, 20ft from other nodes, is obstructed by a concrete wall with openings

Installed:
ath10k-firmware-qca4019-ct
ath10k-firmware-qca9888-ct
kmod-ath10k-ct
wpad-openssl
dnsmasq-full

Nodes: 
Node 1: root, total memory = 146/245MB
Node 2: Ap node (no clients), total memory = 114/245MB
Node 3: freewheel, total memory = 122/245MB

TX Power:
Node 1: tx = 27dBm (501 mW)
Node 2: tx = 25 dBm (316mW)
Node 3: tx = 28 dBm (630 mW)
*reported by LuCI

RSSI: 
Node 1 -> Node 2 (36/-103 dBm), Node 3 (-44/-103 dBm) , tx/rx 866 Mbit/s
Node 2 -> Node 1 (-45/-102 dBm), Node 3 (--44/-102 dBm), tx/rx 866 Mbit/s
Node 3 -> Node 1 (-58/103dBm), Node 2 (-45/-103 dBm), tx/rx 866 Mbit/s / 780Mbit/s
*reported by LuCI

Node 1 config: 

cat etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option channel '157'
	option country 'CA'
	option legacy_rates '0'
	option txpower '27'

config wifi-iface 'wifinet'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'lan'
	option key 'xxxxxxxxxx'
	option mesh_id 'xxxxxxxxxxx'

*same on all nodes (except txpower)

Test scenarios:

Tests done with no load on mesh, no wireless clients, root node connected to internet.
Tests done with mesh node quad core CPU, Qualcomm IPQ4019.
Tests done with same iperf commands as @cgomesu archer C7 tests for comparison purposes.

Node 1 server:
iperf3 -i 10 -s

Node 2 client TCP <-> Node 1 server:

LuCI -> Status -> Overview -> Load Average 0.79, 0.33, 0.27 (highest value recorded over halfway through test)

iperf3 -t 60 -P 5 -w 64K -c 192.168.x.x
Connecting to host 192.168.x.x, port 5201

[ ID] Interval                   Transfer          Bitrate             Retr
[SUM]   0.00-60.00  sec  2.04 GBytes   292 Mbits/sec  335             sender
[SUM]   0.00-60.01  sec  2.04 GBytes   292 Mbits/sec                  receiver


**Node 2 client  UDP test -> Node 1 server:**

LuCI -> Status -> Overview -> Load Average 0.70, 0.38, 0.29

iperf3 -u -t 60 -b 1G -c 192.168.x.x

Connecting to host 192.168.x.x, port 5201
[  5] local 192.168.x.x port 49509 connected to 192.168.x.x port 5201

[ ID] Interval                 Transfer        Bitrate               Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec   828 MBytes   116 Mbits/sec  0.000 ms  0/599931 (0%)  sender
[  5]   0.00-60.05  sec   824 MBytes   115 Mbits/sec  0.123 ms  2991/599924 (0.5%)  receiver

Node 3 client TCP test <-> Node 1 server:

LuCI -> Status -> Overview -> Load Average 0.69, 0.26, 0.21

iperf3 -t 60 -P 5 -w 64K -c 192.168.x.x

Connecting to host 192.168.x.x, port 5201
[  5] local 192.168.x.x port 49509 connected to 192.168.x.x port 5201

[ ID] Interval                   Transfer          Bitrate             Retr
[SUM]   0.00-60.00  sec  1.88 GBytes   269 Mbits/sec  364             sender
[SUM]   0.00-60.01  sec  1.88 GBytes   268 Mbits/sec                  receiver


**Node 3 client UDP test <-> Node 1 server::**

LuCI -> Status -> Overview -> Load Average -> 0.81, 0.73, 0.51

iperf3 -u -t 60 -b 1G -c 192.168.x.x

Connecting to host 192.168.x.x, port 5201
[  5] local 192.168.x.x port 46435 connected to 192.168.x.x port 5201

[ ID] Interval                Transfer            Bitrate         Jitter           Lost/Total Datagrams
[  5]   0.00-60.00  sec   809 MBytes   113 Mbits/sec  0.000 ms  0/585943 (0%)  sender
[  5]   0.00-60.05  sec   805 MBytes   112 Mbits/sec  0.523 ms  2880/585920 (0.49%)  receiver
1 Like

all nodes are EA8300

I'm very jealous right now, hehe. Good to know that mesh point mode is working with the ath10k-ct modules on the EA8300. Will keep note of that for sure.

Tests done with mesh node quad core CPU, Qualcomm IPQ4019.

By any chance, are you still able to run the tests through the nodes instead? You could use any pair of devices that have gigabit NIC and a decent processor. My experience with throughput tests is that the results from running iperf3 on the mesh nodes themselves can be quite misleading. (See also my comment below regarding the reported results.)

The # of retries (335 over 1min) seems a little high. This is also true for the other TCP tests. If you lower your window size by half the one I used (-w 32K) or increase it (-w 80K), do you still get that many re-connection attempts? Connection is getting lost more often than usual for such a short distance.

Your nodes are performing worse via UDP than TCP, which is odd. Notice that the UDP sender is also maxing at roughly 110Mbits/sec. There is a significant bottleneck here. Would definitely try running iperf through the nodes instead. Multiple things do not look right.

Thanks for posting the data. Very interesting results despite the unusual patterns I pointed out. I'll take note of them for future reference. (Thinking about updating the guide with a section about mesh performance and this might come handy.)

Machine 1 -> Node 1 <---> Node 2 <- Machine 2

*all settings same as before

Machine 1 -> Node 1 <---> Node 2 <- Machine 2

iperf3 -s  (server on machine 2)

iperf3 -t 60 -P 5 -w 32K -c 192.168.x.x  (client on machine 1)

TCP Tests:

test 1
[SUM]   0.00-60.00  sec  1.35 GBytes   194 Mbits/sec  309             sender
[SUM]   0.00-60.01  sec  1.35 GBytes   194 Mbits/sec                  receiver

test 2
[SUM]   0.00-60.00  sec  1.29 GBytes   184 Mbits/sec  276             sender
[SUM]   0.00-60.00  sec  1.29 GBytes   184 Mbits/sec                  receiver

test 3
[SUM]   0.00-60.00  sec  1.17 GBytes   168 Mbits/sec  347             sender
[SUM]   0.00-60.00  sec  1.17 GBytes   168 Mbits/sec                  receiver



iperf3 -t 60 -P 5 -w 64K -c 192.168.x.x  (client on machine 1)

test 1
[SUM]   0.00-60.00  sec  1.75 GBytes   251 Mbits/sec   67             sender
[SUM]   0.00-60.01  sec  1.75 GBytes   251 Mbits/sec                  receiver

test 2
[SUM]   0.00-60.00  sec  1.78 GBytes   255 Mbits/sec   66             sender
[SUM]   0.00-60.00  sec  1.78 GBytes   255 Mbits/sec                  receiver

test3
[SUM]   0.00-60.00  sec  1.90 GBytes   272 Mbits/sec  234             sender
[SUM]   0.00-60.01  sec  1.90 GBytes   272 Mbits/sec                  receiver



iperf3 -t 60 -P 5 -w 80K -c 192.168.x.x  (client on machine 1)

test 1
[SUM]   0.00-60.00  sec  2.02 GBytes   290 Mbits/sec   22             sender
[SUM]   0.00-60.01  sec  2.02 GBytes   290 Mbits/sec                  receiver

test 2
[SUM]   0.00-60.00  sec  2.02 GBytes   289 Mbits/sec   29             sender
[SUM]   0.00-60.01  sec  2.02 GBytes   289 Mbits/sec                  receiver

test 3
[SUM]   0.00-60.00  sec  2.11 GBytes   302 Mbits/sec   49             sender
[SUM]   0.00-60.01  sec  2.11 GBytes   302 Mbits/sec                  receiver

UDP Tests:

UDP Tests:

iperf3 -u -t 60 -b 1G -c 192.168.x.x  (client on machine 1)

test 1
[ ID] Interval                Transfer          Bitrate              Jitter         Lost/Total Datagrams
[  5]   0.00-60.00  sec  4.59 GBytes   657 Mbits/sec  0.000 ms  0/3401013 (0%)  sender
[  5]   0.00-60.21  sec  2.01 GBytes   286 Mbits/sec  0.052 ms  1912722/3401005 (56%)  receiver

test 2
[ ID] Interval                Transfer          Bitrate              Jitter         Lost/Total Datagrams
[  5]   0.00-60.00  sec  4.62 GBytes   662 Mbits/sec  0.000 ms  0/3427184 (0%)  sender
[  5]   0.00-60.03  sec  2.14 GBytes   306 Mbits/sec  0.125 ms  1843343/3427173 (54%)  receiver

test 3
[ ID] Interval                 Transfer          Bitrate             Jitter         Lost/Total Datagrams
[  5]   0.00-60.00  sec  4.63 GBytes   663 Mbits/sec  0.000 ms  0/3435782 (0%)  sender
[  5]   0.00-60.06  sec  2.39 GBytes   343 Mbits/sec  0.145 ms  1660086/3435769 (48%)  receiver

machine 1: Asus aspire 4733z-4418 (SSD upgrade), goes through an unmanaged switch before Node 1
machine 2: T420 (SSD upgrade), connected directly to Node 2.

...UDP tests: -b 1G ...is a little high for the EA8300 radios 2tx2r 866 Mbit/s
...maybe the receiver (machine 1) is dropping so many UDP because it is older / had other windows and apps running? I'll do a reverse test later perhaps?
...UDP was bottlenecked via the "APs only test" as previously noted.
...ubuntu lists both NICs @ 1000MB
...both machines are wired up with CAT5 (3-6ft cables) because my ISP is only 150 Mbit/s so I didn't care as I can barely hit 100 Mbit/s with VPN's, short runs can hit 1 Gbps (?), etc.. I have CAT6 / could redo some tests with full CAT6, (CAT6 < 150ft can do 10Gbps allegedly).
...I have a faster WIN10 laptop I could test with.

:face_with_monocle:

1 Like

Your latest results are looking fine, as I pointed out in our private messages. The TCP tests continued to show a fairly high retry rate (mean 331 over the three tests) but it's nothing to be too worried about. The UDP tests indicate that your mesh network is performing very well throughput-wise.

...both machines are wired up with CAT5 (3-6ft cables) because my ISP is only 150 Mbit/s so I didn't care as I can barely hit 100 Mbit/s with VPN's, short runs can hit 1 Gbps (?), etc.. I have CAT6 / could redo some tests with full CAT6, (CAT6 < 150ft can do 10Gbps allegedly).

I think you meant CAT5e. That's totally fine.

Thanks for sharing the data. Very interesting indeed. Now waiting for @samba2 .

*same as before except new machine 1

Retest

-Swap out machine 1 (Aspire) → X131e , i3-3227U CPU @ 1.90GHz, 8GB SODIMM DDR3) Synchronous 1333 MHz (0.8 ns), 256GB SSD

-Machine 2: T420, i5-2520M CPU @ 2.50GHz, 2 x 4GB SODIMM DDR3 Synchronous 1333 MHz (0.8 ns), 256 GB SSD

-both running ubuntu 20.04, w/ 10/100/1000 NIC

-short runs of CAT5 unchanged, pretty sure its not enhanced


*same as before except new machine 1

Retest

-Swap out machine 1 (Aspire) →  X131e , i3-3227U CPU @ 1.90GHz, 8GB SODIMM DDR3) Synchronous 1333 MHz (0.8 ns)

-Machine 2: T420, i5-2520M CPU @ 2.50GHz, 2 x 4GB SODIMM DDR3 Synchronous 1333 MHz (0.8 ns)

-both running ubuntu 20.04

-short runs of CAT5 unchanged

$ iperf3 -u -t 180 -w 80K -b 1G -c 192.168.1.125 - R
Connecting to host 192.168.1.125, port 5201
[  5] local 192.168.1.111 port 56896 connected to 192.168.1.125 port 5201
[ ID] Interval           Transfer     Bitrate         Total Datagrams
[  5]   0.00-1.00   sec   108 MBytes   909 Mbits/sec  78473  
[  5]   1.00-2.00   sec   111 MBytes   930 Mbits/sec  80297  
[  5]   2.00-3.00   sec   111 MBytes   931 Mbits/sec  80381  
[  5]   3.00-4.00   sec   113 MBytes   945 Mbits/sec  81588  
[  5]   4.00-5.00   sec   111 MBytes   932 Mbits/sec  80416  
[  5]   5.00-6.00   sec   111 MBytes   933 Mbits/sec  80552  
[  5]   6.00-7.00   sec   112 MBytes   941 Mbits/sec  81212  
[  5]   7.00-8.00   sec   113 MBytes   945 Mbits/sec  81620  
[  5]   8.00-9.00   sec   113 MBytes   948 Mbits/sec  81805  
[  5]   9.00-10.00  sec   113 MBytes   945 Mbits/sec  81541  
[  5]  10.00-11.00  sec   111 MBytes   932 Mbits/sec  80422  
[  5]  11.00-12.00  sec   111 MBytes   930 Mbits/sec  80325  
[  5]  12.00-13.00  sec   112 MBytes   943 Mbits/sec  81368  
[  5]  13.00-14.00  sec   114 MBytes   956 Mbits/sec  82548  
[  5]  14.00-15.00  sec   112 MBytes   939 Mbits/sec  81019  
[  5]  15.00-16.00  sec   111 MBytes   932 Mbits/sec  80481  
[  5]  16.00-17.00  sec   111 MBytes   930 Mbits/sec  80315  
[  5]  17.00-18.00  sec   111 MBytes   932 Mbits/sec  80462  
[  5]  18.00-19.00  sec   113 MBytes   946 Mbits/sec  81697  
[  5]  19.00-20.00  sec   112 MBytes   937 Mbits/sec  80903  
[  5]  20.00-21.00  sec   114 MBytes   956 Mbits/sec  82554  
[  5]  21.00-22.00  sec   112 MBytes   938 Mbits/sec  80932  
[  5]  22.00-23.00  sec   112 MBytes   937 Mbits/sec  80857  
[  5]  23.00-24.00  sec   112 MBytes   943 Mbits/sec  81414  
[  5]  24.00-25.00  sec   111 MBytes   931 Mbits/sec  80353  
[  5]  25.00-26.00  sec   113 MBytes   945 Mbits/sec  81603  
[  5]  26.00-27.00  sec   111 MBytes   932 Mbits/sec  80446  
[  5]  27.00-28.00  sec   114 MBytes   954 Mbits/sec  82383  
[  5]  28.00-29.00  sec   112 MBytes   939 Mbits/sec  81042  
[  5]  29.00-30.00  sec   114 MBytes   952 Mbits/sec  82199  
[  5]  30.00-31.00  sec   112 MBytes   943 Mbits/sec  81373  
[  5]  31.00-32.00  sec   111 MBytes   935 Mbits/sec  80708  
[  5]  32.00-33.00  sec   111 MBytes   931 Mbits/sec  80351  
[  5]  33.00-34.00  sec   111 MBytes   930 Mbits/sec  80309  
[  5]  34.00-35.00  sec   112 MBytes   939 Mbits/sec  81064  
[  5]  35.00-36.00  sec   112 MBytes   937 Mbits/sec  80907  
[  5]  36.00-37.00  sec   111 MBytes   932 Mbits/sec  80433  
[  5]  37.00-38.00  sec   111 MBytes   931 Mbits/sec  80380  
[  5]  38.00-39.00  sec   113 MBytes   945 Mbits/sec  81571  
[  5]  39.00-40.00  sec   112 MBytes   937 Mbits/sec  80863  
[  5]  40.00-41.00  sec   111 MBytes   932 Mbits/sec  80458  
[  5]  41.00-42.00  sec   112 MBytes   941 Mbits/sec  81235  
[  5]  42.00-43.00  sec   112 MBytes   942 Mbits/sec  81327  
[  5]  43.00-44.00  sec   111 MBytes   932 Mbits/sec  80441  
[  5]  44.00-45.00  sec   111 MBytes   933 Mbits/sec  80535  
[  5]  45.00-46.00  sec   111 MBytes   934 Mbits/sec  80633  
[  5]  46.00-47.00  sec   111 MBytes   931 Mbits/sec  80393  
[  5]  47.00-48.00  sec   113 MBytes   944 Mbits/sec  81501  
[  5]  48.00-49.00  sec   111 MBytes   932 Mbits/sec  80466  
[  5]  49.00-50.00  sec   113 MBytes   948 Mbits/sec  81825  
[  5]  50.00-51.00  sec   111 MBytes   929 Mbits/sec  80220  
[  5]  51.00-52.00  sec   113 MBytes   949 Mbits/sec  81906  
[  5]  52.00-53.00  sec   112 MBytes   941 Mbits/sec  81193  
[  5]  53.00-54.00  sec   113 MBytes   948 Mbits/sec  81865  
[  5]  54.00-55.00  sec   114 MBytes   956 Mbits/sec  82534  
[  5]  55.00-56.00  sec   113 MBytes   947 Mbits/sec  81714  
[  5]  56.00-57.00  sec   113 MBytes   946 Mbits/sec  81641  
[  5]  57.00-58.00  sec   113 MBytes   944 Mbits/sec  81480  
[  5]  58.00-59.00  sec   113 MBytes   945 Mbits/sec  81616  
[  5]  59.00-60.00  sec   111 MBytes   932 Mbits/sec  80444  
[  5]  60.00-61.00  sec   113 MBytes   949 Mbits/sec  81909  
[  5]  61.00-62.00  sec   113 MBytes   950 Mbits/sec  82044  
[  5]  62.00-63.00  sec   112 MBytes   937 Mbits/sec  80912  
[  5]  63.00-64.00  sec   111 MBytes   931 Mbits/sec  80375  
[  5]  64.00-65.00  sec   113 MBytes   945 Mbits/sec  81551  
[  5]  65.00-66.00  sec   111 MBytes   935 Mbits/sec  80711  
[  5]  66.00-67.00  sec   112 MBytes   942 Mbits/sec  81354  
[  5]  67.00-68.00  sec   112 MBytes   939 Mbits/sec  81076  
[  5]  68.00-69.00  sec   114 MBytes   956 Mbits/sec  82554  
[  5]  69.00-70.00  sec   111 MBytes   932 Mbits/sec  80471  
[  5]  70.00-71.00  sec   113 MBytes   945 Mbits/sec  81618  
[  5]  71.00-72.00  sec   112 MBytes   939 Mbits/sec  81090  
[  5]  72.00-73.00  sec   111 MBytes   930 Mbits/sec  80300  
[  5]  73.00-74.00  sec   113 MBytes   948 Mbits/sec  81822  
[  5]  74.00-75.00  sec   114 MBytes   954 Mbits/sec  82372  
[  5]  75.00-76.00  sec   113 MBytes   946 Mbits/sec  81659  
[  5]  76.00-77.00  sec   111 MBytes   933 Mbits/sec  80525  
[  5]  77.00-78.00  sec   114 MBytes   954 Mbits/sec  82365  
[  5]  78.00-79.00  sec   113 MBytes   950 Mbits/sec  81989  
[  5]  79.00-80.00  sec   111 MBytes   931 Mbits/sec  80413  
[  5]  80.00-81.00  sec   113 MBytes   952 Mbits/sec  82150  
[  5]  81.00-82.00  sec   111 MBytes   933 Mbits/sec  80533  
[  5]  82.00-83.00  sec   111 MBytes   931 Mbits/sec  80406  
[  5]  83.00-84.00  sec   112 MBytes   939 Mbits/sec  81081  
[  5]  84.00-85.00  sec   113 MBytes   946 Mbits/sec  81663  
[  5]  85.00-86.00  sec   111 MBytes   930 Mbits/sec  80319  
[  5]  86.00-87.00  sec   113 MBytes   947 Mbits/sec  81782  
[  5]  87.00-88.00  sec   113 MBytes   948 Mbits/sec  81817  
[  5]  88.00-89.00  sec   112 MBytes   936 Mbits/sec  80798  
[  5]  89.00-90.00  sec   111 MBytes   933 Mbits/sec  80544  
[  5]  90.00-91.00  sec   113 MBytes   945 Mbits/sec  81535  
[  5]  91.00-92.00  sec   112 MBytes   937 Mbits/sec  80919  
[  5]  92.00-93.00  sec   111 MBytes   933 Mbits/sec  80571  
[  5]  93.00-94.00  sec   111 MBytes   930 Mbits/sec  80279  
[  5]  94.00-95.00  sec   112 MBytes   940 Mbits/sec  81118  
[  5]  95.00-96.00  sec   111 MBytes   932 Mbits/sec  80452  
[  5]  96.00-97.00  sec   111 MBytes   932 Mbits/sec  80489  
[  5]  97.00-98.00  sec   114 MBytes   955 Mbits/sec  82432  
[  5]  98.00-99.00  sec   113 MBytes   950 Mbits/sec  81994  
[  5]  99.00-100.00 sec   112 MBytes   941 Mbits/sec  81238  
[  5] 100.00-101.00 sec   111 MBytes   934 Mbits/sec  80665  
[  5] 101.00-102.00 sec   111 MBytes   931 Mbits/sec  80357  
[  5] 102.00-103.00 sec   113 MBytes   944 Mbits/sec  81533  
[  5] 103.00-104.00 sec   114 MBytes   955 Mbits/sec  82482  
[  5] 104.00-105.00 sec   111 MBytes   933 Mbits/sec  80576  
[  5] 105.00-106.00 sec   114 MBytes   956 Mbits/sec  82523  
[  5] 106.00-107.00 sec   111 MBytes   929 Mbits/sec  80196  
[  5] 107.00-108.00 sec   111 MBytes   931 Mbits/sec  80367  
[  5] 108.00-109.00 sec   111 MBytes   931 Mbits/sec  80357  
[  5] 109.00-110.00 sec   111 MBytes   931 Mbits/sec  80364  
[  5] 110.00-111.00 sec   111 MBytes   931 Mbits/sec  80360  
[  5] 111.00-112.00 sec   111 MBytes   931 Mbits/sec  80369  
[  5] 112.00-113.00 sec   111 MBytes   930 Mbits/sec  80260  
[  5] 113.00-114.00 sec   113 MBytes   947 Mbits/sec  81779  
[  5] 114.00-115.00 sec   113 MBytes   950 Mbits/sec  81988  
[  5] 115.00-116.00 sec   111 MBytes   931 Mbits/sec  80354  
[  5] 116.00-117.00 sec   111 MBytes   928 Mbits/sec  80095  
[  5] 117.00-118.00 sec   114 MBytes   955 Mbits/sec  82429  
[  5] 118.00-119.00 sec   111 MBytes   934 Mbits/sec  80653  
[  5] 119.00-120.00 sec   113 MBytes   947 Mbits/sec  81715  
[  5] 120.00-121.00 sec   113 MBytes   947 Mbits/sec  81785  
[  5] 121.00-122.00 sec   113 MBytes   946 Mbits/sec  81622  
[  5] 122.00-123.00 sec   111 MBytes   929 Mbits/sec  80224  
[  5] 123.00-124.00 sec   114 MBytes   953 Mbits/sec  82295  
[  5] 124.00-125.00 sec   112 MBytes   940 Mbits/sec  81112  
[  5] 125.00-126.00 sec   112 MBytes   937 Mbits/sec  80906  
[  5] 126.00-127.00 sec   113 MBytes   947 Mbits/sec  81793  
[  5] 127.00-128.00 sec   113 MBytes   947 Mbits/sec  81776  
[  5] 128.00-129.00 sec   112 MBytes   943 Mbits/sec  81372  
[  5] 129.00-130.00 sec   112 MBytes   940 Mbits/sec  81146  
[  5] 130.00-131.00 sec   111 MBytes   931 Mbits/sec  80376  
[  5] 131.00-132.00 sec   113 MBytes   945 Mbits/sec  81605  
[  5] 132.00-133.00 sec   113 MBytes   952 Mbits/sec  82188  
[  5] 133.00-134.00 sec   111 MBytes   934 Mbits/sec  80662  
[  5] 134.00-135.00 sec   111 MBytes   933 Mbits/sec  80542  
[  5] 135.00-136.00 sec   114 MBytes   956 Mbits/sec  82555  
[  5] 136.00-137.00 sec   112 MBytes   937 Mbits/sec  80849  
[  5] 137.00-138.00 sec   111 MBytes   931 Mbits/sec  80340  
[  5] 138.00-139.00 sec   114 MBytes   955 Mbits/sec  82464  
[  5] 139.00-140.00 sec   112 MBytes   936 Mbits/sec  80833  
[  5] 140.00-141.00 sec   111 MBytes   932 Mbits/sec  80465  
[  5] 141.00-142.00 sec   114 MBytes   954 Mbits/sec  82323  
[  5] 142.00-143.00 sec   111 MBytes   934 Mbits/sec  80659  
[  5] 143.00-144.00 sec   113 MBytes   947 Mbits/sec  81760  
[  5] 144.00-145.00 sec   111 MBytes   932 Mbits/sec  80416  
[  5] 145.00-146.00 sec   114 MBytes   954 Mbits/sec  82352  
[  5] 146.00-147.00 sec   111 MBytes   931 Mbits/sec  80380  
[  5] 147.00-148.00 sec   113 MBytes   947 Mbits/sec  81768  
[  5] 148.00-149.00 sec  88.6 MBytes   743 Mbits/sec  64161  
[  5] 149.00-150.00 sec   114 MBytes   952 Mbits/sec  82194  
[  5] 150.00-151.00 sec   112 MBytes   937 Mbits/sec  80887  
[  5] 151.00-152.00 sec   111 MBytes   932 Mbits/sec  80422  
[  5] 152.00-153.00 sec   114 MBytes   954 Mbits/sec  82358  
[  5] 153.00-154.00 sec   111 MBytes   931 Mbits/sec  80340  
[  5] 154.00-155.00 sec   111 MBytes   928 Mbits/sec  80144  
[  5] 155.00-156.00 sec   112 MBytes   941 Mbits/sec  81235  
[  5] 156.00-157.00 sec   111 MBytes   931 Mbits/sec  80347  
[  5] 157.00-158.00 sec   113 MBytes   948 Mbits/sec  81861  
[  5] 158.00-159.00 sec   113 MBytes   949 Mbits/sec  81904  
[  5] 159.00-160.00 sec   112 MBytes   936 Mbits/sec  80833  
[  5] 160.00-161.00 sec   111 MBytes   931 Mbits/sec  80341  
[  5] 161.00-162.00 sec   113 MBytes   947 Mbits/sec  81770  
[  5] 162.00-163.00 sec   111 MBytes   932 Mbits/sec  80420  
[  5] 163.00-164.00 sec   111 MBytes   934 Mbits/sec  80607  
[  5] 164.00-165.00 sec   112 MBytes   940 Mbits/sec  81144  
[  5] 165.00-166.00 sec   113 MBytes   947 Mbits/sec  81748  
[  5] 166.00-167.00 sec   111 MBytes   931 Mbits/sec  80357  
[  5] 167.00-168.00 sec   111 MBytes   931 Mbits/sec  80344  
[  5] 168.00-169.00 sec   111 MBytes   934 Mbits/sec  80669  
[  5] 169.00-170.00 sec  87.0 MBytes   730 Mbits/sec  63010  
[  5] 170.00-171.00 sec   114 MBytes   956 Mbits/sec  82537  
[  5] 171.00-172.00 sec   113 MBytes   952 Mbits/sec  82183  
[  5] 172.00-173.00 sec   113 MBytes   947 Mbits/sec  81718  
[  5] 173.00-174.00 sec   111 MBytes   932 Mbits/sec  80434  
[  5] 174.00-175.00 sec   111 MBytes   933 Mbits/sec  80546  
[  5] 175.00-176.00 sec   111 MBytes   932 Mbits/sec  80443  
[  5] 176.00-177.00 sec   114 MBytes   955 Mbits/sec  82406  
[  5] 177.00-178.00 sec   112 MBytes   942 Mbits/sec  81285  
[  5] 178.00-179.00 sec   114 MBytes   954 Mbits/sec  82374  
[  5] 179.00-180.00 sec  86.4 MBytes   725 Mbits/sec  62559  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-180.00 sec  19.6 GBytes   936 Mbits/sec  0.000 ms  0/14551395 (0%)  sender
[  5]   0.00-180.21 sec  7.53 GBytes   359 Mbits/sec  0.069 ms  8971042/14551120 (62%)  receiver

iperf Done.

iperf3 -u -t 180 -w 80K -b 1G -c 192.168.1.125
Connecting to host 192.168.1.125, port 5201
[  5] local 192.168.1.111 port 48910 connected to 192.168.1.125 port 5201
[ ID] Interval           Transfer     Bitrate         Total Datagrams
[  5]   0.00-1.00   sec   112 MBytes   940 Mbits/sec  81116  
[  5]   1.00-2.00   sec   111 MBytes   934 Mbits/sec  80662  
[  5]   2.00-3.00   sec   113 MBytes   948 Mbits/sec  81824  
[  5]   3.00-4.00   sec   112 MBytes   938 Mbits/sec  80989  
[  5]   4.00-5.00   sec   112 MBytes   938 Mbits/sec  80990  
[  5]   5.00-6.00   sec   111 MBytes   933 Mbits/sec  80553  
[  5]   6.00-7.00   sec   112 MBytes   936 Mbits/sec  80764  
[  5]   7.00-8.00   sec   114 MBytes   954 Mbits/sec  82382  
[  5]   8.00-9.00   sec   113 MBytes   944 Mbits/sec  81499  
[  5]   9.00-10.00  sec   111 MBytes   933 Mbits/sec  80552  
[  5]  10.00-11.00  sec   114 MBytes   954 Mbits/sec  82357  
[  5]  11.00-12.00  sec   111 MBytes   932 Mbits/sec  80424  
[  5]  12.00-13.00  sec   112 MBytes   935 Mbits/sec  80744  
[  5]  13.00-14.00  sec   112 MBytes   939 Mbits/sec  81050  
[  5]  14.00-15.00  sec   112 MBytes   940 Mbits/sec  81111  
[  5]  15.00-16.00  sec   111 MBytes   931 Mbits/sec  80403  
[  5]  16.00-17.00  sec   112 MBytes   937 Mbits/sec  80908  
[  5]  17.00-18.00  sec   112 MBytes   938 Mbits/sec  80994  
[  5]  18.00-19.00  sec   111 MBytes   932 Mbits/sec  80447  
[  5]  19.00-20.00  sec   114 MBytes   955 Mbits/sec  82445  
[  5]  20.00-21.00  sec   111 MBytes   935 Mbits/sec  80684  
[  5]  21.00-22.00  sec   113 MBytes   951 Mbits/sec  82084  
[  5]  22.00-23.00  sec   111 MBytes   930 Mbits/sec  80310  
[  5]  23.00-24.00  sec   113 MBytes   951 Mbits/sec  82066  
[  5]  24.00-25.00  sec   113 MBytes   944 Mbits/sec  81472  
[  5]  25.00-26.00  sec   112 MBytes   938 Mbits/sec  80982  
[  5]  26.00-27.00  sec   113 MBytes   945 Mbits/sec  81592  
[  5]  27.00-28.00  sec   111 MBytes   931 Mbits/sec  80388  
[  5]  28.00-29.00  sec   112 MBytes   936 Mbits/sec  80841  
[  5]  29.00-30.00  sec   111 MBytes   930 Mbits/sec  80308  
[  5]  30.00-31.00  sec   112 MBytes   938 Mbits/sec  80987  
[  5]  31.00-32.00  sec   113 MBytes   952 Mbits/sec  82181  
[  5]  32.00-33.00  sec   111 MBytes   932 Mbits/sec  80474  
[  5]  33.00-34.00  sec   111 MBytes   931 Mbits/sec  80386  
[  5]  34.00-35.00  sec   113 MBytes   951 Mbits/sec  82069  
[  5]  35.00-36.00  sec   111 MBytes   931 Mbits/sec  80389  
[  5]  36.00-37.00  sec   112 MBytes   937 Mbits/sec  80918  
[  5]  37.00-38.00  sec   112 MBytes   941 Mbits/sec  81212  
[  5]  38.00-39.00  sec   111 MBytes   931 Mbits/sec  80403  
[  5]  39.00-40.00  sec   112 MBytes   940 Mbits/sec  81131  
[  5]  40.00-41.00  sec   113 MBytes   949 Mbits/sec  81898  
[  5]  41.00-42.00  sec   111 MBytes   932 Mbits/sec  80477  
[  5]  42.00-43.00  sec   114 MBytes   952 Mbits/sec  82203  
[  5]  43.00-44.00  sec   112 MBytes   937 Mbits/sec  80917  
[  5]  44.00-45.00  sec   112 MBytes   937 Mbits/sec  80894  
[  5]  45.00-46.00  sec   111 MBytes   935 Mbits/sec  80729  
[  5]  46.00-47.00  sec   111 MBytes   931 Mbits/sec  80396  
[  5]  47.00-48.00  sec   112 MBytes   943 Mbits/sec  81375  
[  5]  48.00-49.00  sec   111 MBytes   931 Mbits/sec  80353  
[  5]  49.00-50.00  sec   112 MBytes   943 Mbits/sec  81406  
[  5]  50.00-51.00  sec   113 MBytes   947 Mbits/sec  81760  
[  5]  51.00-52.00  sec   113 MBytes   950 Mbits/sec  82030  
[  5]  52.00-53.00  sec   114 MBytes   955 Mbits/sec  82482  
[  5]  53.00-54.00  sec   111 MBytes   932 Mbits/sec  80461  
[  5]  54.00-55.00  sec   113 MBytes   950 Mbits/sec  82014  
[  5]  55.00-56.00  sec   113 MBytes   947 Mbits/sec  81778  
[  5]  56.00-57.00  sec   112 MBytes   942 Mbits/sec  81352  
[  5]  57.00-58.00  sec   111 MBytes   931 Mbits/sec  80365  
[  5]  58.00-59.00  sec   111 MBytes   931 Mbits/sec  80355  
[  5]  59.00-60.00  sec   113 MBytes   946 Mbits/sec  81691  
[  5]  60.00-61.00  sec   112 MBytes   942 Mbits/sec  81294  
[  5]  61.00-62.00  sec   108 MBytes   908 Mbits/sec  78354  
[  5]  62.00-63.00  sec  92.3 MBytes   775 Mbits/sec  66874  
[  5]  63.00-64.00  sec   112 MBytes   937 Mbits/sec  80849  
[  5]  64.00-65.00  sec   112 MBytes   939 Mbits/sec  81044  
[  5]  65.00-66.00  sec   113 MBytes   944 Mbits/sec  81527  
[  5]  66.00-67.00  sec   113 MBytes   946 Mbits/sec  81663  
[  5]  67.00-68.00  sec   111 MBytes   931 Mbits/sec  80377  
[  5]  68.00-69.00  sec   111 MBytes   931 Mbits/sec  80372  
[  5]  69.00-70.00  sec   113 MBytes   947 Mbits/sec  81762  
[  5]  70.00-71.00  sec   112 MBytes   936 Mbits/sec  80814  
[  5]  71.00-72.00  sec   111 MBytes   931 Mbits/sec  80356  
[  5]  72.00-73.00  sec   112 MBytes   938 Mbits/sec  81000  
[  5]  73.00-74.00  sec   111 MBytes   931 Mbits/sec  80372  
[  5]  74.00-75.00  sec   111 MBytes   932 Mbits/sec  80418  
[  5]  75.00-76.00  sec   112 MBytes   938 Mbits/sec  80966  
[  5]  76.00-77.00  sec   113 MBytes   945 Mbits/sec  81605  
[  5]  77.00-78.00  sec   113 MBytes   947 Mbits/sec  81761  
[  5]  78.00-79.00  sec  88.0 MBytes   738 Mbits/sec  63719  
[  5]  79.00-80.00  sec   114 MBytes   955 Mbits/sec  82479  
[  5]  80.00-81.00  sec   113 MBytes   946 Mbits/sec  81631  
[  5]  81.00-82.00  sec   114 MBytes   955 Mbits/sec  82481  
[  5]  82.00-83.00  sec   114 MBytes   955 Mbits/sec  82444  
[  5]  83.00-84.00  sec   111 MBytes   932 Mbits/sec  80437  
[  5]  84.00-85.00  sec   113 MBytes   946 Mbits/sec  81678  
[  5]  85.00-86.00  sec   113 MBytes   949 Mbits/sec  81885  
[  5]  86.00-87.00  sec   111 MBytes   933 Mbits/sec  80508  
[  5]  87.00-88.00  sec   112 MBytes   936 Mbits/sec  80798  
[  5]  88.00-89.00  sec   113 MBytes   947 Mbits/sec  81785  
[  5]  89.00-90.00  sec   111 MBytes   934 Mbits/sec  80633  
[  5]  90.00-91.00  sec  87.9 MBytes   737 Mbits/sec  63640  
[  5]  91.00-92.00  sec   111 MBytes   932 Mbits/sec  80418  
[  5]  92.00-93.00  sec   113 MBytes   946 Mbits/sec  81678  
[  5]  93.00-94.00  sec   112 MBytes   940 Mbits/sec  81148  
[  5]  94.00-95.00  sec   112 MBytes   938 Mbits/sec  81009  
[  5]  95.00-96.00  sec   111 MBytes   934 Mbits/sec  80648  
[  5]  96.00-97.00  sec   113 MBytes   946 Mbits/sec  81683  
[  5]  97.00-98.00  sec   114 MBytes   954 Mbits/sec  82324  
[  5]  98.00-99.00  sec   111 MBytes   932 Mbits/sec  80463  
[  5]  99.00-100.00 sec   112 MBytes   940 Mbits/sec  81158  
[  5] 100.00-101.00 sec   111 MBytes   934 Mbits/sec  80592  
[  5] 101.00-102.00 sec   111 MBytes   931 Mbits/sec  80369  
[  5] 102.00-103.00 sec   111 MBytes   931 Mbits/sec  80408  
[  5] 103.00-104.00 sec   114 MBytes   955 Mbits/sec  82469  
[  5] 104.00-105.00 sec   111 MBytes   931 Mbits/sec  80400  
[  5] 105.00-106.00 sec   111 MBytes   931 Mbits/sec  80374  
[  5] 106.00-107.00 sec   111 MBytes   931 Mbits/sec  80369  
[  5] 107.00-108.00 sec   111 MBytes   931 Mbits/sec  80369  
[  5] 108.00-109.00 sec   113 MBytes   946 Mbits/sec  81702  
[  5] 109.00-110.00 sec   113 MBytes   950 Mbits/sec  81973  
[  5] 110.00-111.00 sec   112 MBytes   941 Mbits/sec  81250  
[  5] 111.00-112.00 sec   111 MBytes   931 Mbits/sec  80390  
[  5] 112.00-113.00 sec   112 MBytes   943 Mbits/sec  81418  
[  5] 113.00-114.00 sec   113 MBytes   945 Mbits/sec  81591  
[  5] 114.00-115.00 sec   111 MBytes   931 Mbits/sec  80399  
[  5] 115.00-116.00 sec   112 MBytes   941 Mbits/sec  81191  
[  5] 116.00-117.00 sec  88.8 MBytes   745 Mbits/sec  64340  
[  5] 117.00-118.00 sec   112 MBytes   936 Mbits/sec  80774  
[  5] 118.00-119.00 sec   114 MBytes   955 Mbits/sec  82469  
[  5] 119.00-120.00 sec   111 MBytes   933 Mbits/sec  80531  
[  5] 120.00-121.00 sec  97.9 MBytes   821 Mbits/sec  70915  
[  5] 121.00-122.00 sec   102 MBytes   853 Mbits/sec  73641  
[  5] 122.00-123.00 sec   113 MBytes   949 Mbits/sec  81942  
[  5] 123.00-124.00 sec   113 MBytes   952 Mbits/sec  82159  
[  5] 124.00-125.00 sec   111 MBytes   932 Mbits/sec  80426  
[  5] 125.00-126.00 sec   112 MBytes   942 Mbits/sec  81361  
[  5] 126.00-127.00 sec   111 MBytes   931 Mbits/sec  80373  
[  5] 127.00-128.00 sec   111 MBytes   931 Mbits/sec  80382  
[  5] 128.00-129.00 sec   111 MBytes   931 Mbits/sec  80400  
[  5] 129.00-130.00 sec   113 MBytes   946 Mbits/sec  81660  
[  5] 130.00-131.00 sec   112 MBytes   939 Mbits/sec  81092  
[  5] 131.00-132.00 sec   111 MBytes   933 Mbits/sec  80559  
[  5] 132.00-133.00 sec   113 MBytes   946 Mbits/sec  81662  
[  5] 133.00-134.00 sec  86.1 MBytes   722 Mbits/sec  62346  
[  5] 134.00-135.00 sec   111 MBytes   931 Mbits/sec  80353  
[  5] 135.00-136.00 sec   112 MBytes   937 Mbits/sec  80906  
[  5] 136.00-137.00 sec   112 MBytes   940 Mbits/sec  81168  
[  5] 137.00-138.00 sec   114 MBytes   955 Mbits/sec  82419  
[  5] 138.00-139.00 sec   111 MBytes   932 Mbits/sec  80447  
[  5] 139.00-140.00 sec   112 MBytes   941 Mbits/sec  81243  
[  5] 140.00-141.00 sec   112 MBytes   941 Mbits/sec  81222  
[  5] 141.00-142.00 sec   113 MBytes   952 Mbits/sec  82188  
[  5] 142.00-143.00 sec   113 MBytes   946 Mbits/sec  81664  
[  5] 143.00-144.00 sec   114 MBytes   954 Mbits/sec  82334  
[  5] 144.00-145.00 sec   112 MBytes   937 Mbits/sec  80912  
[  5] 145.00-146.00 sec   114 MBytes   955 Mbits/sec  82418  
[  5] 146.00-147.00 sec   114 MBytes   954 Mbits/sec  82355  
[  5] 147.00-148.00 sec   112 MBytes   937 Mbits/sec  80920  
[  5] 148.00-149.00 sec   112 MBytes   943 Mbits/sec  81367  
[  5] 149.00-150.00 sec   113 MBytes   945 Mbits/sec  81619  
[  5] 150.00-151.00 sec   114 MBytes   955 Mbits/sec  82428  
[  5] 151.00-152.00 sec   114 MBytes   955 Mbits/sec  82454  
[  5] 152.00-153.00 sec   111 MBytes   932 Mbits/sec  80467  
[  5] 153.00-154.00 sec  88.0 MBytes   738 Mbits/sec  63697  
[  5] 154.00-155.00 sec   113 MBytes   951 Mbits/sec  82133  
[  5] 155.00-156.00 sec   113 MBytes   944 Mbits/sec  81489  
[  5] 156.00-157.00 sec   113 MBytes   945 Mbits/sec  81578  
[  5] 157.00-158.00 sec   111 MBytes   931 Mbits/sec  80378  
[  5] 158.00-159.00 sec   112 MBytes   943 Mbits/sec  81424  
[  5] 159.00-160.00 sec   112 MBytes   942 Mbits/sec  81336  
[  5] 160.00-161.00 sec   113 MBytes   952 Mbits/sec  82162  
[  5] 161.00-162.00 sec   111 MBytes   933 Mbits/sec  80504  
[  5] 162.00-163.00 sec   114 MBytes   953 Mbits/sec  82306  
[  5] 163.00-164.00 sec   112 MBytes   940 Mbits/sec  81179  
[  5] 164.00-165.00 sec   113 MBytes   947 Mbits/sec  81748  
[  5] 165.00-166.00 sec   111 MBytes   932 Mbits/sec  80439  
[  5] 166.00-167.00 sec   112 MBytes   937 Mbits/sec  80920  
[  5] 167.00-168.00 sec   114 MBytes   954 Mbits/sec  82390  
[  5] 168.00-169.00 sec   111 MBytes   932 Mbits/sec  80471  
[  5] 169.00-170.00 sec   111 MBytes   931 Mbits/sec  80329  
[  5] 170.00-171.00 sec   112 MBytes   943 Mbits/sec  81431  
[  5] 171.00-172.00 sec   113 MBytes   949 Mbits/sec  81944  
[  5] 172.00-173.00 sec   113 MBytes   947 Mbits/sec  81789  
[  5] 173.00-174.00 sec   112 MBytes   937 Mbits/sec  80901  
[  5] 174.00-175.00 sec   111 MBytes   932 Mbits/sec  80436  
[  5] 175.00-176.00 sec   112 MBytes   942 Mbits/sec  81334  
[  5] 176.00-177.00 sec   111 MBytes   931 Mbits/sec  80346  
[  5] 177.00-178.00 sec   111 MBytes   935 Mbits/sec  80715  
[  5] 178.00-179.00 sec   113 MBytes   946 Mbits/sec  81701  
[  5] 179.00-180.00 sec   111 MBytes   932 Mbits/sec  80485  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-180.00 sec  19.5 GBytes   933 Mbits/sec  0.000 ms  0/14490827 (0%)  sender
[  5]   0.00-180.22 sec  7.53 GBytes   359 Mbits/sec  0.287 ms  8909951/14490827 (61%)  receiver

Channel 157 VHT-80 is somewhat busy - but they all are except for DFS channels. I'm reluctant to switch over to DFS as this seems fast enough at >300Mbps throughput is twice my ISP line speed @ 150Mbps.

Thanks for helping! @cgomesu

@samba2 Did you get your mesh setup working? I'm looking into a similar setup to cover my property.

1 Like

I'm looking too (Home set-up with OpenWrt and Ubiquiti - #6 by lpyparmentier), it's late I'll check everything being said in this topic later. For tl;dr: I've bad performance on 2 mesh Unifi LR-6 (~200mbp/s) on self installed+configured OpenWRT while I've very better (400mbp/s the limit of ISP) with Orbi RBK23 (original OS, apparently based on OpenWRT also). All running on 5ghz band.

Hi,

I'm having the same issue on a mesh network using a pair of Meraki MR-33 AP's with OpenWRT 21.02.1. Firewall, dnsmasq an DHCP are stopped (devices are working as dumb APs), the mesh is using a 5Ghz link which creates a bridge between both AP ethernet ports and a 2,4Ghz SSID.

Regards.