Mesh network - bad performance

Hi,

We're about to setup a 802.11s mesh network routed by B.A.T.M.A.N adv. Although I closely followed the guidance of this blog post as well as the OpenWrt forum currently our network is barley usable. What we see is that the speed goes from high rates of 200-300 Mbit/s down to the (presumably) minimum of 6-7 Mbit/s. Speed stays low for some seconds and goes slowly back up again - to just drop again down to 6-7 Mbit/s. This seems to affect the whole network.

Setup

[Bridge 1]-----5 Ghz-----[Gateway]-----5 Ghz-----[Bridge 2]-----5 Ghz-----[Bridge 3]
              802.11s        |        802.11s                  802.11s
                          Internet  

The network is situated in an apartment building and provides multiple flats with access to the internet. Client access is provided at 2.4 Ghz, the 5 Ghz band is exclusively for meshing. The nodes are approx. 10-20 m apart from each other - always divided by at least one wall.

With a wifi analyzer I confirmed that our channel 149 is not used by someone else. Also the mesh nodes only see their direct neighbors (batctl n). The nodes at the edge (Bridge 1 and Bridge 3) only have 1 neighbor each. The nodes in the middle (Gateway and Bridge 2) have 2 neighbors each.

Experiments

As an experiment, I configured Bridge 1 and Gateway to exclusively communicate on their own channel - and the performance (measured with batctl tp) was just fine. I never saw these drops down to 6 Mbit/s. Instead the connection speed stayed constant and reliable at a high rate.

In the moment I brought in Bridge 2 and Bridge 3 again, the situation turned bad again - the speed drops described above returned.

Also, I tried to force Gateway to not use the low rates with this config (snippet):

wireless.radio0.basic_rate='12000 18000 24000 36000 48000 54000'
wireless.radio0.supported_rates='12000 18000 24000 36000 48000 54000'   
...
wireless.wmesh=wifi-iface                                                      
wireless.wmesh.device='radio0'                                                 
wireless.wmesh.ifname='if-mesh'                                                
wireless.wmesh.network='mesh'                                                  
wireless.wmesh.mode='mesh'      
wireless.wmesh.basic_rate='12000 18000 24000 36000 48000 54000'                
wireless.wmesh.supported_rates='12000 18000 24000 36000 48000 54000'
...

However, after applying the config I still saw the connection speed of the associated mesh neighbor (iwinfo if-mesh assoclist) drop to 6 Mbit/s. So I believe the config change had no effect.

Assumption

My assumption is that the frame collisions (I mean on the radio layer) leads to the bad performance. However, I wonder how other mesh networks do it differently. To my understanding it is required that all mesh nodes communicate via the same channel. How do you deal with the frame collisions of multiple nodes? And more importantly: What do you do to provide acceptable performance (e.g. 50 Mbit/s) in such a network?

Details

Hardware/ Firmware Spec all devices:

  • TP-Link Archer 7 V5
  • OpenWrt 19.07.7, r11306-c4a6851c72

Installed software (identical):

root@Gateway:~# opkg list-installed | egrep "kmod-ath10k|ath10k-firmware-qca988x|wpad-mesh-openssl|kmod-mac80211|kmod-cfg80211"
ath10k-firmware-qca988x - 2019-10-03-d622d160-1
kmod-ath10k - 4.14.221+4.19.161-1-1
kmod-cfg80211 - 4.14.221+4.19.161-1-1
kmod-mac80211 - 4.14.221+4.19.161-1-1
wpad-mesh-openssl - 2019-08-08-ca8c2bd2-7

Loaded firmware: 10.2.4-1.0-00047

logread output on startup:

...
Sun May 16 20:14:57 2021 kern.info kernel: [   13.309842] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
Sun May 16 20:14:57 2021 kern.warn kernel: [   13.623838] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with error -2
Sun May 16 20:14:57 2021 kern.warn kernel: [   13.634923] ath10k_pci 0000:00:00.0: Falling back to user helper
Sun May 16 20:14:57 2021 kern.err kernel: [   13.911257] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed
Sun May 16 20:14:57 2021 kern.warn kernel: [   13.924488] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2
Sun May 16 20:14:57 2021 kern.warn kernel: [   13.935596] ath10k_pci 0000:00:00.0: Falling back to user helper
Sun May 16 20:14:57 2021 kern.err kernel: [   14.152300] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
Sun May 16 20:14:57 2021 kern.info kernel: [   14.591884] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
Sun May 16 20:14:57 2021 kern.info kernel: [   14.601450] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
Sun May 16 20:14:57 2021 kern.info kernel: [   14.614497] ath10k_pci 0000:00:00.0: firmware ver 10.2.4-1.0-00047 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 35bd9258
Sun May 16 20:14:57 2021 kern.warn kernel: [   14.660214] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
Sun May 16 20:14:57 2021 kern.warn kernel: [   14.671024] ath10k_pci 0000:00:00.0: Falling back to user helper
Sun May 16 20:14:57 2021 kern.err kernel: [   14.783898] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
Sun May 16 20:14:57 2021 kern.info kernel: [   14.794552] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
Sun May 16 20:14:57 2021 kern.info kernel: [   15.919414] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.054509] ath: EEPROM regdomain: 0x0
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.054516] ath: EEPROM indicates default country code should be used
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.054519] ath: doing EEPROM country->regdmn map search
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.054532] ath: country maps to regdmn code: 0x3a
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.054537] ath: Country alpha2 being used: US
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.054540] ath: Regpair used: 0x3a
Sun May 16 20:14:57 2021 kern.info kernel: [   16.308123] batman_adv: B.A.T.M.A.N. advanced openwrt-2019.2-11 (compatibility version 15) loaded
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.360880] ath: EEPROM regdomain: 0x0
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.360888] ath: EEPROM indicates default country code should be used
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.360891] ath: doing EEPROM country->regdmn map search
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.360904] ath: country maps to regdmn code: 0x3a
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.360908] ath: Country alpha2 being used: US
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.360911] ath: Regpair used: 0x3a
Sun May 16 20:14:57 2021 kern.debug kernel: [   16.373336] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Sun May 16 20:14:57 2021 kern.info kernel: [   16.374884] ieee80211 phy1: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
Sun May 16 20:14:57 2021 user.info kernel: [   16.423460] kmodloader: done loading kernel modules from /etc/modules.d/*
...

The 802.11s configuration is (almost) identical for all devices:

# /etc/config/wireless
...
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option disabled '0'
        option channel '149'  # moved to here to guarantee no interference
        option txpower '20'

config wifi-iface 'wmesh'                       
        option device 'radio0'                  
        option ifname 'if-mesh'                 
        option network 'mesh'  
        option mode 'mesh'     
        option mesh_id 'our-house-mesh-backbone'
        option encryption 'sae'                 
        option key '<some key>'
        option mesh_fwding '0'                                                                                           
        option mesh_ttl '1'                                                                                              
        option mesh_rssi_threshold '0'          

config wifi-device 'radio1'                                                                                              
        option type 'mac80211'                                                                                           
        option hwmode '11g'                                                                                              
        option path 'platform/ahb/18100000.wmac'                                                                         
        option htmode 'HT20'                                                                                             
        option disabled '0'                                                                                              
        option channel '1'                                                                                               
        option txpower '24' 

config wifi-iface 'liberlo2_4Ghz'                                                                                        
        option ssid 'our-house-liberlo'                                                                                  
        option device 'radio1'                                                                                           
        option mode 'ap'                                                                                                 
        option key '<some other key>'                                                                                
        option network 'lan_bat0_100'                                                                                    
        option encryption 'psk2'                                                                                         
        option disabled '0'    
...

# /etc/config/network
...
config interface 'mesh'
        option proto 'batadv_hardif'
        option master 'bat0'
        option mtu '2304'
        option throughput_override '0'

config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV' 
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option fragmentation '1'
        option gw_mode 'off'
        option hop_penalty '30'
        option isolation_mark '0x00000000/0x00000000'
        option log_level '0'
        option multicast_mode '1'
        option multicast_fanout '16'
        option network_coding '0'
        option orig_interval '1000'
...

Planned next steps/ Experiments

These are the things I plan to do next with the hop to improve the situation:

  • upgrade all nodes to firmware version 21.02.0-rc1
  • reduce the 5 Ghz channel bandwidth from 80 Mhz to 40 Mhz (I read somewhere this is supposed to be more reliable - whatever that means)

As I am running out of ideas - I really hope for your ideas, suggestions and experience. If you need some more background - please let me know.

Thank you for reading and your support.

1 Like

Hey, @samba2 , I'm the author of the blog post you mentioned. Wireless mesh networks are targeted towards scalability and reliability, rather than performance, but 6Mbps sounds pretty bad indeed.

Now, I've deployed the exact same configuration many times before and have never experienced the throughput instability you described. This makes me wonder about the environment in which the nodes were installed. There are many factors to consider when working with wireless communication but fortunately, there are a couple of things you can do software-wise to try to fix the throughput issues you mentioned:

  • Test throughput with iperf3 (https://iperf.fr/) instead of the batctl throughput meter (tp). Install iperf on two different laptops (preferably with a gigabit NIC) and connect them to different nodes via an ethernet cable. When running in client mode, tell iperf to create 5 or 10 parallel connections (-P 5) and look for the statistics associated with the sum across connections ([SUM]). There are other things you can do here but this should give you a better idea of actual throughput over the mesh.

  • Have you noticed anything unusual from the output of batctl tp bat0 when there is only two nodes connected to the mesh vs. three or four? (The condition you mentioned that causes throughput to decrease dramatically.) And what about the syslog of each node? Anything unusual going on there? The OpenWrt wiki also mentions an issue with the way batman-adv use ARP packets.

  • Have you tried to tweak the values in your bat0 and mesh (batadv_hardif) stanzas? Those look like the default ones, which should work fine in most cases, but you can definitely change them to better fit yours. See Tweaking B.A.T.M.A.N. Advanced, for example.

  • Finally, in the bat0 stanza, try the latest batman algorithm (BATMAN_V) instead of BATMAN_IV. (I have not tested that in a while because as I said before, I've never had major issues with the standard settings.) The official batman-adv wiki does mention differences in neighbor discovery and throughput metrics between IV and V (https://www.open-mesh.org/projects/batman-adv/wiki/BATMAN_V).

If none of this helps, then I'd suggest you to try relocating your mesh nodes. You mentioned that many only see one other neighbor, which is usually not ideal a mesh topology. For example, do you experience the throughput issue if all the nodes are in the same room (within line of sight)? Can you cover the entire area with each node having at least two neighbors (triangular topology)?

Anyway, I have a couple of tp-link C7s here for a client project that I can use to try to replicate your issue. They are all V2 though and I know the hardware is not exactly the same as V5 but I will let you know if I learn anything new.

2 Likes

@samba2

  • Check also without using encryption for your mesh interface
config wifi-iface 'wmesh'                       
        option device 'radio0'                  
        option ifname 'if-mesh'                 
        option network 'mesh'  
        option mode 'mesh'     
        option mesh_id 'our-house-mesh-backbone'
        option encryption 'none' 
        option key '<some key>'
        option mesh_fwding '0'                                                                                           
        option mesh_ttl '1'                                                                                              
        option mesh_rssi_threshold '0'  
  • running mesh and ap at the same time could impact performance

  • try some new LibreMesh stock ath79 Builds

https://downloads.libremesh.org/releases/2020.1/targets/ath79/

2 Likes

Hi, be gentle I'm new.

I tested a similar configuration on similar equipment for fun / for a home network I thought I might share:

4 node 5Ghz (VHT80) mesh using AR750S (802.11s, WPA3, not using B.A.T.M.A.N.) all within 20ft of each other:

Node 1: root / internet
Node 2: TV via ethernet
Node 3: AP w/ 1-2 devices connected
Node 4: Laptop via ethernet

My use case:

-better WiFi with WPA3 security on 19.07.7 mesh node than on older laptop w/ outdated NIC
-better audio quality and security than bluetooth (fight me)
-reduce or eliminate ethernet cables (got rid of 4 longruns)
-fun
-learn
-eliminate downtime for other users by getting me off the main network

The AR750S uses the same single core QCA9563 as the C7 and same amount of memory 16/128. But it has fewer radios / antennas with only 1 for 5Ghz and 2 for 2.4Ghz.

I found it worked best in a 5Ghz mesh configuration - more stable, faster, less problems. The root node was the most stable. Node 2 / TV was very stable. Node 3 / AP had the most problems. Node 4 was very stable with a laptop downloading two days worth of W10 updates.

This behavior to me tended to suggest the single core QCA9563 didn't like juggling AP duty especially with limited radios / antennas. Furthermore even with more antennas I don't think the C7 can keep up as in theory that would only improve its data transmission capacity by roughly 300% on 5Ghz and 50% on 2.4Ghz compared to a AR750S but in theory could still overwhelm the CPU especially if it is running other services / VLANs?

I think the AR750S mesh performed well but somewhat struggled (node 3 / AP specifically) to support one user, a TV and radio, the C7 would see similar capacity issues eventually - especially with multiple users to stress test it. Also if it has to deal with less than -50db signal which would in theory reduce a C7 mesh down to the throughput of my close proximity AR750S test mesh.

By this time I had so much fun that I ordered two used C7's (V2) and two EA8300's off ebay and successfully loaded 19.07.7 on all of them thanks to you guys / standing on the shoulders of giants.

I added two C7's to the mix replacing the root node and the TV node but found the mesh was not as reliable which I suspected was due to the C7 vs AR750's slower radios (1300Mbps vs 433Mbps) clashing. I know you are supposed to use matched equipment - but that's no fun / not what I have.

Then I tried adding the more powerful (quad core, 256/256MB) EA8300 to the mix as node 3 / AP. By now I was running HTOP on all nodes in watch windows during testing / usage and predictably the C7's had better / lower CPU usage than the AR750S's. But of course the EA8300 quad core and double the memory was able to do everything including wireguard effortlessly compared to the C7's.

Thoughts/Theories/Conclusions:

The AR750S is an amazing little board that can do it all - but it is resource constrained which will lead to reliability issues if you ask too much of it, it is a travel router after all. Take node 3 / AP for example. I could offload AP work to another AR750S (via ethernet to node 3) as a dedicated AP (or dumb AP). I haven't successfully configured this yet (plus I am migrating to more powerful routers) and now using the AR750S's as ethernet connected clients for the laptops instead due to transmission rates mismatch. They work flawlessly in STA mode providing ethernet for old laptops with non WPA3 compliant NIC's.

Or you could try adding extra nodes to the mesh to enhance reliability and improve low signal conditions between distant nodes if possible to get that ideal -50db signal / max transmission rate. Bear in mind the more you add, the more you will have to run around to fix when it goes down. Test this on the bench first if possible until you are satisfied it is reliable enough.

Since used C7's are only $25USD that might be a way to go for your use case. In fact since uptime is so important you might want to buy a fleet of them IF they can be proven to be reliable for your use case. However I know that more VLANs (and other software packages) means more CPU time and you may be hitting a brick wall there ie they MAY NOT be good candidates for your use case as I think they are facing similar resource constraints as the AR750S (single core QCA9563 and the 16/128MB ram). Still great routers though that you can add to your mix as AP's, clients, clients w/ AP, or dedicated mesh nodes to stabilize the mesh / improve signal quality between distant nodes / back ups / spares / testing purposes so you don't risk tampering with the main mesh and downtime.

I think a router like the EA8300 might be better suited to your situation due to the more powerful quad core and bigger memory. It also has a second 5Ghz radio which gives you more options. It ran effortlessly/flawlessly compared to the C7 and the AR750S. I am currently moving towards a 3-4 node EA8300 mesh in place of nodes 1,2,3. Node 4 I am eliminating / moving towards just configuring an AR750S as a client and connecting it to node 3 / AP, (due to the radio bitrate issues between mismatched nodes).

At $50USD used on Ebay the EA8300 offers tremendous value and processing power needed to handle a mesh in my opinion. They seem to play well with the C7's despite there also being a transmission rate mismatch (1300Mbps vs the EA8300's 866Mbps).

The EA8300 has internal 2.4Ghz antennas which may not be good enough for your situation. Also it has a lower 5Ghz transmission rate (2T:2R vs 3T:3R) than the C7, so I would be slightly concerned about saturating the back haul - you should get at least ~150Mbps throughput at -50db.

I perf3 tested my (node 2 TV / C7) to (node 3 / AP/ EA8300) at 70Mbps (due to CPU loading?). So I then tested it the other way around theorizing the quad core could handle it better and it reported 200Mbps. I know you get lower results but I am just learning. These 2 nodes are only 10ft apart.

Forcing the radios to HT40 can help - less hunting / may improve issues with hidden mesh nodes deciding on different frequencies as they hop around on VHT80 across 4x20Mhz channels - but then you are limiting the device to 2T:2R if I am not mistaken / 866Mbps. Some users even go with channel 165 to avoid interference - but that is only 20Mhz wide = 433Mbps.

I generally estimate or budget throughput at 1/4 or 1/3 Max of the advertised rate due to interference, distance and overhead and that would go down in a bigger mesh potentially. Real world those numbers are going to be lower if the nodes don't have at least -50db signal between each other. OpenWrt's brilliant developers and engineers have eliminated the guess work for users by lovingly providing detailed watch windows ("network->wireless" and "status->overview") showing your RSSI and rate information per network in realtime to help you test and monitor your WLAN.

Last but not least I am slightly concerned about the C7's 2.4Ghz stability based on what I have read - although I am using the V2 not the V5. Also for my purposes I try to avoid 2.4Ghz. One of my uses for the mesh was to enable old cheap laptops to connect using the latest security WPA3 without having to update their WLANS. Another was to get rid of ethernet cables.

All end clients care about is speed and 100% uptime so in my case I made separate networks / routers (non mesh) for other family members so they don't have any problems while I test and configure my mesh network.

All in all I am very pleased with 19.07.7 and 802.11s and feel most of the problems are due to hardware limitations of the smaller routers, hardware mismatches / non-homogenous equipment or noisy / low signal quality and not the 802.11s standard / software.

Another thing you could try is putting the slightly bigger 9db or 12db mixed freq antennas on the C7's - but that could get expensive. I think you can get those for $5-7 each on aliexpress. You could also try directional patch antennas as well which would improve your SNR for nodes in it's LOS. YMMV.

Try putting all the nodes near windows on the same side of the building if possible as this tends to give them a better line of sight / better signal path than nodes buried in a structure. Less error correction = more available bandwidth / faster performance / better reliability.

Also since vertical whip antennas tend to make a toroidal polar pattern, routers located above each other vertically in a structure may not get as much RSSI. Try orienting all the antennas horizontally to improve RSSI between nodes stacked vertically in a tall building? You could also buy extender cables (if possible - I think the the C7 V5 has ufl connectors) and mount the antennas outside or in a better position / closer to a window). YMMV.

Thanks again to all! I came across cgomesu's website recently when I was trying to learn how to configure my AR750S mesh. Thank-you. I have since bought another C7 and EA8300.

AR750S 1x2 radios
C7 = 3x3 radios
EA8300 = 2x2x2 radios

I have a 150Mbps internet connection.

I was able to get 135Mbps w/ iPad with VPN (or full line speed 150Mbps without VPN) using two EA8300's: one as root node and the other as AP node with all devices within 15ft of each other using 80211.s (non B.A.T.M.A.N.).

vs about 50-65Mbps mesh using all AR750S with a 5Ghz mesh and 5Ghz AP I got around 30-40Mbps on my iPad connected to it. Sorry that part I didn't collect alot of data as it was alittle glitchy, VPN added to the mix, and I moved on to the bigger APs/routers as I was just trying to build (hack and slash) a stable high speed mesh as quickly as possible. It's working!

:partying_face::partying_face::partying_face::partying_face::partying_face:

C7 V2 and AR750S both configured with ath10k non CT drivers better suited to 16/128 devices.
EA8300 configured with at10k-ct drivers better suited to 256/256 devices (OOB 19.07.7) shows go.

I think if you made the mesh backbone exclusively out of something comparable to an EA8300 configured with AP's and then connect to them with C7's in STA/AP mode (with AP's on the C7 for the "last mile") might offer best connectivity and reliability. The local STA/AP C7 more powerful radios would solve the problem of bad client connections with weak radios hitting and congesting the main mesh. I am already doing something like that with node 4 but for other reasons.

Another trick might be to make hidden AP's on each mesh node for servicing them if they ever disconnect from the mesh (or even client STA/APs). That way you don't have to access them physically to connect ethernet once they are installed. I don't use all the fancy management tools yet as my node count is small and easily accessible when I break it from testing.

1 Like

Thank you all for your responses.

Before I start trying out your suggestions (I am only a night mesh admin unfortunately) I thought I provide some iperf3 stats. Since the routers are already rolled out (I might collect them over the weekend to do some local testing) I installed ipfer3 directly on the router and ran the performance test from router to router.

The single bridges ran in server mode iperf3 -s and the gateway started the test with iperf3 -c <bridge hostname> -P 5

Tnx @cgomesu for suggesting this - now you can see throughput over time. I'd say it is not a lot.

Bridge 1 <> Gateway

Connecting to host ash, port 5201                                              
[  5] local 192.168.2.1 port 56326 connected to 192.168.2.2 port 5201         
[  7] local 192.168.2.1 port 56328 connected to 192.168.2.2 port 5201       
[  9] local 192.168.2.1 port 56330 connected to 192.168.2.2 port 5201         
[ 11] local 192.168.2.1 port 56332 connected to 192.168.2.2 port 5201         
[ 13] local 192.168.2.1 port 56334 connected to 192.168.2.2 port 5201         
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd              
[  5]   0.00-1.00   sec   964 KBytes  7.89 Mbits/sec    0   52.3 KBytes       
[  7]   0.00-1.00   sec   563 KBytes  4.60 Mbits/sec    0   32.5 KBytes       
[  9]   0.00-1.00   sec   902 KBytes  7.38 Mbits/sec    0   50.9 KBytes       
[ 11]   0.00-1.00   sec   885 KBytes  7.24 Mbits/sec    0   56.6 KBytes       
[ 13]   0.00-1.00   sec   535 KBytes  4.37 Mbits/sec    0   31.1 KBytes       
[SUM]   0.00-1.00   sec  3.76 MBytes  31.5 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   1.00-2.00   sec   322 KBytes  2.64 Mbits/sec    0   55.1 KBytes       
[  7]   1.00-2.00   sec   201 KBytes  1.65 Mbits/sec    0   33.9 KBytes       
[  5]   1.00-2.00   sec   322 KBytes  2.64 Mbits/sec    0   55.1 KBytes                                                                              [39/1253]
[  7]   1.00-2.00   sec   201 KBytes  1.65 Mbits/sec    0   33.9 KBytes       
[  9]   1.00-2.00   sec   281 KBytes  2.31 Mbits/sec    0   53.7 KBytes       
[ 11]   1.00-2.00   sec   344 KBytes  2.82 Mbits/sec    0   59.4 KBytes       
[ 13]   1.00-2.00   sec   208 KBytes  1.70 Mbits/sec    0   33.9 KBytes       
[SUM]   1.00-2.00   sec  1.32 MBytes  11.1 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   2.00-3.00   sec   303 KBytes  2.48 Mbits/sec    0   55.1 KBytes       
[  7]   2.00-3.00   sec   164 KBytes  1.34 Mbits/sec    0   33.9 KBytes       
[  9]   2.00-3.00   sec   287 KBytes  2.35 Mbits/sec    0   53.7 KBytes       
[ 11]   2.00-3.00   sec   329 KBytes  2.70 Mbits/sec    0   59.4 KBytes       
[ 13]   2.00-3.00   sec   163 KBytes  1.33 Mbits/sec    0   33.9 KBytes       
[SUM]   2.00-3.00   sec  1.22 MBytes  10.2 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   3.00-4.00   sec   744 KBytes  6.08 Mbits/sec    0   63.6 KBytes       
[  7]   3.00-4.00   sec   498 KBytes  4.07 Mbits/sec    0   46.7 KBytes       
[  9]   3.00-4.00   sec   706 KBytes  5.77 Mbits/sec    0   53.7 KBytes       
[ 11]   3.00-4.00   sec   737 KBytes  6.03 Mbits/sec    0   65.0 KBytes       
[ 13]   3.00-4.00   sec   420 KBytes  3.44 Mbits/sec    0   33.9 KBytes       
[SUM]   3.00-4.00   sec  3.03 MBytes  25.4 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   4.00-5.00   sec   520 KBytes  4.27 Mbits/sec    0   63.6 KBytes       
[  7]   4.00-5.00   sec   395 KBytes  3.24 Mbits/sec    0   46.7 KBytes        
[  9]   4.00-5.00   sec   475 KBytes  3.90 Mbits/sec    0   53.7 KBytes        
[ 11]   4.00-5.00   sec   535 KBytes  4.39 Mbits/sec    0   65.0 KBytes        
[ 13]   4.00-5.00   sec   296 KBytes  2.43 Mbits/sec    0   33.9 KBytes        
[SUM]   4.00-5.00   sec  2.17 MBytes  18.2 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                           
[  5]   5.00-6.00   sec   130 KBytes  1.07 Mbits/sec    0   63.6 KBytes       
[  7]   5.00-6.00   sec   130 KBytes  1.07 Mbits/sec    0   46.7 KBytes       
[  9]   5.00-6.00   sec   120 KBytes   985 Kbits/sec    0   53.7 KBytes       
[ 11]   5.00-6.00   sec   188 KBytes  1.54 Mbits/sec    0   65.0 KBytes       
[ 13]   5.00-6.00   sec  96.2 KBytes   788 Kbits/sec    0   33.9 KBytes       
[SUM]   5.00-6.00   sec   665 KBytes  5.44 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   6.00-7.00   sec   549 KBytes  4.49 Mbits/sec    0   63.6 KBytes       
[  7]   6.00-7.00   sec   380 KBytes  3.11 Mbits/sec    0   46.7 KBytes       
[  9]   6.00-7.00   sec   426 KBytes  3.48 Mbits/sec    0   53.7 KBytes       
[ 11]   6.00-7.00   sec   505 KBytes  4.13 Mbits/sec    0   65.0 KBytes       
[ 13]   6.00-7.00   sec   267 KBytes  2.19 Mbits/sec    0   33.9 KBytes       
[SUM]   6.00-7.00   sec  2.08 MBytes  17.4 Mbits/sec    0                
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   7.00-8.00   sec   983 KBytes  8.06 Mbits/sec    0   99.0 KBytes       
[  7]   7.00-8.00   sec   590 KBytes  4.83 Mbits/sec    0   46.7 KBytes       
[  9]   7.00-8.00   sec   655 KBytes  5.37 Mbits/sec    0   56.6 KBytes       
[ 11]   7.00-8.00   sec   766 KBytes  6.28 Mbits/sec    0   65.0 KBytes       
[ 13]   7.00-8.00   sec   413 KBytes  3.38 Mbits/sec    0   33.9 KBytes       
[SUM]   7.00-8.00   sec  3.33 MBytes  27.9 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   8.00-9.00   sec   906 KBytes  7.42 Mbits/sec    0   99.0 KBytes       
[  7]   8.00-9.00   sec   444 KBytes  3.63 Mbits/sec    0   46.7 KBytes       
[  9]   8.00-9.00   sec   567 KBytes  4.64 Mbits/sec    0   56.6 KBytes       
[ 11]   8.00-9.00   sec   621 KBytes  5.08 Mbits/sec    0   65.0 KBytes       
[ 13]   8.00-9.00   sec   328 KBytes  2.68 Mbits/sec    0   33.9 KBytes       
[SUM]   8.00-9.00   sec  2.80 MBytes  23.5 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   9.00-10.00  sec   216 KBytes  1.77 Mbits/sec    0   99.0 KBytes       
[  7]   9.00-10.00  sec   129 KBytes  1.06 Mbits/sec    0   46.7 KBytes       
[  9]   9.00-10.00  sec   127 KBytes  1.04 Mbits/sec    0   56.6 KBytes       
[ 11]   9.00-10.00  sec   150 KBytes  1.23 Mbits/sec    0   65.0 KBytes       
[ 13]   9.00-10.00  sec  77.8 KBytes   638 Kbits/sec    0   33.9 KBytes       
[SUM]   9.00-10.00  sec   700 KBytes  5.74 Mbits/sec    0                      
- - - - - - - - - - - - - - - - - - - - - - - - -                              
[ ID] Interval           Transfer     Bitrate         Retr                     
[  5]   0.00-10.00  sec  5.51 MBytes  4.62 Mbits/sec    0             sender   
[  5]   0.00-10.05  sec  5.38 MBytes  4.49 Mbits/sec                  receiver
[  7]   0.00-10.00  sec  3.41 MBytes  2.86 Mbits/sec    0             sender
[  7]   0.00-10.05  sec  3.33 MBytes  2.78 Mbits/sec                  receiver
[  9]   0.00-10.00  sec  4.44 MBytes  3.72 Mbits/sec    0             sender  
[  9]   0.00-10.05  sec  4.36 MBytes  3.64 Mbits/sec                  receiver
[ 11]   0.00-10.00  sec  4.94 MBytes  4.14 Mbits/sec    0             sender  
[ 11]   0.00-10.05  sec  4.85 MBytes  4.05 Mbits/sec                  receiver
[ 13]   0.00-10.00  sec  2.74 MBytes  2.30 Mbits/sec    0             sender  
[ 13]   0.00-10.05  sec  2.69 MBytes  2.24 Mbits/sec                  receiver
[SUM]   0.00-10.00  sec  21.0 MBytes  17.6 Mbits/sec    0             sender  
[SUM]   0.00-10.05  sec  20.6 MBytes  17.2 Mbits/sec                  receiver
                                                                               
iperf Done.                              

Bridge 2 <> Gateway

Connecting to host mele-mele, port 5201                                       
[  5] local 192.168.2.1 port 50220 connected to 192.168.2.3 port 5201         
[  7] local 192.168.2.1 port 50222 connected to 192.168.2.3 port 5201       
[  9] local 192.168.2.1 port 50224 connected to 192.168.2.3 port 5201         
[ 11] local 192.168.2.1 port 50226 connected to 192.168.2.3 port 5201         
[ 13] local 192.168.2.1 port 50228 connected to 192.168.2.3 port 5201         
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd              
[  5]   0.00-1.00   sec   632 KBytes  5.18 Mbits/sec    0   62.2 KBytes       
[  7]   0.00-1.00   sec   368 KBytes  3.01 Mbits/sec    0   35.4 KBytes       
[  9]   0.00-1.00   sec   496 KBytes  4.06 Mbits/sec    0   49.5 KBytes       
[ 11]   0.00-1.00   sec   329 KBytes  2.70 Mbits/sec    0   31.1 KBytes       
[ 13]   0.00-1.00   sec   354 KBytes  2.90 Mbits/sec    0   36.8 KBytes       
[SUM]   0.00-1.00   sec  2.13 MBytes  17.8 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   1.00-2.00   sec  0.00 Bytes  0.00 bits/sec    0   62.2 KBytes     
[  7]   1.00-2.00   sec  25.5 KBytes   208 Kbits/sec    0   35.4 KBytes       
[  9]   1.00-2.00   sec  39.6 KBytes   324 Kbits/sec    0   49.5 KBytes       
[ 11]   1.00-2.00   sec  21.2 KBytes   174 Kbits/sec    0   31.1 KBytes       
[ 13]   1.00-2.00   sec  25.5 KBytes   208 Kbits/sec    0   36.8 KBytes       
[SUM]   1.00-2.00   sec   112 KBytes   914 Kbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   2.00-3.00   sec   308 KBytes  2.53 Mbits/sec    0   62.2 KBytes       
[  7]   2.00-3.00   sec   130 KBytes  1.07 Mbits/sec    0   35.4 KBytes       
[  9]   2.00-3.00   sec   230 KBytes  1.89 Mbits/sec    0   49.5 KBytes       
[ 11]   2.00-3.00   sec   133 KBytes  1.09 Mbits/sec    0   31.1 KBytes       
[ 13]   2.00-3.00   sec   144 KBytes  1.18 Mbits/sec    0   36.8 KBytes       
[SUM]   2.00-3.00   sec   946 KBytes  7.75 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   3.00-4.00   sec   727 KBytes  5.96 Mbits/sec    0   62.2 KBytes       
[  7]   3.00-4.00   sec   445 KBytes  3.65 Mbits/sec    0   53.7 KBytes       
[  9]   3.00-4.00   sec   543 KBytes  4.45 Mbits/sec    0   49.5 KBytes       
[ 11]   3.00-4.00   sec   455 KBytes  3.73 Mbits/sec    0   49.5 KBytes       
[ 13]   3.00-4.00   sec   551 KBytes  4.52 Mbits/sec    0   55.1 KBytes       
[SUM]   3.00-4.00   sec  2.66 MBytes  22.3 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   4.00-5.00   sec  1.23 MBytes  10.3 Mbits/sec    0   99.0 KBytes       
[  7]   4.00-5.00   sec   690 KBytes  5.65 Mbits/sec    0   53.7 KBytes        
[  9]   4.00-5.00   sec   912 KBytes  7.47 Mbits/sec    0   69.3 KBytes        
[ 11]   4.00-5.00   sec   529 KBytes  4.33 Mbits/sec    0   49.5 KBytes        
[ 13]   4.00-5.00   sec   983 KBytes  8.05 Mbits/sec    0   76.4 KBytes       
[SUM]   4.00-5.00   sec  4.27 MBytes  35.8 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                           
[  5]   5.00-6.00   sec  1.10 MBytes  9.19 Mbits/sec    0   99.0 KBytes       
[  7]   5.00-6.00   sec   602 KBytes  4.93 Mbits/sec    0   53.7 KBytes       
[  9]   5.00-6.00   sec   793 KBytes  6.50 Mbits/sec    0   69.3 KBytes       
[ 11]   5.00-6.00   sec   550 KBytes  4.51 Mbits/sec    0   49.5 KBytes       
[ 13]   5.00-6.00   sec   836 KBytes  6.85 Mbits/sec    0   76.4 KBytes       
[SUM]   5.00-6.00   sec  3.81 MBytes  32.0 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   6.00-7.00   sec   929 KBytes  7.61 Mbits/sec    0   99.0 KBytes       
[  7]   6.00-7.00   sec   475 KBytes  3.88 Mbits/sec    0   66.5 KBytes       
[  9]   6.00-7.01   sec  1.43 MBytes  11.9 Mbits/sec    0    187 KBytes       
[ 11]   6.00-7.01   sec   386 KBytes  3.14 Mbits/sec    0   46.7 KBytes       
[ 13]   6.00-7.01   sec  1.35 MBytes  11.3 Mbits/sec    0    188 KBytes       
[SUM]   6.00-7.00   sec  4.53 MBytes  38.0 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   7.00-8.00   sec   397 KBytes  3.26 Mbits/sec    0   99.0 KBytes       
[  7]   7.00-8.00   sec   345 KBytes  2.83 Mbits/sec    0   80.6 KBytes       
[  9]   7.01-8.00   sec   717 KBytes  5.91 Mbits/sec    0    187 KBytes       
[ 11]   7.01-8.00   sec   177 KBytes  1.46 Mbits/sec    0   46.7 KBytes       
[ 13]   7.01-8.00   sec   829 KBytes  6.83 Mbits/sec    0    188 KBytes       
[SUM]   7.00-8.00   sec  2.41 MBytes  20.2 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   8.00-9.00   sec   345 KBytes  2.82 Mbits/sec    0   99.0 KBytes       
[  7]   8.00-9.00   sec   303 KBytes  2.47 Mbits/sec    0   80.6 KBytes       
[  9]   8.00-9.00   sec   665 KBytes  5.42 Mbits/sec    0    187 KBytes       
[ 11]   8.00-9.00   sec   143 KBytes  1.17 Mbits/sec    0   46.7 KBytes       
[ 13]   8.00-9.00   sec   515 KBytes  4.20 Mbits/sec    0    188 KBytes       
[SUM]   8.00-9.00   sec  1.92 MBytes  16.1 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   9.00-10.00  sec   731 KBytes  6.01 Mbits/sec    0   99.0 KBytes       
[  7]   9.00-10.00  sec   551 KBytes  4.53 Mbits/sec    0   80.6 KBytes       
[  9]   9.00-10.00  sec  1.61 MBytes  13.5 Mbits/sec    0    317 KBytes       
[ 11]   9.00-10.00  sec   318 KBytes  2.61 Mbits/sec    0   46.7 KBytes       
[ 13]   9.00-10.00  sec  1.26 MBytes  10.6 Mbits/sec    0    188 KBytes       
[SUM]   9.00-10.00  sec  4.43 MBytes  37.3 Mbits/sec    0                      
- - - - - - - - - - - - - - - - - - - - - - - - -                              
[ ID] Interval           Transfer     Bitrate         Retr                     
[  5]   0.00-10.00  sec  6.30 MBytes  5.28 Mbits/sec    0             sender  
[  5]   0.00-10.06  sec  6.16 MBytes  5.14 Mbits/sec                  receiver
[  7]   0.00-10.00  sec  3.84 MBytes  3.22 Mbits/sec    0             sender
[  7]   0.00-10.06  sec  3.76 MBytes  3.14 Mbits/sec                  receiver
[  9]   0.00-10.00  sec  7.33 MBytes  6.15 Mbits/sec    0             sender  
[  9]   0.00-10.06  sec  6.99 MBytes  5.83 Mbits/sec                  receiver
[ 11]   0.00-10.00  sec  2.97 MBytes  2.49 Mbits/sec    0             sender  
[ 11]   0.00-10.06  sec  2.92 MBytes  2.44 Mbits/sec                  receiver
[ 13]   0.00-10.00  sec  6.75 MBytes  5.66 Mbits/sec    0             sender  
[ 13]   0.00-10.06  sec  6.44 MBytes  5.37 Mbits/sec                  receiver
[SUM]   0.00-10.00  sec  27.2 MBytes  22.8 Mbits/sec    0             sender  
[SUM]   0.00-10.06  sec  26.3 MBytes  21.9 Mbits/sec                  receiver
                                                                               
iperf Done.                                      

Gateway <> Bridge 3 via Bridge 2

Connecting to host papella, port 5201                                          
[  5] local 192.168.2.1 port 41838 connected to 192.168.2.4 port 5201         
[  7] local 192.168.2.1 port 41840 connected to 192.168.2.4 port 5201       
[  9] local 192.168.2.1 port 41842 connected to 192.168.2.4 port 5201         
[ 11] local 192.168.2.1 port 41844 connected to 192.168.2.4 port 5201         
[ 13] local 192.168.2.1 port 41846 connected to 192.168.2.4 port 5201         
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd              
[  5]   0.00-1.00   sec   199 KBytes  1.63 Mbits/sec    0   41.0 KBytes       
[  7]   0.00-1.00   sec   144 KBytes  1.18 Mbits/sec    0   24.0 KBytes       
[  9]   0.00-1.00   sec   216 KBytes  1.77 Mbits/sec    0   42.4 KBytes       
[ 11]   0.00-1.00   sec   197 KBytes  1.61 Mbits/sec    0   42.4 KBytes       
[ 13]   0.00-1.00   sec   192 KBytes  1.57 Mbits/sec    0   42.4 KBytes       
[SUM]   0.00-1.00   sec   949 KBytes  7.77 Mbits/sec    0                   
- - - - - - - - - - - - - - - - - - - - - - - - -                           
[  5]   1.00-2.00   sec   123 KBytes  1.01 Mbits/sec    0   41.0 KBytes   
[  7]   1.00-2.00   sec  90.5 KBytes   741 Kbits/sec    0   24.0 KBytes       
[  9]   1.00-2.00   sec   116 KBytes   950 Kbits/sec    0   42.4 KBytes       
[ 11]   1.00-2.00   sec   144 KBytes  1.18 Mbits/sec    0   42.4 KBytes       
[ 13]   1.00-2.00   sec   158 KBytes  1.30 Mbits/sec    0   42.4 KBytes       
[SUM]   1.00-2.00   sec   632 KBytes  5.18 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   2.00-3.00   sec   120 KBytes   985 Kbits/sec    0   41.0 KBytes       
[  7]   2.00-3.00   sec  53.7 KBytes   440 Kbits/sec    0   24.0 KBytes       
[  9]   2.00-3.00   sec   124 KBytes  1.02 Mbits/sec    0   42.4 KBytes       
[ 11]   2.00-3.00   sec  87.7 KBytes   718 Kbits/sec    0   42.4 KBytes       
[ 13]   2.00-3.00   sec   123 KBytes  1.01 Mbits/sec    0   42.4 KBytes       
[SUM]   2.00-3.00   sec   509 KBytes  4.17 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   3.00-4.00   sec  90.5 KBytes   741 Kbits/sec    0   41.0 KBytes       
[  7]   3.00-4.00   sec  52.3 KBytes   429 Kbits/sec    0   24.0 KBytes       
[  9]   3.00-4.00   sec  58.0 KBytes   475 Kbits/sec    0   42.4 KBytes       
[ 11]   3.00-4.00   sec  89.1 KBytes   730 Kbits/sec    0   42.4 KBytes       
[ 13]   3.00-4.00   sec  56.6 KBytes   463 Kbits/sec    0   42.4 KBytes       
[SUM]   3.00-4.00   sec   346 KBytes  2.84 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   4.00-5.00   sec  59.4 KBytes   487 Kbits/sec    0   41.0 KBytes       
[  7]   4.00-5.00   sec  33.9 KBytes   278 Kbits/sec    0   24.0 KBytes        
[  9]   4.00-5.00   sec  84.8 KBytes   695 Kbits/sec    0   42.4 KBytes        
[ 11]   4.00-5.00   sec  89.1 KBytes   730 Kbits/sec    0   42.4 KBytes        
[ 13]   4.00-5.00   sec  87.7 KBytes   718 Kbits/sec    0   42.4 KBytes        
[SUM]   4.00-5.00   sec   355 KBytes  2.91 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                           
[  5]   5.00-6.00   sec  89.1 KBytes   730 Kbits/sec    0   41.0 KBytes       
[  7]   5.00-6.00   sec  55.1 KBytes   452 Kbits/sec    0   24.0 KBytes       
[  9]   5.00-6.00   sec  84.8 KBytes   695 Kbits/sec    0   42.4 KBytes       
[ 11]   5.00-6.00   sec  86.3 KBytes   707 Kbits/sec    0   42.4 KBytes       
[ 13]   5.00-6.00   sec  86.3 KBytes   707 Kbits/sec    0   42.4 KBytes       
[SUM]   5.00-6.00   sec   402 KBytes  3.29 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   6.00-7.00   sec  29.7 KBytes   243 Kbits/sec    0   41.0 KBytes       
[  7]   6.00-7.00   sec  18.4 KBytes   151 Kbits/sec    0   24.0 KBytes       
[  9]   6.00-7.00   sec  0.00 Bytes  0.00 bits/sec    0   42.4 KBytes       
[ 11]   6.00-7.00   sec  0.00 Bytes  0.00 bits/sec    0   42.4 KBytes       
[ 13]   6.00-7.00   sec  28.3 KBytes   232 Kbits/sec    0   42.4 KBytes       
[ 13]   6.00-7.00   sec  28.3 KBytes   232 Kbits/sec    0   42.4 KBytes       
[SUM]   6.00-7.00   sec  76.4 KBytes   625 Kbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   7.00-8.00   sec   194 KBytes  1.59 Mbits/sec   30   29.7 KBytes       
[  7]   7.00-8.00   sec  50.9 KBytes   417 Kbits/sec   18   15.6 KBytes       
[  9]   7.00-8.00   sec   195 KBytes  1.60 Mbits/sec   31   32.5 KBytes       
[ 11]   7.00-8.00   sec   115 KBytes   938 Kbits/sec   31   29.7 KBytes       
[ 13]   7.00-8.00   sec  65.0 KBytes   533 Kbits/sec   31   29.7 KBytes       
[SUM]   7.00-8.00   sec   619 KBytes  5.07 Mbits/sec  141                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   8.00-9.00   sec  91.9 KBytes   754 Kbits/sec    0   29.7 KBytes       
[  7]   8.00-9.00   sec  52.3 KBytes   429 Kbits/sec    0   15.6 KBytes       
[  9]   8.00-9.00   sec  91.9 KBytes   753 Kbits/sec    0   32.5 KBytes       
[ 11]   8.00-9.00   sec  89.1 KBytes   730 Kbits/sec    0   29.7 KBytes       
[ 13]   8.00-9.00   sec  87.7 KBytes   719 Kbits/sec    0   29.7 KBytes       
[SUM]   8.00-9.00   sec   413 KBytes  3.39 Mbits/sec    0                     
- - - - - - - - - - - - - - - - - - - - - - - - -                             
[  5]   9.00-10.00  sec   123 KBytes  1.01 Mbits/sec    0   29.7 KBytes       
[  7]   9.00-10.00  sec  67.9 KBytes   556 Kbits/sec    0   15.6 KBytes       
[  9]   9.00-10.00  sec   161 KBytes  1.32 Mbits/sec    0   32.5 KBytes       
[ 11]   9.00-10.00  sec   124 KBytes  1.02 Mbits/sec    0   29.7 KBytes       
[ 13]   9.00-10.00  sec   120 KBytes   985 Kbits/sec    0   29.7 KBytes       
[SUM]   9.00-10.00  sec   597 KBytes  4.89 Mbits/sec    0                      
- - - - - - - - - - - - - - - - - - - - - - - - -                              
[ ID] Interval           Transfer     Bitrate         Retr                     
[  5]   0.00-10.00  sec  1.09 MBytes   917 Kbits/sec   30             sender   
[  5]   0.00-10.06  sec  1.04 MBytes   871 Kbits/sec                  receiver
[  7]   0.00-10.00  sec   619 KBytes   507 Kbits/sec   18             sender
[  7]   0.00-10.06  sec   591 KBytes   482 Kbits/sec                  receiver
[  9]   0.00-10.00  sec  1.11 MBytes   928 Kbits/sec   31             sender  
[  9]   0.00-10.06  sec  1.04 MBytes   865 Kbits/sec                  receiver
[ 11]   0.00-10.00  sec  1021 KBytes   836 Kbits/sec   31             sender  
[ 11]   0.00-10.06  sec   976 KBytes   795 Kbits/sec                  receiver
[ 13]   0.00-10.00  sec  1005 KBytes   824 Kbits/sec   31             sender  
[ 13]   0.00-10.06  sec   950 KBytes   774 Kbits/sec                  receiver
[SUM]   0.00-10.00  sec  4.78 MBytes  4.01 Mbits/sec  141             sender  
[SUM]   0.00-10.06  sec  4.54 MBytes  3.79 Mbits/sec                  receiver
                                                                               
iperf Done.                                                       

Thank you @16F84 for your long post. Regarding signal strength, I did some DIY console dashboard to monitor the three wifi links (as introduced in the first post). I assume that a stronger signal is always beneficial - however, I was afraid that if e.g. all the nodes are too close to each other they would "scream each other down". Thinking about it I reckon that the mac layer should actually handle collisions + retry so maybe I was wrong

Anyway, here is an overview of the link qualities captured from the nodes via ssh calling the respective local iwinfo command + some polishing of the output via grep and sed:

Although here in the overview the link between Bridge 1 and Gateway is the weakest - for this couple I did my "move the 2 to an exclusive channel test" with a batctl tp speed of up to 50 Mbit/s.

Question: Can a far away/ weak link slow down a mesh?

One improvement should probably be to move Bridge 1 closer to Gateway - or get an external antenna.

PS: yes the mesh nodes are named by some Pokemon trainers :wink:

1 Like

Dear Mark,

tnx for your ideas. We use channel 149 on the 5 Ghz band exclusively for meshing so this should not impact the performance.

Regarding running without encryption - this will be one of my experiments the next evenings. Since we're in a crowded living area I can only do this for a short time (security) but I also think it is worth a try!

The new LibreMesh stock builds sound very interesting. Could you please quickly explain how the LibreMesh builds relate to the OpenWrt builds? Also, I've invested quite some time in my auto-generated Openwrt configs (uci). Can I continue using them?

Dear Carlos,

Regarding all you other ideas - I will try them out and feedback here as soon as possible.

Update on my plan to go from 80 Mhz channel width to 40 Mhz:

Did it - no change in the described behaviour. Speed is still dropping as you can see the in iperf3 tests which ran already on 40 Mhz channel width.

LibrrMesh is an enhancement to OpenWRT for easy mesh network deployment

It automatically configure your device at first boot as a community mesh network.

You alter its behavior by modifying the lime-defaults or with UCI commands or directly editing the openwrt configuration files.

LIbreMesh also has a hardware device available

But also does build for other ath79 devices

You can also create your own builds using the development steps like you would do creating OpenWRT images from source with their added feeds and packages

https://libremesh.org/docs/en_quick_starting_guide.html

2 Likes

Yes.

The first thing you should do is try turning up transmit power to the MAXIMUM on everything. If you can achieve at least -60db/-50db RSSI you may not have to move the nodes closer together.

Higher transmit power = higher received signal strength at the receiver = higher bit rates.

I have read many passionate dissertations about keeping transmit power as low as possible. That isn't going to help here. Crank it up!

I am surprised that didn't fix it.

This should be set to MAX POWER for your country or '30' / 1000mW, is what I can set mine to in Canada for channel 149.

You could also try the DFS channels 52 - 148. I haven't tested that on the C7 yet. They should be generally unused and you may get a better RSSI/SNR (higher tx/rx rates) on a quieter channel.

....txpower '25' / 316mW, is the max on my C7 set to Canada on 2.4Ghz which is low since most routers can do 1000mW. This may be due to the C7 V2 having internal antennas for the 2.4Ghz, or hardware limits - not sure. Eitherway that's bad/ a fair bit lower than the max '30'.

Maximum wifi transmission power per country | Wolph

You should be seeing in luci->network->wireless (or your SSH) tx/rx rates of at least 600-866Mbps between the mesh nodes. Your tx/rx rates are going to be slow at -78db RSSI. -78db is too low. This should be -60db /-50db or better if possible.

Until that is resolved that mesh will have low RSSI and high error rates resulting in 1-10Mbps connection speeds. Adding a few more mesh nodes may also aid in offloading the C7's that have AP's active / stabilize everything.

GLHF

PS

I am able to run my mesh nodes at low power settings (15db/31mW) due to their close proximity / no walls and achieve -50db RSSI (50-60db SNR) and max bit rates for the EA8300 of 866Mbps per 5Ghz radio.

***Also make sure you have software/hardware flow offloading checked off under 'network->firewall' to speed things up. Many thanks @nbd.

Wow. A lot of good advice. Will try it out this evening.

I had time to run a few tests today and try to replicate the issues you've been experiencing with the Archer C7. Unfortunately, I was unable to replicate your issue. Even behind three 15cm-thick walls, with the nodes roughly 15m apart of each other and connected over 5Ghz, I was still able to get a mean 52Mbits/sec via TCP and 85Mbits/sec via UDP. For reference, when the nodes are within line of sight and 2m apart of each other (mesh baseline), I was able to get a mean 125Mbits/sec via TCP and 143 Mbits/sec via UDP. (You can find the details of my tests at the end of this reply.)

Regarding your own iperf tests, it seems you're running them on the nodes themselves, rather than through the nodes. I get very different readings when running iperf on the nodes vs. through them, which I assume has to do with the CPU limitations of the Archer C7. As @16F84 pointed out, many of such network devices have limited processing power. This is the reason why I mentioned using laptops connected to the mesh nodes via an Ethernet cable.

I also played around with MTU sizes and fragmentation options (e.g., https://www.open-mesh.org/projects/batman-adv/wiki/Fragmentation-technical) but did not notice any remarkable differences that could explain your throughput issues. I think @16F84 provided a few interesting suggestions regarding tuning your radio settings (see channel selection) but honestly, I've been using pretty much default values and not running into anything like you reported.

All this makes me think there is something peculiar about the environment in which the nodes were deployed or maybe the nodes are almost not seeing each other. If you cannot take them down for further testing, then try adding a few nodes between them, then play around with hop penalty settings, and see how that impacts proper throughput measurements (through your mesh nodes). To help you debug this further, check logs, see what batctl s says before and after a throughput test, and save the output of batctl td bat0 to a file and later on, check it for errors (you might need to change the log level).


Tests

  • Iperf3 server (S): Laptop with gigabit Intel NIC and i7-4700mq CPU running Linux;

    • Server Iperf3: iper3 -s
  • iperf3 client (C): Desktop with gigabit Intel NIC and i7-4790k CPU running Linux;

    • Client iperf3 TCP mode: iperf3 -t 60 -P 5 -w 64K -c SERVER_IP
    • Client iperf3 UDP mode: iperf3 -u -t 60 -b 1G -c SERVER_IP
  • Mesh nodes 01 and 02: Archer C7 v2;

  • Mesh node 03: Archer C7 v4;

  • All nodes:

    Architecture: Qualcomm Atheros QCA9558 ver 1 rev 0
    Firmware Version: OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.128.50949-ec81a49
    Kernel Version: 4.14.221
    Relevant pkgs:
      ath10k-firmware-qca988x - 2019-10-03-d622d160-1
      kmod-ath10k - 4.14.221+4.19.161-1-1
      wpad-mesh-openssl - 2019-08-08-ca8c2bd2-7
      batctl-default - 2019.2-8
      kmod-batman-adv - 4.14.221+2019.2-11
    
  • Openwrt /etc/config/wireless:

    config wifi-device 'radio0'
            option type 'mac80211'
            option channel '44'
            option hwmode '11a'
            option path 'pci0000:00/0000:00:00.0'
            option htmode 'VHT80'
            option country 'BR'
            option disabled '0'
    
    config wifi-iface 'wmesh'
            option device 'radio0'
            option ifname 'if-mesh'
            option network 'mesh'
            option mode 'mesh'
            option mesh_id 'REDACTED'
            option encryption 'sae'
            option key 'REDACTED'
            option mesh_fwding '0'
            option mesh_ttl '1'
            option mcast_rate '24000'
            option disabled '0'
    
  • Openwrt /etc/config/network:

    config interface 'lan'
            option type 'bridge'
            option ifname 'eth1.1 bat0.1'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            list dns '8.8.8.8'
    
    config switch                            
            option name 'switch0'            
            option reset '1'                 
            option enable_vlan '1'           
                                             
    config switch_vlan                       
            option device 'switch0'          
            option vlan '1'                  
            option ports '2 3 4 5 0t'        
    
    config interface 'bat0'                  
            option proto 'batadv'            
            option routing_algo 'BATMAN_IV'  
            option aggregated_ogms '1'       
            option ap_isolation '0'          
            option bonding '0'               
            option bridge_loop_avoidance '1' 
            option distributed_arp_table '1' 
            option fragmentation '1'         
            option gw_mode 'off'             
            option hop_penalty '30'          
            option isolation_mark '0x00000000/0x00000000'
            option log_level '0'                         
            option multicast_mode '1'                    
            option multicast_fanout '16'                 
            option network_coding '0'                    
            option orig_interval '1000'                  
                                                         
    config interface 'mesh'                              
            option proto 'batadv_hardif'                 
            option master 'bat0'                         
            option mtu '2304'                            
            option throughput_override '0'               
    

Test scenarios

  • Very noisy environment (multiple apt buildings nearby)
  • Tested conditions:
    1. SC same node (baseline mesh-less)
    2. S - Node 01 - Node 02 - C (baseline mesh): within line of sight + 2 meters apart
    3. S - Node 01 - Node 02 - C (close): 01 concrete wall (15cm thick) + roughly 7 meters apart
    4. S - Node 01 - Node 03 - Node 02 - C (far): 03 concrete walls + 15 meters apart

Results

The first output is always for the TCP test, while the second is for UDP. All results are summaries over 1 minute. (Of note, for TCP, the window size was changed to 64K because I was getting lots of retries with the default value and over the mesh connections. This made me play around with MTU and fragmentation settings but the results did not show anything relevant to OP's issue, so I'm not reporting them here.)

Baseline mesh-less

$ iperf3 -t 60 -P 5 -w 64K -c S_IP
[ ID] Interval           Transfer     Bitrate         Retr
[SUM]   0.00-60.00  sec  6.57 GBytes   941 Mbits/sec    0             sender
[SUM]   0.00-60.00  sec  6.57 GBytes   941 Mbits/sec                  receiver

$ iperf3 -u -t 60 -b 1G -c S_IP
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  6.68 GBytes   956 Mbits/sec  0.000 ms  0/4953791 (0%)  sender
[  5]   0.00-60.00  sec  6.68 GBytes   956 Mbits/sec  0.022 ms  123/4953791 (0.0025%)  receiver

Baseline mesh

$ iperf3 -t 60 -P 5 -w 64K -c S_IP
[ ID] Interval           Transfer     Bitrate         Retr
[SUM]   0.00-60.00  sec   893 MBytes   125 Mbits/sec    1             sender
[SUM]   0.00-60.02  sec   893 MBytes   125 Mbits/sec                  receiver

$ iperf3 -u -t 60 -b 1G -c S_IP
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  6.66 GBytes   954 Mbits/sec  0.000 ms  0/4940958 (0%)  sender
[  5]   0.00-60.03  sec  1021 MBytes   143 Mbits/sec  0.085 ms  4201504/4940913 (85%)  receiver

Close

$ iperf3 -t 60 -P 5 -w 64K -c S_IP
[ ID] Interval           Transfer     Bitrate         Retr
[SUM]   0.00-60.00  sec   753 MBytes   105 Mbits/sec    1             sender
[SUM]   0.00-60.01  sec   753 MBytes   105 Mbits/sec                  receiver

$ iperf3 -u -t 60 -b 1G -c S_IP
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  6.66 GBytes   954 Mbits/sec  0.000 ms  0/4940942 (0%)  sender
[  5]   0.00-60.04  sec   868 MBytes   121 Mbits/sec  0.682 ms  4312030/4940422 (87%)  receiver

Far

$ iperf3 -t 60 -P 5 -w 64K -c S_IP
[ ID] Interval           Transfer     Bitrate         Retr
[SUM]   0.00-60.00  sec   377 MBytes  52.7 Mbits/sec   23             sender
[SUM]   0.00-60.05  sec   376 MBytes  52.6 Mbits/sec                  receiver

$ iperf3 -u -t 60 -b 1G -c S_IP
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  6.66 GBytes   954 Mbits/sec  0.000 ms  0/4938732 (0%)  sender
[  5]   0.00-60.08  sec   608 MBytes  84.9 Mbits/sec  0.029 ms  4497992/4938407 (91%)  receiver
1 Like

your

batctl -s

should be

batctl s

@cgomesu have you successfully used BATMAN-adv bonding or BATMAN-adv over Ethernet ?

thanks for the correction!

I have never played too much with any of the multilink optimizations because the default behavior is almost always enough for my use-cases. Why are you asking?

Regarding batman over wired connections, I've never used that before but I don't see any reason why it should not work if the physical ports are properly configured to route mesh vs non-mesh traffic (or possibly through vlans instead). (Funny enough, I got an email just a few days ago about this same topic. It was a user running a small ISP and thinking about using wired mesh for redundancy. Asked them to keep me posted on the project.) So far, however, I've never seen any successful implementation of wired mesh with batman.

The batman-adv bonding yielded no performance gain on my last tests.

As for batman-adv over Ethernet........

What I did last time

I also took discussion on github with the LIbreMesh developers

Further the Gluon documents also refer to it
https://gluon.readthedocs.io/en/latest/features/wired-mesh.html

The use cases for wired mesh are very limited but I'll gladly test it with the Archers C7 I have here and their standard OpenWrt images. However, as you might have noticed, this topic is unrelated to @samba2 's issue, so I don't think it would be appropriate to talk about it here. If you want help with wired mesh using the batman routing protocol, write a new post and ping me there. (The post you mentioned is closed.)

Iperf3 tests

3 node mesh, all nodes are EA8300, 19.07.7, vanilla 802.11s, WPA3 SAE

Layout:
Nodes 1 and 2: have a partial LOS, are located 18ft apart, some walls.
Node 3: has no LOS, 20ft from other nodes, is obstructed by a concrete wall with openings

Installed:
ath10k-firmware-qca4019-ct
ath10k-firmware-qca9888-ct
kmod-ath10k-ct
wpad-openssl
dnsmasq-full

Nodes: 
Node 1: root, total memory = 146/245MB
Node 2: Ap node (no clients), total memory = 114/245MB
Node 3: freewheel, total memory = 122/245MB

TX Power:
Node 1: tx = 27dBm (501 mW)
Node 2: tx = 25 dBm (316mW)
Node 3: tx = 28 dBm (630 mW)
*reported by LuCI

RSSI: 
Node 1 -> Node 2 (36/-103 dBm), Node 3 (-44/-103 dBm) , tx/rx 866 Mbit/s
Node 2 -> Node 1 (-45/-102 dBm), Node 3 (--44/-102 dBm), tx/rx 866 Mbit/s
Node 3 -> Node 1 (-58/103dBm), Node 2 (-45/-103 dBm), tx/rx 866 Mbit/s / 780Mbit/s
*reported by LuCI

Node 1 config: 

cat etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option channel '157'
	option country 'CA'
	option legacy_rates '0'
	option txpower '27'

config wifi-iface 'wifinet'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'lan'
	option key 'xxxxxxxxxx'
	option mesh_id 'xxxxxxxxxxx'

*same on all nodes (except txpower)

Test scenarios:

Tests done with no load on mesh, no wireless clients, root node connected to internet.
Tests done with mesh node quad core CPU, Qualcomm IPQ4019.
Tests done with same iperf commands as @cgomesu archer C7 tests for comparison purposes.

Node 1 server:
iperf3 -i 10 -s

Node 2 client TCP <-> Node 1 server:

LuCI -> Status -> Overview -> Load Average 0.79, 0.33, 0.27 (highest value recorded over halfway through test)

iperf3 -t 60 -P 5 -w 64K -c 192.168.x.x
Connecting to host 192.168.x.x, port 5201

[ ID] Interval                   Transfer          Bitrate             Retr
[SUM]   0.00-60.00  sec  2.04 GBytes   292 Mbits/sec  335             sender
[SUM]   0.00-60.01  sec  2.04 GBytes   292 Mbits/sec                  receiver


**Node 2 client  UDP test -> Node 1 server:**

LuCI -> Status -> Overview -> Load Average 0.70, 0.38, 0.29

iperf3 -u -t 60 -b 1G -c 192.168.x.x

Connecting to host 192.168.x.x, port 5201
[  5] local 192.168.x.x port 49509 connected to 192.168.x.x port 5201

[ ID] Interval                 Transfer        Bitrate               Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec   828 MBytes   116 Mbits/sec  0.000 ms  0/599931 (0%)  sender
[  5]   0.00-60.05  sec   824 MBytes   115 Mbits/sec  0.123 ms  2991/599924 (0.5%)  receiver

Node 3 client TCP test <-> Node 1 server:

LuCI -> Status -> Overview -> Load Average 0.69, 0.26, 0.21

iperf3 -t 60 -P 5 -w 64K -c 192.168.x.x

Connecting to host 192.168.x.x, port 5201
[  5] local 192.168.x.x port 49509 connected to 192.168.x.x port 5201

[ ID] Interval                   Transfer          Bitrate             Retr
[SUM]   0.00-60.00  sec  1.88 GBytes   269 Mbits/sec  364             sender
[SUM]   0.00-60.01  sec  1.88 GBytes   268 Mbits/sec                  receiver


**Node 3 client UDP test <-> Node 1 server::**

LuCI -> Status -> Overview -> Load Average -> 0.81, 0.73, 0.51

iperf3 -u -t 60 -b 1G -c 192.168.x.x

Connecting to host 192.168.x.x, port 5201
[  5] local 192.168.x.x port 46435 connected to 192.168.x.x port 5201

[ ID] Interval                Transfer            Bitrate         Jitter           Lost/Total Datagrams
[  5]   0.00-60.00  sec   809 MBytes   113 Mbits/sec  0.000 ms  0/585943 (0%)  sender
[  5]   0.00-60.05  sec   805 MBytes   112 Mbits/sec  0.523 ms  2880/585920 (0.49%)  receiver
1 Like

all nodes are EA8300

I'm very jealous right now, hehe. Good to know that mesh point mode is working with the ath10k-ct modules on the EA8300. Will keep note of that for sure.

Tests done with mesh node quad core CPU, Qualcomm IPQ4019.

By any chance, are you still able to run the tests through the nodes instead? You could use any pair of devices that have gigabit NIC and a decent processor. My experience with throughput tests is that the results from running iperf3 on the mesh nodes themselves can be quite misleading. (See also my comment below regarding the reported results.)

The # of retries (335 over 1min) seems a little high. This is also true for the other TCP tests. If you lower your window size by half the one I used (-w 32K) or increase it (-w 80K), do you still get that many re-connection attempts? Connection is getting lost more often than usual for such a short distance.

Your nodes are performing worse via UDP than TCP, which is odd. Notice that the UDP sender is also maxing at roughly 110Mbits/sec. There is a significant bottleneck here. Would definitely try running iperf through the nodes instead. Multiple things do not look right.

Thanks for posting the data. Very interesting results despite the unusual patterns I pointed out. I'll take note of them for future reference. (Thinking about updating the guide with a section about mesh performance and this might come handy.)

Machine 1 -> Node 1 <---> Node 2 <- Machine 2

*all settings same as before

Machine 1 -> Node 1 <---> Node 2 <- Machine 2

iperf3 -s  (server on machine 2)

iperf3 -t 60 -P 5 -w 32K -c 192.168.x.x  (client on machine 1)

TCP Tests:

test 1
[SUM]   0.00-60.00  sec  1.35 GBytes   194 Mbits/sec  309             sender
[SUM]   0.00-60.01  sec  1.35 GBytes   194 Mbits/sec                  receiver

test 2
[SUM]   0.00-60.00  sec  1.29 GBytes   184 Mbits/sec  276             sender
[SUM]   0.00-60.00  sec  1.29 GBytes   184 Mbits/sec                  receiver

test 3
[SUM]   0.00-60.00  sec  1.17 GBytes   168 Mbits/sec  347             sender
[SUM]   0.00-60.00  sec  1.17 GBytes   168 Mbits/sec                  receiver



iperf3 -t 60 -P 5 -w 64K -c 192.168.x.x  (client on machine 1)

test 1
[SUM]   0.00-60.00  sec  1.75 GBytes   251 Mbits/sec   67             sender
[SUM]   0.00-60.01  sec  1.75 GBytes   251 Mbits/sec                  receiver

test 2
[SUM]   0.00-60.00  sec  1.78 GBytes   255 Mbits/sec   66             sender
[SUM]   0.00-60.00  sec  1.78 GBytes   255 Mbits/sec                  receiver

test3
[SUM]   0.00-60.00  sec  1.90 GBytes   272 Mbits/sec  234             sender
[SUM]   0.00-60.01  sec  1.90 GBytes   272 Mbits/sec                  receiver



iperf3 -t 60 -P 5 -w 80K -c 192.168.x.x  (client on machine 1)

test 1
[SUM]   0.00-60.00  sec  2.02 GBytes   290 Mbits/sec   22             sender
[SUM]   0.00-60.01  sec  2.02 GBytes   290 Mbits/sec                  receiver

test 2
[SUM]   0.00-60.00  sec  2.02 GBytes   289 Mbits/sec   29             sender
[SUM]   0.00-60.01  sec  2.02 GBytes   289 Mbits/sec                  receiver

test 3
[SUM]   0.00-60.00  sec  2.11 GBytes   302 Mbits/sec   49             sender
[SUM]   0.00-60.01  sec  2.11 GBytes   302 Mbits/sec                  receiver

UDP Tests:

UDP Tests:

iperf3 -u -t 60 -b 1G -c 192.168.x.x  (client on machine 1)

test 1
[ ID] Interval                Transfer          Bitrate              Jitter         Lost/Total Datagrams
[  5]   0.00-60.00  sec  4.59 GBytes   657 Mbits/sec  0.000 ms  0/3401013 (0%)  sender
[  5]   0.00-60.21  sec  2.01 GBytes   286 Mbits/sec  0.052 ms  1912722/3401005 (56%)  receiver

test 2
[ ID] Interval                Transfer          Bitrate              Jitter         Lost/Total Datagrams
[  5]   0.00-60.00  sec  4.62 GBytes   662 Mbits/sec  0.000 ms  0/3427184 (0%)  sender
[  5]   0.00-60.03  sec  2.14 GBytes   306 Mbits/sec  0.125 ms  1843343/3427173 (54%)  receiver

test 3
[ ID] Interval                 Transfer          Bitrate             Jitter         Lost/Total Datagrams
[  5]   0.00-60.00  sec  4.63 GBytes   663 Mbits/sec  0.000 ms  0/3435782 (0%)  sender
[  5]   0.00-60.06  sec  2.39 GBytes   343 Mbits/sec  0.145 ms  1660086/3435769 (48%)  receiver

machine 1: Asus aspire 4733z-4418 (SSD upgrade), goes through an unmanaged switch before Node 1
machine 2: T420 (SSD upgrade), connected directly to Node 2.

...UDP tests: -b 1G ...is a little high for the EA8300 radios 2tx2r 866 Mbit/s
...maybe the receiver (machine 1) is dropping so many UDP because it is older / had other windows and apps running? I'll do a reverse test later perhaps?
...UDP was bottlenecked via the "APs only test" as previously noted.
...ubuntu lists both NICs @ 1000MB
...both machines are wired up with CAT5 (3-6ft cables) because my ISP is only 150 Mbit/s so I didn't care as I can barely hit 100 Mbit/s with VPN's, short runs can hit 1 Gbps (?), etc.. I have CAT6 / could redo some tests with full CAT6, (CAT6 < 150ft can do 10Gbps allegedly).
...I have a faster WIN10 laptop I could test with.

:face_with_monocle:

1 Like