Mesh clients really slow (mtu issue)

Hi new setup here, I have two wifi units (google pucks) one is my main unit that has the lan port plugged into my router (mikrotik). The router provides all the routing/dns/dhcp/nat etc. I have 3 SSID's on the main wifi unit (only radio0 2.4ghz right now) each one a separate vlan. Connecting devices to all 3 of these SSID's works great.

I setup mesh unit (not wired), using gretap over ipv4 and the mesh unit is reachable for mgmt. I setup the same SSID's as the main unit and the mesh itself is over 5ghz radio1. The clients get IP address from the router, and icmp tests look good but browsing anything is really really slow, most sites just time out.

Running test from doesn't work.

It felt like an MTU issue, so I set one of my clients to mtu to 1100 vs 1500 and now the connection to work.

enable DF is unchecked on the tap/trunk interface and the default mtu is untouched which is 1280 for these bridged interfaces which does seem pretty low.

Should I increase the default mtu on the tap/tunnel interface? I set to 1500 and it's better, not sure if the mikrotik supports pmtu. Any advice on the tap/tunnel setting is appreciated!