Mesh (802.11s) setup - Poor bandwidth and other questions

Hello everyone,

I am relatively new to OpenWRT, and unable to find direct answers to my questions in existing topics.

My topology:
ISP -> Router-1(Netgear R6220 on OpenWrt 19.07.7) -> Router-2(Linksys E5600 on OpenWRT Snapshot)

I have followed the instructions from OpenWRT wiki for most part.[]

Router-1(Netgear R6220) config:

  1. 2 AP(SSID) on 2.4Ghz on channel 13 @ 25dBm TX power.
  2. 2 AP(SSID)(WPA2 PSK - Forced CCMP) + 1 MeshPoint(WPA3-SAE) on 5Ghz.
  3. 5Ghz radio settings: 80MHz width on channel 153 @ 25dBm TX power.
  4. Uses wpad-mesh-openssl.
  5. LAN iface is set to with DHCP enabled.
  6. MeshPoint is bridged to LAN-br iface.
  7. Software flow offloading & Hardware flow offloading are both enabled.

Router-2(Linksys E5600) config:

  1. 1 AP(SSID)(No encryption) on 2.4Ghz on channel 11 @ 20dBm TX power.
  2. 1 AP(SSID)(No encryption) + 1 MeshPoint(WPA3-SAE) on 5Ghz.
  3. 5Ghz radio settings: 80MHz width on channel 153 @ 21dBm TX power.
  4. Uses wpad-mesh-openssl.
  5. LAN iface is set to with DHCP disabled.
  6. MeshPoint is bridged to LAN-br iface.
  7. Software flow offloading & Hardware flow offloading are both enabled.
  8. Built from SNAPSHOT with 'kmod-mt7663-firmware-ap' & 'kmod-mt7663-firmware-sta' included. Details in this thread: Adding OpenWrt support for Linksys E5600

Bandwidth details:

  1. Contract with ISP for 150Mbps.
  2. Cable from ISP gives 150+ Mbps download when connected directly to laptop(Tested on
  3. 5Ghz AP on Router-1 with MeshPoint turned OFF gives about 80-100 Mbps.


  1. Poor Bandwidth on 5Ghz band if Mesh is enabled.
  • reports very poor bandwidth from clients connected to 5Ghz AP on either of the routers. Router-2 reports as low as 300kbps-12Mbps.
  • Clients on 5Ghz AP of Router-1 give around 80-100Mbps if Router-2 is switched off, or if MeshPoint is disabled.
  • Clients connected to 2.4Ghz AP on either router get between 30-40Mbps on - with/without Mesh enabled.
  1. How do I access Router-2( when my client is assigned 192.168.1.XX IP address from DHCP on router-1? I am able to access it if assign a static 192.168.2.XX IP to client(but it's now on a different subnet and can't access internet).

Attempts done so far:

  1. Disabled 5Ghz AP on Router-2, in hopes of checking if Router-1 gives good bandwidth on its 5Ghz AP - did not work.
  2. Tried to change Router-1's LAN iface to, in hopes of including Router-2's in the same subnet. - did not work
  3. Tried to change Router-2's LAN iface also to 23 subnet( - did not work.

I understand there will be performance implications by using AP & STA on a single radio on the same channel. But would it be this drastic? Could something else be wrong? Is it worth switching to wolfSSL instead of openSSL?

Please let me know if any other details are needed, and I can provide.

When you have two routers bridged together, they should have IPs in the same subnet. There is only one network, a big LAN.

How are you connecting to the Internet from router 2 with the mesh disabled? The whole point of the mesh is to have a wireless link back to the Internet. If you have both routers on a wired network, you don't need mesh radios.

I am relying on DHCP server from Router-1 to assign IP addresses to all clients(whether they are connected to Router1 or Router-2), and hence they will all be in the same subnet.

Router-2 itself has an IP address for LAN-br iface of itself - which is set to I think I get my mistake here. I was expecting and to be in the same subnet "23", but it looks like starts a new IP range from 2.1 series. Will try changing this and see.

I am not connecting to the Internet from Router-2 without mesh. What I meant was - Router-1's 2.4Ghz AP gives 30-40 Mbps irrespective of mesh enabled/disabled, and Router-2's 2.4Ghz AP gives the same 30-40Mbps if mesh is enabled on 5Ghz band.

Use for everything to keep it simple, e.g. main router, second router You are correct that is part of That subnet does not include, it covers 192.168.0.X and 192.168.1.X.

30-40 Mbps is typical usable throughput on HT20.

1 Like

Thank you! Doing this made both my routers accessible on the network.

I'm okay with 30-40 Mbps on 2.4Ghz band(even though it's really HT40 and not HT20).
But the problem is with <10Mbps on 5Ghz APs on both the routers.

Both the routers are set to run their 5Ghz radios at 80MHz width. Mesh network between them is connected at VHT80, please check this picture:

But any client connected to the AP of this 5Ghz radio(either router1/router2) gets <10Mbps on, even though I'm standing right next to the router. Is this the expected throughput if I run Mesh(STA) and AP on the same 5Ghz radio?

Remember: Clients on 2.4Ghz AP of Router-2 get 30-40Mbps - so the Mesh itself seems to be working well.

Also, I seemed to be facing some connectivity issues when I run my 5Ghz AP and Mesh with different encryption techniques. Is this possible?

Apparently, I don't seem to have the bandwidth issues if I run my mesh without encryption(instead of WPA3-SAE).

I have since switched to wpad-mesh-wolfssl, but the problem persists. Does this say anything?

I am not confident about leaving my mesh unencrypted. Do I have any options?

Bumping this thread up to see if anybody can help me.

Solved so far: Router reachability is solved by using the same subnet for both routers, and setting Router-2's gateway and DNS to upstream router(Router-1)'s IP.

Still unresolved + findings so far: Bandwidth from 5Ghz APs of both routers drops when I use WPA3-SAE encryption for mesh connectivity. I hardly get <10Mbps when my ISP provides me 150Mbps. However, I am able to achieve 70-80Mbps on these same 5Ghz APs if I don't use encryption for mesh connectivity.
Note: Mesh points are configured to run on 5Ghz band for both routers, on channel 153.

Bump, anyone?

@digislayer, I know this is an old thread but I have curiosity if you fixed your poor bandwidth issue. I was experiencing the same outcome with 2 NanoHDs and moving to WDS fixed it.

1 Like

I too ended up resorting to using WDS instead, @amteza . I had to use either WDS, or Mesh without WPA3-SAE.

Note: I haven't yet tried the latest 21.02.1 release yet.

I tried 21.02.1 and master, same poor bandwidth in both. Will test someday in the future again. Thanks for your reply.

Having similar issues on the latest version 21.02.1 on TPlink Archer a6 v2. I have 3 of thes in a mesh, and a 4th one on original OS using as a control.
Newbie to OPenwrt so still reading here and researching to try to resolve severely dropped radio and bandwidth when just a few feet away from the meshed routers, on both 5ghz and 2.4ghz networks. Will try disabling the encryption on the mesh, see what happens.