Merkai MR33 - 5GHz AC Wifi - only 433Mb/s?

Hi all,

I've just taken my Meraki MR33 out of storage to be used as an access point to better cover my house. I've upgraded to the latest firmware and have it setup as you can see below:

As you can see, I'm only getting a maximum throughput of 433.3Mb/s. I know this is half of 866 respectively, however can anyone advise what settings I need to do to get full throughput?

The device connected is my Google Pixel 7 pro. My laptop is the same with the speeds too, however these devices can push 866Mb/s fine, I've seen it when connected to my Asus router directly.


It looks like that connected device is in a low power state. Try waking it up and running a speed test or something.

Yeah to be honest the phone screen was off. I ran a speed test on it and still hasn't budged. I do only have 70 meg broadband but I would have thought it'd give me the full throughput regardless like my Asus router does.

Do i need to enable another radio or something?

That is no way to do a proper speedtest.

I use Magic Iperf on my Android phone and then setup a wired client (Multicore PC) running the iperf3 server.

Your phone is using just 1 of its 2 spatial streams ((at least almost all phones have 2 streams):

The link speed should still be 866. I've seen the link speed before when doing nothing and it was reporting this speed.

I've just tried using iperf and it's only pushing 390, OpenWRT still states 433 bitrate.

Then it's connecting at 866mpbs and there's some connection display bug. It it were only 433 it wouldn't get near those 390

I'm not sure on a display bug, my phone still displays it connecting at 433Mb/s. If I connect to my Asus router it's a solid 866Mb/s when doing nothing. This is what i'm trying to explain.

So when does it pushes 390 (mbps?)?