Meraki MR33 Flashing - Putty Not Seeing Device

I have been following along with the Google Drive instructions, because i haven't found any other source. I feel like th google drive files are out of date. I am having an issue with finding the device. I know how to use the serial and putty, as well as changing the settings to get to it. When I power on the device I should see scrolling text to go through the window, there is nothing. I do see the usb serial device in device manager.

Thank you to anyone who has some suggestions.

You cannot proceed until you can see the serial port.

  • Baud rate
  • Flow control
  • Are you certain you connected a 3 volt TTL to Serial connector
  • Are you certain you properly connected: Tx-to-Rx, Rx-toTx and GND-to-GND?

I am sure about the baud and flow control. I am using an adapter that has a switch for 3.3v or 5v. I am using it set to 3.3. I didn't have the tx and rx swapped on the other end. I will give that a try.

1 Like

OK so that worked but now, the doesn't go any further than the 'Uploading Image' line. I see stuff int he putty, it shows the init of the mr33.

Is there a way to troubleshoot the ubootwrite? I tried this for the serial and it didn't give me an error like all of the other things I tried, but also no readout. I was trying --serial=COM3 --write=mr33-uboot.bin

  • The command I see here doesn't mention serial =COM3
  • Are you running the PY file on a Windows computer??? There is no COM3 on a Linux computer.
  • If you hare having an issue with that script, just use a standard TFTP program and serial software
  • The instructions clearly state that U-Boot is looking for the file mr-33-uboot.bin at

Hello, That is correct the instructions do not state COM3, but instead /dev/ttyX. That /dev/ is not available within windows, that is why I am using COM3. Maybe this just isn't possible on windows?

When you are saying standard tftp and serial software? what do you mean? I am open to using any tftp, I am unable to get to that step. For the serial software is there something more standardized than putty?

I do have the laptop connected with the network.

Thank you so much for your help,

Yep. For TFTP, I suggest one of the following:

Not really, I recommend PuTTY myself.

Did this get anywhere ? Just like OP I'm encountering obstacles after obstacle. Anyway instructions could get updated or polished?

Please see the OP, these "instructions" are at a Google Drive URL. They are not on an OpenWrt webpage:

I followed the google drive instructions and like I said, I keep encountering issues. This is the first time I have done anything of this nature so I'm finding things very complicated.

As per another POST I had open; I bought this and found some drivers to have the WIN OS pc I'm working on to recognized the serial connection and give me a com port. I then change the properties of said connection and go to PUTTY and try to connect using serial with the settings as per the google drive instructions and putty doesn't recognize it even after plugging the power source to the mr33.

What power source?!?!

Hopefully you didn't connect + to the board and damage the port.

Oh no, I didnt do that I have only connect the TX, RX, and GD. I'm talking about the unit power source.

  • I'm lost, you wouldn't see output from the MR33's console until you pluged in the power supply, so that's normal
  • You'll have to properly set not only COM Port; but: baud rate, flow control, and parity are also accurate
1 Like

@jalh adapter + PUTTY working? disconnect serial adapter from MR33. just connect RX to TX on serial adapter. you should now get local echo in PUTTY.
Then only connect RX+GND from the serial adapter to the MR33 GND/RX pins and boot the MR33. if you do not see anything in PUTTY, connect the adapter RX wire to the MR33 TX pin and retry. when it works, connect the remaining serial adapter TX wire to the free (RX or TX) pin on the MR33.
also, the MR33 pins are quite short, make sure you get electrical contact inside the wire plugs.

1 Like

Correct, I used the 115200 baud rate, flow control and paruty on both PUTTY and the device manager properties of the serial connection. Im not sure if changin the usb-tts bridge would solve this issue and used the one recommended from amazon.

So I just followed your steps, and I still did not get the device to show up on putty. However, when I disconnect the serial cable while on putty, it gives me an error. At this point I think I think I'm gonna try on a linux machine to see how it goes.

So I got this running on a linux machine (VM) and i go ahead and run :
chmod a+x
i ran ls -l to make sure the permissions were rightly assigned and it shows:
-rwxrwxr -x 1 myname myname filesize date
then i try to run the: --write=mr33-uboot.bin
and i get an error saying " command not found"

I try the same command with the
./ --write=mr33-uboot.bin
and get this error "/usr/bin/env: 'python2.7': not such file or directory.

Im not sure if anyone could help me here at this point.