Meraki MR18 Setting it up as Repeater

I would like to configure the MR18 as a repeater. This is to extend the existing wifi and connect a device through its ethernet connection. Please advice or point me in the right direction.

Thanks,

1 Like
1 Like

frollic,
Thank you. I will take a look.

OK. I have tried to follow the instructions but I cannot get internet connection. I am getting the following error when doing the ping:-

I have gone through the configuration a number of times now resetting everything back and starting again but no luck. I can able to connect Join the wireless network as I can see the radio active. Any ideas what is the issue or where to look?

Thanks,

I found the SSH script to download the configuraitons and have pasted it below. Thanks for your help.

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.10, r11427-9ce6aa9d8d
 -----------------------------------------------------
root@OpenWrt:~# ubus call system board; \
> uci export network; uci export wireless; \
> uci export dhcp; uci export firewall; \
> ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
> ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
{
	"kernel": "4.14.275",
	"hostname": "OpenWrt",
	"system": "Qualcomm Atheros QCA9558 ver 1 rev 0",
	"model": "Meraki MR18",
	"board_name": "mr18",
	"release": {
		"distribution": "OpenWrt",
		"version": "19.07.10",
		"revision": "r11427-9ce6aa9d8d",
		"target": "ar71xx/nand",
		"description": "OpenWrt 19.07.10 r11427-9ce6aa9d8d"
	}
}
package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd23:c830:b414::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'

config interface 'wwan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.30'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/qca955x_wmac'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet3'
	option ssid 'SKY2182A'
	option device 'radio0'
	option mode 'sta'
	option key 'PCBPFLVVDR'
	option network 'wwan'
	option encryption 'psk2'

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

package firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'
	list network 'wwan'

config include
	option path '/etc/firewall.user'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
       valid_lft forever preferred_lft forever
7: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.30/24 brd 192.168.1.255 scope global wlan0
       valid_lft forever preferred_lft forever
default via 192.168.1.1 dev wlan0 
192.168.1.0/24 dev wlan0 scope link  src 192.168.1.30 
192.168.2.0/24 dev br-lan scope link  src 192.168.2.1 
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1 
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1 
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1 
broadcast 192.168.1.0 dev wlan0 table local scope link  src 192.168.1.30 
local 192.168.1.30 dev wlan0 table local scope host  src 192.168.1.30 
broadcast 192.168.1.255 dev wlan0 table local scope link  src 192.168.1.30 
broadcast 192.168.2.0 dev br-lan table local scope link  src 192.168.2.1 
local 192.168.2.1 dev br-lan table local scope host  src 192.168.2.1 
broadcast 192.168.2.255 dev br-lan table local scope link  src 192.168.2.1 
0:	from all lookup local 
32766:	from all lookup main 
32767:	from all lookup default 
ls: /tmp/resolv.*/*: No such file or directory
lrwxrwxrwx    1 root     root            16 Apr 16  2022 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 Jan  6 16:24 /tmp/resolv.conf
-rw-r--r--    1 root     root            40 Jan  6 16:25 /tmp/resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==
# Interface wwan
nameserver 192.168.1.1
head: /tmp/resolv.*/*: No such file or directory
root@OpenWrt:~# 

Your ap/repeater doesn't really need internet access, that in itself isn't an issue.

Does it work for the clients?

By clients do you mean the attached devices? My laptop connected via ethernet gets the IP address from the router as per the instructions but no it does not have internet.

The issue is without internet I cannot progress to the next step of the configuration under "Installing relayd package" and create the replay interface etc..

And I suppose the clients will not get the internet connection without the replay interface that bridges the Lan and Wan.

Thanks,

You should probably install relayd 1st, but you can also DL the package to your client, then (win)scp it to the device, and install it manually via ssh.

This is the Routes screen:

I am afraid that is out of my depth. :thinking:

Then start from scratch (reset the device), install the required packages 1st, then do the config.

If you're connecting a device that only requires an Internet connection (like a smart TV), don't use relayd, just set up a basic routed client.

You need to install relayd or luci-proto-relay

igmpproxy also for IPTV

opkg update
opkg install luci-proto-relay igmpproxy

the configuration you have will work by adding in network file

config interface 'STABRIDGE'
	option proto 'relay'
	list network 'lan'
	list network 'wwan'

After rmodify network file restart network

uci commit network
/etc/init.d/network restart

Here I have several WIFI 6 repeaters with Openwrt and I now have no problems with my 5 android televisions as well as 5 Orange TV UHD boxes

Thank you all for your suggestions. I will these later and report back.

Thanks

I have mode some progress. I restarted from scratch and still had issues getting the internet. I eventually figured out the issue was the AP had same IP as Meraki (see other thread I started for details)

Now I have the Bridge mode setup through Relayd. I have disconnected it from the laptop and rebooted everything. I can connect to it in AP mode as well by connecting the client via ethernet and it works fine.

However, I cannot log into the Luci Web UI. I have tried to have a static IP address and all but I don't get the login screen.

Thanks,

1 Like

Have you got any further, I'm looking at a atheros wds transparent bridge for mine.