Meraki MR18 - Method C problem


Trying to install OpenWRT on a Meraki MR18 using the following guide:
My firmware version is 24-201610261613-Gb6d270c7-onion which means the method "C" should work. I got this firmware output by running odm fw_version via serial, so the odm tool hasn't been removed.

HOWEVER as soon as I reboot by holding the reset button for 10 seconds, the system reboots into busybox (no meraki prompt, just Busybox#, which does NOT have the odm flash tool.

Rebooting the system once more boots it past busybox, where I can once again use the odm commands, but I consistently get timeouts when I try to do this:

odm firmware part2
Connecting to (
wget: can't connect to remote host ( Connection timed out

Yes, I've confirmed my webserver and DHCP are up and running, and even tried with another laptop hooked up to my laptop serving the files and DHCP. No problems there. The problem seems to be with the Meraki device, which only blinks its ethernet light for just a moment. I should also mention the leftmost ethernet light (with the device upside-down) is steady orange with no cable connected.

Trying while the status LED is cycling colours, or blinking orange doesn't make any difference either, I just keep getting timeouts.

odm ip (which should give IP address information) returns an error as well.

Any thoughts?

EDIT: I've gotten it to boot past Busybox by holding the reset button for exactly 12s instead of "10+", but it still won't connect to my webserver. It does get an IP address according to DHCP, but that's about it. Network lights stay off.


For some reason the wired ethernet interface just wouldn't work for flashing BUT.....if the meraki AP errors out after a complete reset, it creates a default "meraki-scanning" SSID. Which just happens to be open and serve DHCP offers. So all I had to do was connect my laptop to the SSID, make sure the webserver listened on the wifi IP address the Meraki gave me and presto! "odm firmware yaddayadda" now worked and flashed the image as expected.

1 Like