Meraki MR18 JTAG connection not working

Hello, I have recently got some used Cisco Meraki MR18's and tried to use JTAG to flash OpenWRT onto them. However, I have got issues as OpenOCD will not recognize the Meraki MR18 and I have read the documentation and I can confirm that the AP is wired correctly.

Here I include some screenshot's and pictures of the wiring diagram and OpenOCD error:

I have the same output but without connecting any MR18

To take a test look here

I've tried the commands and the mr18 doesn't stop booting and doesn't respond to any OpenOCD commands

I've also used this usb blaster pinout and i'm sure that everything is wired correctly
image_2022-06-02_182854694

Yes, usb blaster pinout is correct.
You have to connect only the PIN 1-3-5-9-2-8

does 2 have to connected even if the gnd on the serial is connected?

Yes. There are 2 different devices, not like the Raspberry Pi

ohh, that's why it probably doesn't work as I only have the one ground connection.
Additionally what JTAG pin header is responsible for ground on the MR18?

Standard 14-pin
https://openwrt.org/docs/techref/hardware/port.jtag#pin_header2
2 to 10

Alright I will try that now

I have tried connecting the gnd of the usb blaster, but unfortunately it will still not work.

I now have these messages
Error: isa info not available, failed to read cp0 config register: 0
target halted in MIPS32 mode due to debug-request, pc: 0x00000000

I've done it! Turns out that on firmware 26+ that VCC has to be connected and then it works!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.