Meraki MR-12 borked

So, I have a Meraki MR12 that had an old (V17.x) build on it. Trying to upgrade to v23.x firmware (merged with the MR-16 code) via Luci wouldn't fly. I found a suggestion to SSH in and perform the sysupgrade via command line. That put the the thing in to a boot loop. Cracked it open and attached a serial console and see it's kernel panicking and rebooting...

Tried to do a reinstall (from and/or (

The first gave me "Bad Magic Number" trying the second I'm getting a LZMA ERROR 1 trying to decompress the kernel (I think).

Is there a definitive way to get the MR-12 un-borked and loaded with the latest build? Holding the reset button for 15 secs while powering on seems to make it wan to load the stock firmware name, if I had a source for that, would it at least get in in to a state that I could try a fresh OpenWRT install?

Any pointers appreciated.

This doesn't exist yet. Are you talking about 22.03 or snapshot? Or something else?

You won't be able to migrate directly from such an old version. You'll need to do some intermediate upgrades.

I'd recommend sticking with the MR12 images.

One of the major changes that will prevent the upgrade is the migration from ar71xx to ath79.

  • Start by upgrading to 19.07.10 which is still on ar71xx. DO NOT KEEP SETTINGS. This will cause the configuration to be in the default state after the upgrade.
  • Then upgrade to 21.02.5 which will migrate to ath79. You'll get a warning about an incompatible image... it is safe to force the upgrade provided that:
    • you verified that you downloaded the correct image (mr12 sysupgrade)
    • the checksum matches the value shown on the firmware selector site.
    • you do not keep settings during the upgrade
  • Then you can upgrade to 22.03.3 and configure your device.
1 Like

Thanks for the quick response...

Indeed I meant 22.03, my bad.

So, given I already tried the process that didn't work, I no longer have the option to "Start by upgrading to 19.07.10..." , as the thing won't boot. I can still get a serial console however...

So, is attempting a fresh install with that version the best choice?

You’ll probably need to use tftp. Does the serial console have anything in the boot loaded for that?

Yeah, I can tftpboot a kernel.bin

And assume th flash commands from the [OpenWrt Wiki] Meraki MR12 page, substituting the 19.07.10 page?

(although if I'm going to TFTP a fresh install, why wouldn't I just 22.03.3?)

So you should be able, in theory, to update directly to the latest. If that doesn't work, maybe try installing the MR12 image from 17.01 to get back to where you were.

Gotcha. I guess the issue I had was that [OpenWrt Wiki] Meraki MR12 only has ugrade file links, not for fresh install of the latest version...

The Kernel image is probably what you need to get an install from tftp. From there, it will probably run as initramfs, which is not intended for normal use -- you'll use the sysupgrade feature at that point to flash the sysupgrade image.

OK.. So from the MR12 install page I used the following:

tftpboot 0x80010000 openwrt-19.07.10-ar71xx-generic-mr12-squashfs-kernel.bin;erase 0x9fda0000 +0x240000;cp.b 0x80010000 0x9fda0000 0x240000

tftpboot 0x80010000 openwrt-19.07.10-ar71xx-generic-mr12-squashfs-rootfs.bin;erase 0x9f080000 +0xD20000;cp.b 0x80010000 0x9f080000 0xD20000

setenv bootcmd bootm 0x9fda0000; saveenv; boot

I immediately get a "Bad Magic Number"

Try using LEDE 17.01.

Bingo... i found the compiled images for Riptide's LEDE CC build, flashed it and it's happy now.

So that's from 2016. Now that it's running, do you recommend I try the hop to 19.07.10 and then go to 21.02.5 and then 22.03.3 that you outlined above?

Thanks much for your help.

Yes, I think this should work.

Well, the upgrade to 19.07.10 worked. The subsequent forced upgrade to 21.02.5 (not keeping settings) resulted in a kernel panic/reboot loop

Which image did you use?

That one should have worked. Not sure why it has kp’d.

Hmm.. this KP is the issue that I ultimately ran in to previously. In the serial console the last non-successful entries are:

[    1.481642] No filesystem could mount root, tried:
[    1.481646]  squashfs
[    1.486562]
[    1.490346] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
[    1.500164] Rebooting in 1 seconds..

In my first adventure with this yesterday I also at one point got a LZW error. Any chance this squashfs is compressed using an algorithm not natively supported for decompressing?

@lexmark3200 have you seen anything odd on 21.02 or 22.03 as you seem to be the only person on the forum who has successfully booted the ath79 images on the mr12.

Ah actually I haven't gotten those to boot. Earlier I mentioned:

Well, the upgrade to 19.07.10 worked. The subsequent forced upgrade to 21.02.5 (not keeping settings) resulted in a kernel panic/reboot loop

After that I had to start over and stopped at 19.07.10.. so l. in the same camp as everyone else. Sorry.