MediaTek MT7628AN / relayd / dhcp

Hi all. I'm having trouble with OpenWrt 19.2 on TP-Link Archer C50 v3. This behaviour has been the same in previous versions not just 19.2. Perhaps it's specific to MediaTek MT7628AN or maybe it's a problem with relayd I'm not sure that's why I'm posting.

I have the C50 setup as 5ghz bridge to an Archer VR600 v1 vdsl modem. I'm only using 2.4ghz for client access and leaving the 5ghz radio dedicated to bridge. Everything seems ok and clients get dhcp from the VR600 but every day at some random time clients lose dhcp and can't reconnect.

If I set clients to manual ip configuration they work fine but some are tiny IoT devices and can't be configred manually. Over many weeks I've tried and tested everything I can. The only thing that works is to run cron 0 * * * * /sbin/wifi.

Reloading wifi every hour works but this should not be happening.

Any ideas?

See this issue #169
and try correctly set options "disassoc_low_ack", "legacy_rates" in wireless config.

Yes tried all that. So in other words issue #169 remains unresolved since 2018.