Master failing to compile: patch 379-mac80211-fix-starting-aggregation-sessions-on-mesh-i fails to apply

Hi Everyone,

I want to compile on the current master to see if some of the issues (mesh blackhole and mediatek ethernet switch) that are affecting me on the openwrt-21.02 branch are fixed there.

However, the compilation fails here:

Applying ./patches/subsys/379-mac80211-fix-starting-aggregation-sessions-on-mesh-i.patch.orig
using plaintext:
patching file net/mac80211/tx.c
Hunk #1 succeeded at 1182 with fuzz 1 (offset 23 lines).
Hunk #2 FAILED at 1195.
1 out of 2 hunks FAILED -- saving rejects to file net/mac80211/tx.c.rej
Patch failed!  Please fix
make[3]: *** [Makefile:571:
Error 1
make[3]: Leaving directory '/openwrt/package/kernel/mac80211'
time: package/kernel/mac80211/compile#1.00#0.36#1.12
    ERROR: package/kernel/mac80211 failed to build.
make[2]: *** [package/Makefile:116: package/kernel/mac80211/compile] Error 1

I was compiling fine on the openwrt-21.02 branch. I ran "make clean"
before compiling again and changed the feeds to point to the current
master branches of each package feed useded.

Am I missing something like some system package / compiler tools to update / change?

Thanks in advance

Building fine here, did you reset also master itself, also you might have to clean things up

rm -rf bin tmp build_dir

or make clean... whatever

I did that, but it keeps failing. If I delete that patch which is failing it runs and compiles successfully.
I wonder if this is happening simply because that patch is backporting something from kernel 5.10 but on master 5.10 is enabled by default? Maybe in the buildbot configuration it is configured to compile with the 5.4 kernel and that's why is not failing there?

BTW I'm compiling a mediatek target (ramips).

Might be target specific, I'm building a different target. But I think the issue might be that the build system is attempting to apply a dried muffin remnant left over from a previous fail, indicated by the first message in your fail log (...patch.orig).

1 Like

I think you're right because I found two similar patches in the tree and one I didn't understand what it was, after deleting both it compiled, now that you suggested this I tried to restore the patch from the git tree. Thanks! Will let you know how it goes.

You were right @anomeome, thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.