Making USB WIFI Dongles work

Hi, I have some USB Wifi dongles that I've been trying to make it work on TL-WDR4300 usb ports:

Model: TP-Link TL-WDR4300 v1
Architecture: Atheros AR9344 rev 2
Firmware Version: OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-20.247.75781-0d0ab01
Kernel Version: 4.14.195
root@tl-wdr4300:~# lsusb
Bus 001 Device 003: ID 0bda:a811 Realtek Semiconductor Corp. RTL8811AU 802.11a/b/g/n/ac WLAN Adapter
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 001 Device 005: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter

I tried one at a time.
and I've done:

# Just because I have plenty extroot space I used it instead of wpad-basic
opkg update && opkg remove wpad wpad-mini && opkg install wpad-wolfssl

opkg find *rtl8812*
opkg install kmod-rtl8812au-ct
wifi config # radio2 appeared
uci set wireless.@wifi-device[-1].disabled='0'
uci commit wireless
wifi reload


opkg find *mt76*
opkg install kmod-mt76-usb # brings kmod-mt76-core
opkg install kmod-mt7601u # brings mt7601u-firmware
wifi config # radio2 appeared
uci set wireless.@wifi-device[-1].disabled='0'
uci commit wireless
wifi reload

in all cases device appers on luci, the mt76 allows to do a scan, the realtek doesn't.
both ones appears as Generic 802.11bgn - Device is not active on luci, and does not initialize AP or STA config, both appears to show their macaddresses listing config using: cat /var/run/hostapd-phy0.conf

Please, if someone can help me in proper steps to make it work at least one of them.


There no point in even discussing about the Realtek USB wireless card, but while the Mediatek one should more^wless or less work, you'd still be up for a world of pain - just don't, and stick to the internal wireless cards of your tl-wdr4300.

1 Like

There is a list somewhere of worth trying USB WiFi Dongles?


Avoid USB wireless for 24/7 OR AP usage, it's not good at either, before even thinking about range or throughput (where it can't score either, in particular not connected to the rather slow USB bus of a tl-wdr4300, but NOT limited to this combination).

1 Like

I want to use a usb 4-port hub with 4 usb dongles and all of them act as clients, it is for a prof of concep with MWAN3 multiwan capability, so MT7601U may work for this I think, I do not need to be fully performant/stable, I think that I can even unbind/bind again if some of the usbs get stuck (removing-readding usb power by software)

I just tried the MT7601U as client /station an it works. but yes, it didn't work as AP.

LOL it connects but do not receive the DHCP IP...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.