Macvlan no ping possible

Hi,

i tried to use macvlan to have multiple interfaces on my lan ports.
I plan to use mwan3 as i want to combine 5 gateways that are all on the same physical network.

When i define 2 additional interfaces, i can ping them locally on the router but i'm not able to ping other devices connected via the lan ports.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd39:e45b:9e7c::/48'

config interface 'lan'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'


config device 'veth2'
	option name 'veth2'
	option type 'macvlan'
	option ifname 'eth1'
 
config device 'veth3'
	option name 'veth3'
	option type 'macvlan'
	option ifname 'eth1'

config interface 'lan2'
	option ifname 'veth2'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.0.0.131'

config interface 'lan3'
        option ifname 'veth3'
	option proto 'static'                                                              
        option netmask '255.255.255.0'                                       
        option ipaddr '192.168.8.10'


config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

root@OpenWrt:~# ifconfig

eth0      Link encap:Ethernet  HWaddr 60:E3:27:2A:59:81  
          inet6 addr: fe80::62e3:27ff:fe2a:5981/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1216 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:378814 (369.9 KiB)
          Interrupt:4 

eth0.2    Link encap:Ethernet  HWaddr 60:E3:27:2A:59:81  
          inet6 addr: fe80::62e3:27ff:fe2a:5981/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:810 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:269996 (263.6 KiB)

eth1      Link encap:Ethernet  HWaddr 60:E3:27:2A:59:80  
          inet6 addr: fe80::62e3:27ff:fe2a:5980/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23314 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2422 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4105555 (3.9 MiB)  TX bytes:511871 (499.8 KiB)
          Interrupt:5 

eth1.1    Link encap:Ethernet  HWaddr 60:E3:27:2A:59:80  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fd39:e45b:9e7c::1/60 Scope:Global
          inet6 addr: fe80::62e3:27ff:fe2a:5980/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:635 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2687260 (2.5 MiB)  TX bytes:79955 (78.0 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:685 errors:0 dropped:0 overruns:0 frame:0
          TX packets:685 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:56397 (55.0 KiB)  TX bytes:56397 (55.0 KiB)

veth2     Link encap:Ethernet  HWaddr 0E:D6:8C:BA:32:15  
          inet addr:10.0.0.131  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::cd6:8cff:feba:3215/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:3864 (3.7 KiB)

veth3     Link encap:Ethernet  HWaddr CA:B8:8E:D8:41:F2  
          inet addr:192.168.8.10  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::c8b8:8eff:fed8:41f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:966 (966.0 B)

root@OpenWrt:~# ping 10.0.0.140 -c 3
PING 10.0.0.140 (10.0.0.140): 56 data bytes

--- 10.0.0.140 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:~# ping 10.0.0.131 -c 3
PING 10.0.0.131 (10.0.0.131): 56 data bytes
64 bytes from 10.0.0.131: seq=0 ttl=64 time=0.277 ms
64 bytes from 10.0.0.131: seq=1 ttl=64 time=0.254 ms
64 bytes from 10.0.0.131: seq=2 ttl=64 time=0.254 ms

--- 10.0.0.131 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.254/0.261/0.277 ms
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# ping 192.168.8.1 -c 3
PING 192.168.8.1 (192.168.8.1): 56 data bytes

--- 192.168.8.1 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:~# ping 192.168.8.10 -c 3
PING 192.168.8.10 (192.168.8.10): 56 data bytes
64 bytes from 192.168.8.10: seq=0 ttl=64 time=0.274 ms
64 bytes from 192.168.8.10: seq=1 ttl=64 time=0.254 ms
64 bytes from 192.168.8.10: seq=2 ttl=64 time=0.252 ms

--- 192.168.8.10 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.252/0.260/0.274 ms

Anyone here can help me?

I guess you should use the same ifname=eth1.1 for interface=lan and device=veth*.
On the other hand, you can set up multiple LAN interfaces by spliting VLANs.

Thanks for reply!
if i use ifname=eth1.1 on the veth interface, it disappears in ifconfig...thats annoying because the sample confings i've found also say that i should use eth1.1 instead of eth1

VLAN is not possible because i have one huge network (physically a few kilometers, connected via directional wifi) where the gateways are located.