MAC Address cannot be changed

OpenWrt 22.03.0 r19685-512e76967f / LuCI openwrt-22.03 branch git-22.304.65171-ec905e6
TP-Link Archer A7 v5

In the past, I was able to override the MAC on the WAN interface. But in recent versions of OpenWrt, it doesn't take. I entered a custom MAC on the devices in the Devices tab, but on the Interfaces tab, WAN is showing the default. It is ignoring the MAC value from the associated device.

Is there another way to accomplish?

dmw73,

After changes, don't forget the Save & Apply button, see also unsaved changes button on top of screen?

You could also check /etc/config/network, it should contain something like:

config device
        option name 'wan'
        option macaddr 'FF:F6:24:84:89:5A'
        ...

Hopefully you get it working as it should be.

DG.

1 Like