M2 WiFi AC/AX card recommendation

I need good 2.4GHz AP m.2. WiFi card.
Range is most important thing. AC is ok. I don't need 5GHz (5GHz range is too low).
Any ideas?
I tried intel cards (AX200, 8265NGW), and they do not work in AP mode (only adhoc).

PCI-E x1 is alternative.

ath9k-, ath10k based or mt7615 would probably the chipsets to look for.

1 Like

Problem is with M2 cards with AP support. Anyone have some experiance?

PCI-E x1 is alternative.

You just received three suggestions?

Only suggestions. This doesn't help me without name of real wifi card.

Three simple searches is all you need, and you're welcome.

2 Likes

I was looking for hours. Sorry stupid me....
... one is enough for 2.4GHz+5GHz or I need two of them?

Was actually answered just a week ago, in X86 2.5gb-e MiniPC + PCie AX card suggestions - #7 by slh

I bought QCA6174A-5 jjPlus JWX6058. It is working fine in windows. In openwrt I have serious of problems. I installed firmware and drivers.

On new openwrt It can't load, init firmware (errors).
I tried old one (19.07)

    7.802139] ath10k_pci 0000:00:11.0: pci irq msi oper_irq_mode 2 irq_mode 0 r                                                           eset_mode 0
[    8.242201] ath10k_pci 0000:00:11.0: Direct firmware load for ath10k/pre-cal-                                                           pci-0000:00:11.0.bin failed with error -2
[    8.256582] ath10k_pci 0000:00:11.0: Falling back to user helper
[    8.272097] firmware ath10k!pre-cal-pci-0000:00:11.0.bin: firmware_loading_st                                                           ore: map pages failed
[    8.287860] ath10k_pci 0000:00:11.0: Direct firmware load for ath10k/cal-pci-                                                           0000:00:11.0.bin failed with error -2
[    8.302638] ath10k_pci 0000:00:11.0: Falling back to user helper
[    8.318741] firmware ath10k!cal-pci-0000:00:11.0.bin: firmware_loading_store:                                                            map pages failed
[    8.335795] ath10k_pci 0000:00:11.0: qca6174 hw3.0 target 0x05020000 chip_id                                                            0x003409ff sub 168c:3361
[    8.350612] ath10k_pci 0000:00:11.0: kconfig debug 0 debugfs 1 tracing 0 dfs                                                            1 testmode 1
[    8.367196] ath10k_pci 0000:00:11.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-                                                           1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[    8.464427] ath10k_pci 0000:00:11.0: board_file api 2 bmi_id N/A crc32 4ed356                                                           9e
[   10.627396] ath10k_pci 0000:00:11.0: Unknown eventid: 118809
[   10.643606] ath10k_pci 0000:00:11.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp m                                                           ax-sta 32 raw 0 hwcrypto 1

Is it worth of try another QCA6174A or try ath9k?

QCA617x is a bit of QCA's red-headed stepchild, it works, but it doesn't meet the reliability of the QCA9xxx series (especially in AP mode) - it's made for cheaper notebooks, not routers/ APs.

Personally I'd first try to have a little more fun with the card you have, while I wouldn't envision a bright future for its intended purposes, you really should be able to get it working.

There is no another m2 (2x2:2) with ath10k except QCA617x .