I try to create a wifi bridge between my ISP router (not on OpenWrt) and a router on OpenWrt (see model below). I don't know if WDS is supported by my ISP router (I tried the following guide but I could not make it works.

So I followed this other guide to make the bridge, but after installing the relayd and luci-proto-prelay package using the gui, there is no Relay bridge option in the list Protocol of the new interface of the web page /cgi-bin/luci/admin/network/iface_add (I rebooted after the installation of the packages):

I believe that both packages are correctly installed as the files /overlay/upper/www/luci-static/resources/protocol/relay.js and /usr/sbin/relayd exist.

I also tried using uci with ssh

uci set network.repeater_bridge=interface
uci set network.repeater_bridge.proto='relay'
uci set'lan wwan'

but then I get Unsupported protocol type. Install protocol extensions... for the REPEATER_BRIDGE in the /cgi-bin/luci/admin/network/network web page.

Does anyone know how to force an interface protocol to relay bridge, or how to properly setup relayd ?

My router model is CH-WR822. It came with OpenWrt preinstalled (I am not sure if I should and how could I update it).

root@OpenWrt:~# cat /etc/openwrt_release
DISTRIB_DESCRIPTION='OpenWrt 19.07-SNAPSHOT r10272-e0f4688'

OpenWrt version:
OpenWrt 19.07-SNAPSHOT, r10272-e0f4688

fwiw, the installed snapshot is over a year old and predates stable releases. If you downloaded and installed the relevant packages recently, the current packages are for latest snapshots and so may not be compatible with your old snapshot release.

Someone will correct me if I'm wrong.

I updated to openwrt-19.07 branch (git-20.247.75781-0d0ab01) / OpenWrt 19.07.4 r11208-ce6496d796 and it Relay bridge option is in the list Protocol of the new interface.
Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.