Lucy gives 502 Bad Gateway error after first time installation on TP-LINK Archer C6 V3

I use a TP-LINK ARCHER C6 V3.20 Router which I got in 2021. I installed OpenWrt by using files present here: [OpenWrt Wiki] TP-Link Archer C6 v3

However, as soon as I tried to go to the GUI after installation, lucy gives me a 502 Bad Gateway Error. What should I do?

Try clearing your cache and cookies. Alternatively, use an incognito window or a different browser.

Also, it is worth noting that openwrt does not use nginx (unless user installed), so that response is either cached or is coming from another device on your network. Make sure that there are no other devices using the address, and that your computer is on that subnet. Best option is to disable WiFi and make a direct Ethernet connection from your computer to the lan port of your openwrt device (ideally with no other connections)

1 Like

Which file specifically did you use?

1 Like

Good question! If the op used the snapshot, that could also explain the error (although I wouldn’t expect a nginx error).

You have installed a snapshot image. Read the link for instructions how to install Luci, which is not installed by default in snapshots.

1 Like