Luci won't load - a file downloads instead

My system has been working fine for a while.. Archer C7 ver 2.0

Using OpenWrt 18.06.1, r7258-5eb055306f

I can access the system using SSH etc but not using a web browser any more.
Chrome, IE and Edge...

When trying to use a web browser the file "luci" downloads instead...

Any ideas on how to fix this ?

I've tried removing Luci and installing the opkg again.. still the same.
In fact when it was removed.. there was no change.

Here's the source of the page I get instead:

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "">
<html xmlns="">
<meta http-equiv="Cache-Control" content="no-cache" />
<meta http-equiv="refresh" content="0; URL=/cgi-bin/luci" />
<body style="background-color: white">
<a style="color: black; font-family: arial, helvetica, sans-serif;" href="/cgi-bin/luci">LuCI - Lua Configuration Interface</a>

The first step for debugging these particular should always involve deleting your browser cache and potentially testing a different browser, even though this doesn't appear to be a primary suspect here.

More likely would be a corruption of /etc/config/uhttpd or /etc/config/luci, both of which you could restore from their /rom/etc/config/ backups - if that doesn't help either, a factory reset could be a natural next step (as it would re-establish potentially deleted packages).


Please check the webserver you run via netstat -nltp. If it is not uhttpd listening on port 80 the verify the cgi config of the respective server

Ahh I have 1091/lighttpd running on port 80...
How do I remove it and run uhttpd instead?

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN 1091/lighttpd
tcp 0 0* LISTEN 3271/dnsmasq
tcp 0 0* LISTEN 1070/dropbear
tcp 0 0 :::80 :::* LISTEN 1121/uhttpd
tcp 0 0 :::53 :::* LISTEN 3271/dnsmasq
tcp 0 0 :::22 :::* LISTEN 1070/dropbear

  • How did lighttpd get installed?


opkg remove lighttpd

It appears I installed an additional package using the GUI and it was in an attempt to restrict internet access.
Nothing appears to happen until I rebooted the router..

I've removed the offending HTTP server and it's rebooting...

YES!! working.... thanks for all the help guys.. Excellent!!!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)