Luci suddenly disappeared

Today suddenly I seen the internet connection to drop for some seconds on my linux box and then come back.

I want to check the router but when I tried to login I got this error in the browser:

No root node was registered, this usually happens if no module was installed.
Install luci-mod-admin-full and retry. If the module is already installed, try removing the /tmp/luci-indexcache file.

I tried from another box without success.

Then I logged in from ssh to check if the luci-mod-admin-full package was installed and it was:

root@OpenWrt:~# opkg list-installed | grep luci-mod-admin-full
luci-mod-admin-full - git-16.018.33482-3201903-1

Then tried to reinstall it:

root@OpenWrt:~# opkg --force-reinstall install luci-mod-admin-full
Removing package luci-mod-admin-full from root...
Installing luci-mod-admin-full (git-16.018.33482-3201903-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/luci/luci-mod-admin-full_git-16.018.33482-3201903-1_ar71xx.ipk.
Configuring luci-mod-admin-full.
Collected errors:
 * extract_archive: Cannot make dir /usr/lib/lua/luci/controller/: Input/output error.
 * extract_archive: Cannot make dir /usr/lib/lua/luci/controller/admin/: Input/output error.
 * wfopen: /usr/lib/lua/luci/controller/admin/network.lua: Input/output error.
 * wfopen: /usr/lib/lua/luci/controller/admin/index.lua: Input/output error.
 * wfopen: /usr/lib/lua/luci/controller/admin/filebrowser.lua: Input/output error.
 * wfopen: /usr/lib/lua/luci/controller/admin/uci.lua: Input/output error.
 * wfopen: /usr/lib/lua/luci/controller/admin/system.lua: Input/output error.
 * wfopen: /usr/lib/lua/luci/controller/admin/status.lua: Input/output error.

Any other ideas please?

The input/output error isn't a good sign. I think your router is having a hardware problem.

1 Like

Yes it could be, any way to be sure?
I searched for something like fsck but no luck.

You would install e2fsprogs...but you have a deeper issue with that I/O error...

https://openwrt.org/packages/pkgdata/e2fsprogs

Is there any error message in dmesg?

yes, these:

root@OpenWrt:~# dmesg | grep error
[    9.410000] jffs2: error: (398) jffs2_build_inode_pass1: child dir "controller" (ino #170) of dir ino #169 appears to be a hard link
[   12.520000] Data bus error, epc == 87081128, ra == 87081128

Is there enough free space at "/overlay"?
Is it mounted read-write?

Yes, mounted rw and 44% used of 2.4M

Do not use 15.05.1 any more, is the easiest advice.

If you router is a small old one with only 4 MB flash / 32 MB RAM, install 17.01,
If larger, install 18.06.1

You may already have somewhat corrupt flash file system, so flashing again (without preserving settings) is a viable option.

2 Likes

At the end I decided to buy a new router.
Thanks for your help guys!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.