Luci stopped working

I'm going to split my issue into several questions so you don't have to read all the info and instead focus on what is relevant for you.

What's your set up?
I'm using a tp-link Archer C7 (US) Ver: 5.0. I installed:


with no issue using the GUI. Everything worked fine.

What's the problem?
Luci is not working so I cannot enter the router settings. I get this (as I'm new I'm limited to just one image per post):

Unable to connect
Firefox can’t establish a connection to the server at

The same happens with chrome.

The router is working fine as an access point. In the image below you can see the router's IP seen from my ISP modem.


What caused the issue?
When selecting the protocol for the WiFi network I went for "Legacy" (I cannot access Luci, so I can't take a picture to show you).

Why did you do that?
Because after installing everything worked like a charm, except for my Sony SRS-X7 speaker. According to Sony:

The unit does not support IEEE 802.11a/n or other 5 GHz frequency bands. Use the 2.4 GHz frequency band (IEEE 802.11 b/g) for the Wi-Fi network.

So I turned the 5GHz band off and only used the 2.4 GHz band. Still my speaker didn't connect. That's when I switched to "Legacy". Now Luci is not working, neither my speaker :frowning: .

What do you need?
I need to restore Luci so I can continue working on the solution for my speaker connection.

Any help will be highly appreciated.

@evol999, welcome to the community!

This is normal, as that's not the IP to access a default install of OpenWrt. The IP is

Also, your pic is not OpenWrt, that leads me to believe that your showing the WAN IP. By default, you can only access the web GUI from the LAN side, due to the firewall config.

  • To be more clear, are you saying WiFi is off?
  • Did you try the Ethernet ports?

Thank you.

After the initial setup I used that address to set my OpenWrt as an access point -I don't know if these are the correct words- but what I'm trying to say is that OpenWrt turns my "wired" internet from my ISP modem into WiFi. This WiFi is working fine to the very moment that I'm writing this.

I was able to "play" with OpenWrt settings via Lucy on the address. After changing the channel mode to "Legay" Lucy access is down. I have restored the WiFi to the settings where Luci was working but I had no luck with that So I think this is an issue, a bug.

No. WiFi is up and running but only on the 2.4GHz band -at the moment of my initial report-. Everything is working fine except -again- for my speaker and Luci. After the tests I re enabled the 5 GHz band.

After some tests these are my conclusions:

  • Right now if I connect a device to any Ethernet port of my OpenWrt router, it works.
  • The only way to access Luci is to connect my laptop directly to my PC and access the But doing so is really annoying since I have to disconnect and reconnect everything every time I want to adjust the OpenWrt device, so I would like to be able to enter OpenWrt from

Final comment: if I open a browser and put this address this is what the browser shows:

Where does this "cgi-bin/luci" come from? What I mean is that something is responding but Luci doesn't start.

Then, not sure how you just turned off LuCI if you're actually connected to a working WiFi.

  • Something is configured improperly - or you plugged into the LAN ports for AP use only, OK.
  • You should be able to access the device if you're on LAN
  • laptop directly to your PC - where's the router/AP in the connection???

This is the landing page in OpenWrt, and since it didn't load, I surmise that's just your Firefox cache.

  • So to be clear, you still cannot access LuCI via wired Ethernet?
  • Can you try to SSH into the router?

Yeah that's my problem! LuCi is no longer available for me.

I agree, something is wrong. But I'm using the slot labeled "Internet" (the blue one)

That's the problem I'm trying to solve.

Here is a basic draw of my set up.

I previously was able to access LuCi on But it stopped working.

No sir, I still cannot access LuCI via wired Ethernet (but I was able to). That's my problem.

I'm newbie to OpenWrt. Let me learn about this and I'll come back to you after running some tests.

OK I tried to connect using SSH over Putty (I'm on windows 10) this is what I got:


To (my OpenWrt IP). It fails immediately.

When I try it takes a while and fails like this:


If you want an AP, use LAN ports only. As I previously noted:

That's likely why you cannot access LuCI.

I believe that this is the wiki you are looking for:

Before doing all this, if not already done, I suggest you to get familiar with the recovery steps on your Archer C7 and make a backup at first.

Essentially, as @lleachii noted, you need to plug one of your LAN from your modem to one of the orange LAN of your OpenWrt router (Archer C7). Your C7 should then be on the same network than your modem DHCP range, Do not use the WAN blue port of the C7, leave it unplugged.

DHCP server on LAN of your C7 needs to be disabled BEFORE doing the cabling. The steps provided by the Wiki makes you disable the DHCP, attribuate a static IP to the LAN interface and disable firewall and other things. You could configure LAN to be DHCP client but that could lead to troubles, especially if it doesn't get served an IP.

One last taught, if you assign your LAN interface C7 a static address in the range, be sure to select one outside of the DHCP range of the modem, or set the modem's DHCP range to start at to reserve the addresses below for your own purposes.

1 Like

Thank you guys.

@lleachii you were right from the beginning the problem was that I didn't properly understand.

After applying the steps given by @DjiPi it was clear for me what was wrong: it's not the same a WAN port than a LAN port. So my bad for not getting @lleachii's answer from the beginning.

Still I prefer @DjiPi's answer because it's more explicit, and contains more info for newbies like me, that's why I marked it as the solution.

Now LuCI is working for me again. My first problem is solved. I'll open a second topic tomorrow for the other one.

Thank you for your time and effort.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.