Luci-proto-wireguard - The installed version of package kernel is not compatible


#1

Could you help me with the following... When I try to install luci-proto-wireguard I get the following warning:

Details for package luci-proto-wireguard

    Version: git-19.011.22767-e3fa766-1
    Size: ~2.0 KB installed
    Dependencies:
        kmod-wireguard (61.1 KB) Not installed
            kernel Version incompatible
            kmod-udptunnel6 (1.7 KB) Not installed
            kmod-udptunnel4 (2.3 KB) Not installed
        wireguard-tools (27.7 KB) Not installed
            libmnl (5.3 KB) Not installed
            ip-full (158.8 KB) Not installed | ip-tiny (120.0 KB) Not installed
                libnl-tiny Installed

Description

Support for WireGuard VPN

    The installed version of package kernel is not compatible, require 4.14.91-1-637dd8ee… while 4.14.90-1-637dd8ee… is installed.

#2

I'd advise running a release version of OpenWrt if you're not.


#3

I'm running the only version available for my device:

http://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-glinet_gl-ar750s-squashfs-sysupgrade.bin


#4

Again, snapshots are upgraded on a regular basis, therefore the packages and requisite kernel versions change:

Options:

  • force the install (not advised)
  • build yor own image with proper packages
  • wait until next snapshot and packages are built (suggested)
  • wait for version 19 for your device

See: https://openwrt.org/releases/snapshot


#5

Where would I see if there are new snapshots available and how do I update my version - do I manually install the image (and Keep Settings) or is there an automatic process?


#6

Ummm...In the same location you downloaded it. The date will obviously change.

http://downloads.openwrt.org/snapshots/targets/ath79/generic

The sysupgrade command.

See: https://openwrt.org/docs/techref/sysupgrade