Luci, nosubnet mask when compiling image with defaults


I am building an openwrt image from git sources. If I leave everything as default and add just the luci uhttp server, the image builds just fine. However, compared to the supported builds, when trying to configure a static address, the luci web interface misses the subnet mask.
As a result, if I add, e.g., the routing table is wrong and even if I add an router ip address (e.g., nothing gets routed.
I noticed that the subnet mask is not missing when I download a prebuild firmware image or use the default image with the image builder.
Does anyone know what luci mod, lib or app needs to be selected to have the subnet mask?

Thanks in advance.

Add where? Router's LAN interface's IPv4 address?
(There is no proper place to add the address when building, unless you add a personal /etc/config/network into the build (or edit the config generation script). So I am a bit uncertain on what exactly you are talking about)

LuCI only manipulates the normal uci config files in /etc/config.

Adding the subnet mask to the static address looks a bit strange. I would expect you to enter netmask, gateway and DNS server when you set a static address.

@hnyman I do the following:
Build image
Boot Openwrt
Then trying to change the static Ip address using luci menu: Network -> Interfaces -> LAN -> Edit
Protocol Static and then the subnet mask is missing and even the help text says that I need to add the static address in the way x.x.x.x/xx.
Thus the question, which option adds the subnet mask field?


To my knowledge "/24" is not enter to the IP address field, but that is quite normally done in the netmask field below, like here in the screen (copied from anothr post here):

That is example of a secodary router that sends traffic to the main .1 router that is defined as gateway and dns server.

@hnyman Seems to happen only if the configured IP Address is removed with the "-" bottom.
Please see screenshot. So probably a bug. So the solution is to change and not to remove and add.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.