Luci Interface doesn't load fully

On one particular PC, the Luci interface doesnt load, I see LuCI - Lua Configuration Interface in the browser but the login boxes never appear, it just sits there waiting for before the browser eventually says web page isn't available.

The only difference between the PC that cannot fully load the page is that it's wired into the router whereas the others are wireless. I've tried different browsers and cleared the cache.

What version of OpenWrt? Are the os and browser versions on the computers the same? Are the wired and WiFi networks the same (not separated or VLANs)? Is the computer directly connected to the router or is there a switch (or any other devices) between them? Can the computer reach other hosts on the network? Have you tried rebooting the computer? The router? An incognito/private browser window?

1 Like

Its the latest version of openwrt
I've tried Windows 10 with Chrome and Edge, and Mac OS with Safari.
The computer is connected directly to the switch
There is no VLAN on that port
Computer can reach other hosts and SSH to the router fine.
Incognito window does the same

What exactly does "latest" mean to you?


19.07.2 - I thought that was the latest I only put the firmware on a few weeks ago. is not the default IP address... What else did you change? Is there anything worth mentioning about your current setup?

I have a router operating as a gateway on, I have pihole running on

Openwrt controls the dhcp and is the only broadcasting access point.

Nothing special really.

Does the problem persist after flashing 19.07.3?