LuCi has vanished

I installed 21.02.1 on a Linksys WRT1900ACS and configured it as an AP (with some difficulty). Now I am trying to reproduce a problem that I encountered to see where to assign the bug, but LuCi is nowhere to be found. I can ping the router at the correct address and it responds, but Firefox says 'Unable to Connect'. I did a hard reset (hold down the reset button while turning on power, keep it down until the LED goes to fast flashing). Chromium says ' refused to connect' and Firefox says 'Unablet to Connect'.

I can still get an ssh password prompt from, so:

  1. What is the default SSH password?
  2. Once I get in, what information would you like me to collect so we can diagnose why LuCi no longer responds?

What image did you install? What settings did you change?

When the LED is flashing quickly, you are in failsafe mode -- you need to set your IP address manually on your computer, and LuCI will not be active. You'll connect via ssh when you're using failsafe mode.

The default ssh password is blank (username: root).

installing factory image or after factory reset, there is no password for root

  1. LuCi vanished before I booted into failsafe mode.
  2. I set the IP address manually, else I wouldn't have been able to ping the router.
  3. Rebooting normally returned the router to the original IP address (not 1.1), but LuCi was still not present.
  4. Rebooting in Failsafe Mode puts the router on 1.1 (it replies to pings), but this time it refuses connections on port 22. I booted into Failsafe Mode twice; both times it came up on 1.1 and both times it refused connections on port 22. Yesterday I had a login prompt.
  5. I attempted to do a hard factory reset - I let the router boot normally (although this time it came up on 1.1, not the .3 subnet that I had programmed into it) - and then held down the reset button for 10 seconds. The power LED started fast flashing after only 5 seconds, but I held down the reset button for well past 10. The router rebooted quickly; I can ping it on 1.1 but it still refuses ssh connections. I tried the factory reset twice.

11 hours ago you just needed the password for ssh

now you've done something that broke that!

Hopefully, you can revert back to the old firmware - using firmware recovery procedure (easiest is the power switch way)

I think instead of factory reset, you should try to flash the last working firmware again to see if the problem stays...

Thank you; the power switch method worked; the router switched over to the previous partition and LuCi has returned. (Note to self: routers that have two firmware partitions pay for themselves many times over in a situation like this.)

When I have more time I will attempt the upgrade to 21.02 again and see if I can recreate these problems.

Perhaps the next time LuCi disappear, you might want to check if uhttpd is up or not.
Maybe a simple

service start uhttpd

from the CLI can solve the problem.

how? with no SSH and no LUCI?

If you noticed that in the first post, he still has SSH access. Which mean, he can still login to CLI mode and check and performed what I said.

Oh, I do know that, but before your suggestion he did say he has no SSH any more - so, unless he also has a TARDIS, then what he had in the first post isn't going to help :smiley:

I believe there's no way " LuCi would simply vanish", unless it wasn't there in the first place. If OP was able to access the router via SSH then they could try and find if luci is indeed installed or not before performing resets.
Now multiple resets might've messed up the partition structure.... or some config which disabled ssh access.

It would be better if OP goes back to OEM firmware and starts all over again. Just have to figure out how to re enable SSH for that.