LuCI - dependency error - libiwinfo20200105

I'm getting error while installing Luci from package
Before installation I made repo update with opkg update, but it still won't work.

Collected errors:

* satisfy_dependencies_for: Cannot satisfy the following dependencies for Lucy:

I also tried to use another package from the other version:
Same results.
Does anyone have similar issues and found a solution for it?
Router model ASUS RT-AC85P

Did you download the packet immediately after you downloaded and flashed the snapshot image?
Snapshots are updated on a daily basis, so if you try to install a package a few days later you will end up with with version mismatches.
Download and flash again the current snapshot, then immediately install the extra packages you'll need.

1 Like

Yesterday I did it within 2 hours after installation. Today I upgraded router OS and tried to install LuCI immediatelty after update with the same error.

Are you using opkg or download the packages manually?

Same error here. There is no such package as libiwinfo20200105 (needed by rpcd-mod-iwinfo_2020-01-05-efe51f41-2_mipsel_24kc.ipk for example)

I'm using opkg as mention in this article

The file is here:
I am not sure why opkg source is pointing to mipsel_24kc though.

Maybe it's older version (my guess based on package name). In mt7621/packages/ it's libiwinfo20181126 while opkg points /libiwinfo20200105

/etc/opkg/distfeeds.conf contains
src/gz openwrt_core
src/gz openwrt_base
So maybe this is a problem?

My wrong, in my distfeeds I also have sources from different targets, so the problem must be somewhere else.

I think matadams91 is right - there is a mismatch in libiwinfo version ( 20181126 exists vs 20200105 needed)
Very unprofessional fix: open /etc/opkg/distfeeds.conf and replace
src/gz openwrt_core
src/gz openwrt_core
Use this fix ONLY for luci, for other packages (ex. kernel modules) revert back to 7621

Yeah, i got the same message libiwinfo20200105 missing trying to upgrade luci-mod-status & rpcd-mod-iwinfo.
A manual upgrade/install of these two packages with --nodeps fixed it, not perfect but that's the only dependency missing. Also dlded the libiwinfo20200105 and did an install --force-overwrite. Everything in order.

Edit : Avoid doing this unless you're looking for trouble ;).

I'll try your solution, but where did you find libiwinfo20200105?

As suggested by [Sandre] i took it from the mt7620 branch; but don't do it, everything seems normal, then i digged in the logs to check if still ok, and unfortunately it's not (at least for the device i've tested (R6350-no broadcom), i get a load of SIGSEGV do_page_fault(): sending SIGSEGV to iwinfo for invalid read access from... etc. Was a risky from the start so yeah don't until someone have a look at it.

To summurise :
Out of curiousity i tried and installed from scratch netgear_r6350-squashfs-sysupgrade.bin (sysupgrade)

luci_git-20.008.20448-a8087bd-1_all.ipk, installs the libiwinfo20181126 and at the same time requires libiwinfo20200105 so data clash are inevitable and the install fails. Any manual install of either libiwinfo20181126 or libiwinfo20200105 will result in SIGSEGV to Iwinfo/rapd for invalid read access, Luci will become unresponsive as soon as you try to access "Wireless" or any page related to interfaces and it'll time out and boot you back to the login window.

The 01/05 snapshot was rock solid ;).

ramips/mt7621 has failed in compilation in the buildbot for the last week:

Thatswhy it still contains the deprecated package version.

Recent Builds:

Time Revision Result Build # Reason Info
Jan 09 04:27 ab16adf80b61... failure 182 The SingleBranchScheduler scheduler named 'all' triggered this build Failed images
Jan 08 04:12 41c19dd54297... failure 181 The SingleBranchScheduler scheduler named 'all' triggered this build Failed images
Jan 07 08:16 414d0541381d... failure 180 The SingleBranchScheduler scheduler named 'all' triggered this build Failed images
Jan 06 04:03 99dd2709b855... failure 179 The SingleBranchScheduler scheduler named 'all' triggered this build Failed images
Jan 05 06:14 fba8083540ce... failure 178 The SingleBranchScheduler scheduler named 'all' triggered this build Failed images
Jan 04 08:13 e98e046f06f3... success 177 The SingleBranchScheduler scheduler named 'all' triggered this build Build successful

Thanks for clarify that. Today - result is success, everything works as expected.

I did it yesterday and everything works fine. Proper build solved all errors. I only got an xhr request timeout, but changing confing solved this. Thx guys for help.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.