Luci Can't change IP or set time

I am a newbie to OpenWrt, it already solved an issue I was having so I am sold and now want to get more seriously into it.

I proved concept on a TPlink 1043, but now want to upgrade to an AC router.

I was able to get one from ebay already built with 19.07 but it will not allow me to make changes. This router is a BT Hub5 and so not a straighforward install, hence I went for a pre-built model.

First I tried to change the IP subnet so that it could replace another router and so I could copy config settings from one to the other visually.

So I rebooted and cancelled change, then tried to change time by telling it to match my laptop time. This has the same failure.

BT5 Rollback on every change

I have read a plethora of similar posts on changing the IP but the solutions that worked for them do not work for me. Things like reloading the new IP on another tab halfway through update, just did not work.

Now I could try the Apply unchecked button but it knowing my luck I will brick the router, so I am trying to find an easy, total newb instruction on how to change with putty and ssh.

One of the problems I have had with 1st OpenWrt is that it was missing things like WGET and when I tried to install it I got a load of dependencies which themselves had dependencies and so on.

So if someone could give me the step by step directions for how to change the IP I feel it would help others.

Any comments as to why the time would not work would be helpful too.

If you are trying to change the LAN IP address, you have to click on 'Apply Unchecked' button when the warning dialogue box appears.

Have you studied the Installation guide for HH5A?
You can always use the Reset button on back of HH5A to restore default openwrt settings (see section 8).
Section 10 also contains some useful information if using SSH instead of LuCI btw.

Once the router has internet access, the clock on the router will automatically update to current time.


Thanks for reply Bill, my concern was whether I could damage the setup and lose access to the router.

I had someone else install OpenWRT because it was not able to be done in the usual simple two stage process.

My concern was forcing a change with Apply unchecked might damage the install as it was not done in the conventional way.

I can understand why changing IP might cause a router to become confused, but I would expect one of two things.

A. For the firmware to reload the new IP after a special kind of reboot.
B. For a dialog to appear that tells the user to reload the new IP

I have seen some quite good ways of doing this on different stock firmware, but surely the most simple would be to have a Luci homepage option similar to the one that warns of no password set that has a rollback option ONLY for change of IP and only on first boot.

I do not understand why it would do this on a sync time with laptop, which I wanted to do for sake of logs.

What I was actually asking for a step by step guide for changing IP via SSH

However, I must thank you for the link, way too complex for me where I am now but I can see it is going be be extremely helpful when I get my head around the basics.

You cannot cause physical 'damage' the router by changing a setting in OpenWrt. You can only damage the router (brick it) if you install wrong or corrupted firmware.

If you completely lose access to the openwrt router after changing a setting, you can perform a reset to restore default settings, and so regain access as described in section 8.

The warning dialogue box was introduced in openwrt 18 and later.

After changing the IP address, you may have to unplug the ethernet cable (or disconnect wifi) between computer and router a couple of times, to force the computer to get a new IP address from the router.

Section 10 shows basic steps to use VI editor.
You need to edit /etc/config/network file
Then issue a 'reboot' command at the prompt.

(WinSCP can also be used to edit the /etc/config/network file too if you use Windows. See section 10 of the guide)

There is greater risk of making an error if you are inexperienced with making changes via SSH. The LuCI user interface reduces the risk.

I would suggest you use LuCI to make the changes, and press the 'Apply Unchecked' button !

Once the router can access the internet, the router logs will show the correct time stamps.


If you do it from ssh, better use uci rather than not-so-user-friendly vi.

uci set network.lan.ipaddr=''
uci commit network
service network restart

That is brilliant. many thanks.

1 Like

I'm just curious...

There's been others who've seen that warning (and even screenshot it too like you)...

Can you explain what about the warning doesn't communicate to proceed?

Normally I would not sweat it, but as I explained I had to pay someone to install OpenWRT on this BT router.

Normal install would involve two files downloaded from OpenWrt,

What I was not clear about was whether using the Apply Anyway would lose me access to the router and force me to send router away for re-install. If it had just been a normal install I would have pressed apply anyway.

I always try to avoid performing operations that pull the rug I am standing on from under my feet. An IP change does that, it is something very common so it is not surprising that many have the issue.

I imagine that the issue for most people is that they do not know the outcome of the Apply Anyway. It is a wording issue.

I will look at the two I did it with stock router if you like.

The thing about OpenWRT is that it is a product for grown ups, people who know they can fix it in other ways. Personally the 3 line code above was perfect.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.