Luci-app-nlbwmon not showing data

luci-app-nlbwmon not showing data in my OpenWrt-based router.

Below are the configurations

cat /etc/config/nlbwmon
config nlbwmon
        option netlink_buffer_size '524288'
        option database_limit '10000'
        option protocol_database '/usr/share/nlbwmon/protocols'
        option database_generations '7'
        option database_directory '/usr/nlbwmon'
        option database_interval '2021-01-01/1'
        option commit_interval '60s'
        option refresh_interval '30s'
        list local_network ''
        list local_network 'lan'

This directory /usr/nlbwmon is also created.
Please help me.
Thanks.

Is it used as router, or just used as access point (means no routing happens) ?

To my knowledge nlbwmon only works if routing happens:
Monitoring bandwidth with luci-app-nlbwmon and two routers on the same subnet - #2 by slh

it used as a router.

Can you write on the database directory ? On my system it is on /var/lib...

same problem :no_mouth:

What does the system log say about nlbwmon ?

Have you tried restoring default config file?

1 Like

yes but the problem is same.

Your answers are very detailed :wink:. So even if you set the accounting period to day of month, and the commit interval to 12h, and the database directory to /var/lib/nlbwmon, you still get no values ?

And you do have devices in your lan interface that do wan access ?

What Openwrt, luci-app_nlbwmon and nlbwmon version do you use on what hardware ?

2 Likes

I would start by deleting the empty local_network definition from the config file. That looks erroneous to me:
list local_network ''